Bug 6388

NativePDF - include custom font does not work 06 April, 2021

Ronnie Po
02 April, 2021
Product: PowerBuilder Category: DataWindow
Version: 2019 R3 Build: 2670
Classification: Issue Publishing: Public
Priority: P2
Status: Closed Reason: RESOLVED
Ken Guo @Appeon 06 April, 2021
#7
Hi Ronnie,

Thanks for your feedback.
We will close this ticket first and please feel free to open a new one if you encounter any problems.

Regards,
Ken
Ronnie Po 06 April, 2021
#6
(In reply to Ken Guo @Appeon from comment #5)
Hi Ronnie,

I'm glad to hear that you have resolved this problem. Can we close this
ticket?

Regards,
Ken
Hi Ken, Yes, please close the ticket. Thanks again.
Ken Guo @Appeon 05 April, 2021
#5
Hi Ronnie,

I'm glad to hear that you have resolved this problem. Can we close this ticket?

Regards,
Ken
Ronnie Po 05 April, 2021
#4
Hi Ken,

While trying to isolate the potential cause of the issue, I decided to uninstall and then re-install the custom fonts, and now the NativePDF document embeds the font as expected. Thanks for your efforts. This issue is resolved for me in my particular environment.
Ronnie Po 05 April, 2021
#3
(In reply to Ken Guo @Appeon from comment #2)
Appeon Testing Result

Hi Ronnie,

After I used the test steps and test cases you provided for testing, the
native pdf I saved was normal. see attached.

I suggest you test it on other machines to see if the problem exists.

My test environment:
Windows 10 64-bit version 1909
PowerBuilder 2019 R3 Build 2670
   
Regards,
Ken
Hi Ken, Thanks for the quick response. My environment includes a clean installation of PowerBuilder 2019 R3 Build 2670 in the following Windows environment. Edition Windows 10 Pro Version 20H2 Installed on ‎3/‎5/‎2021 OS build 19042.867 Experience Windows Feature Experience Pack 120.2212.551.0 I'm not sure what the issue is but I'll try to isolate the cause and will update this ticket.
Ken Guo @Appeon 05 April, 2021
#2
Appeon Testing Result

Hi Ronnie,

After I used the test steps and test cases you provided for testing, the native pdf I saved was normal. see attached.

I suggest you test it on other machines to see if the problem exists.

My test environment:
Windows 10 64-bit version 1909
PowerBuilder 2019 R3 Build 2670
   
Regards,
Ken
Ronnie Po 02 April, 2021
#1
Troubleshoot.zip (101KB)

*Phenomenon:
With this release of PowerBuilder, the option to include custom fonts with generated PDF files no longer works with a barcode font in my application.

Previous versions of PowerBuilder worked fine, including 2019 R2.

*Reproduce Steps:
Unzip the included file.
1. Install the included fonts FREE3OF9.TTF and FRE3OF9X.TTF
2. Open the workspace test.pdw and run the target application.

Remarks:
Please note that I am migrating a production application, and there is currently no workaround for displaying barcodes in the DataWindow reports.
OS:
Windows 10
Platform:
64-bit
Database Type:
Database Version: