Bug 5636

Source control - SCC menu items disabled 01 December, 2020

Kenny Verhoye
20 November, 2020
Product: PowerBuilder Category: PowerBuilder IDE
Version: 2019 R2 Build: 2328
Classification: Publishing: Public
Priority: P3
Status: Analyzing Reason:
Communication Status: Waiting for Customer
Chris Pollach @Appeon 25 November, 2020
#7
Hi Kenny;

 The SCC Log file looks OK.

 If it works OK form another PC then it sounds to me like maybe a mismatch in the .PBG control file as to what the PB IDE "thinks" the SCM has control over vs what WizSource thinks the object are registered to your project.

 Sounds like the best for now is to talk with Roland first. I'll await your further feedback before digging deeper on my side.

Regards ... Chris
Kenny Verhoye 25 November, 2020
#6
pbscc.log (3KB)

Hi Chris,

I haven't reached out to Roland yet, we will contact him. 
I've added the logfile as attachment, I don't see anything unusual. In the mean time I'm working on another machine with my account on which I don't have any issues.

Kind regards,
Kenny Verhoye
Kenny Verhoye 25 November, 2020
#5
pbscc.log (3KB)

Hi Chris,

I haven't reached out to Roland yet, we will contact him. 
I've added the logfile as attachment, I don't see anything unusual. In the mean time I'm working on another machine with my account on which I don't have any issues.

Kind regards,
Kenny Verhoye
Chris Pollach @Appeon 23 November, 2020
#4
Hi Kenny;

  Thank you for the connection confirmation. 

  In that same screen capture dialogue you just provided, please check the "Log All Activity" checkbox and try the SCM connection again. Afterwards, please attach the SCM log file to this ticket. Many thanks in advance!

  Have you contacted Roland at WizSource to see if he provides any further diagnostics from the SCM "Server" side?

Regards ... Chris
Kenny Verhoye 21 November, 2020
#3
source_control_ws_configuration.jpg (122KB)

Hi Chris,

I can connect to WizSource, I have added a screenshot in the attachment of the configuration.

Kind regards,
Kenny
Chris Pollach @Appeon 20 November, 2020
#2
Hi Kenny;

   Can you connect to the WizSource SCM software from the PB IDE's WorkSpace => "property" => "Source Control" dialogue's tab?

Regards ... Chris
Kenny Verhoye 20 November, 2020
#1
source_control_menu_items_disabled.jpg (142KB)

*Phenomenon:
I can't perform any of the source control options in the Powerbuilder IDE. They are just greyed out, I've added a screenshot of the context menu as attachment. The objects under a PBL shows a sign of out of sync, but I can't use option 'Get Latest Version' as it's greyed out. We use WizSource as source control. Thanks in advance for your reply!

*Reproduce Steps:


Remarks:
OS:
Windows 10
Platform:
32-bit
Database Type:
SAP ASE
Database Version:
16