Bug 4985

Making exe using cmd 05 October, 2020

Dipika Patel
27 July, 2020
Product: PowerBuilder Category: Other
Version: 2019 R2 Build:
Classification: Publishing: Public
Priority: P3
Status: Closed Reason: NO RESPONSE
armando herrera @Appeon 05 October, 2020
#6
Hi Dipika,

Based on our policy we have made 3 different attempts to contact you and determine if this ticket has been solved unfortunately, we did not get any response and we proceed to close it. 

If you consider this issue is still not fixed please, contact us.

Regards!
armando herrera @Appeon 14 September, 2020
#5
Hi Dipika, 

We have been trying to keep in touch with you to find out about the resolution of this issue, we would like to continue with our support but without more information, we are in the need to close it in the next 3 working days, according to our internal help support policy but please remember you can always open a new ticket.   

Best Regards.
armando herrera @Appeon 02 September, 2020
#4
Hi Dipika,

I'm just touching base with you about this ticket, please let us know if there is something else to support you with.

Regards!
armando herrera @Appeon 20 August, 2020
#3
Hi Dipika, 

I would like to check with you if the response provided has been was helpful enough to resolve your case. If so, can we proceed to close the ticket?.

Otherwise, do let us know if we can provide you with any further assistance and keep in mind that you are always welcome to open another ticket in case you need it.

Regards!
armando herrera @Appeon 31 July, 2020
#2
Hi Dipika,

Are you still facing this problem?. 
Is there anything else we can do to help with this case? 

Regards!
Ken Guo @Appeon 27 July, 2020
#1
Hi Dipika,

Firstly, make sure your application can be deployed successfully under PB IDE. Pay attention to the settings of the version number.

Secondly, I suggest you try to modify the version number. For example, change to 1,1,1,1 and then execute PBC to see if it is OK because there is a known bug in PBC: if the version number is too large and starts with 0, the issue appears easily. 


Regards,
Ken
Dipika Patel 27 July, 2020
*Phenomenon: We try to make exe using the cmd with the commands which are given for making exe for pb2019. But we are getting some error while building exe. When we try same commands with old code it is working fine. So can you please tell me where can be problem?


Command:
cmd /c pbc190.exe /d "<path of target>"
/o "<target exe>"
/r "<pbr file>"
/w n /f /m n /x 32 /bg y /p <software name> /cp <company name>
/de <software name> /cr <software copyright>
/v <version> /vn <version> /fv <version> /fvn <version> /ge 0 /pd yyy

*Reproduce Steps: 


Remarks:Is there any way that we can make exe automatically or any setup?
We get error "Creation of executable failed with a link error" in log file while making exe. And we don't get any attached error.
OS:
Windows 10
Platform:
64-bit
Database Type:
SAP SQL Anywhere
Database Version:
16