Bug 4089

Re: Autosize height columns with Display setting to 125% 13 January, 2021

Sivaprakash BKR
13 February, 2020
Product: PowerBuilder Category: PowerBuilder IDE
Version: 2017 R3 Build:
Classification: Publishing: Public
Priority: P3
Status: Reproducing Reason:
Communication Status: Waiting for Customer
armando herrera @Appeon 13 January, 2021
#19
Hi Sivaprakash,  

We have been trying to keep in touch with you to find out about the resolution of this issue, we would like to continue with our support but without more information, we are in the need to close it in the next 3 working days, according to our internal help support policy.

Please remember you can always open a new ticket.
    
Regards
armando herrera @Appeon 22 December, 2020
#18
Hi Sivaprakash, 

I'm just touching base with you about this ticket.  

Did we provide you with enough information to resolve this issue?. 
Please let us know if there is something else to support you with.  

Regards!
armando herrera @Appeon 02 December, 2020
#17
Hi Sivaprakash BKR,

Is there any update on this case, do you need any further help from our side? 

Regards!
Sivaprakash BKR 31 May, 2020
#16
armando herrera,
Will do once my assigned work is completed.  Hope it will take a week or 10 days.  
Thanks.
#15
Hi Sivaprakash, 

Can you try to take some screenshots of the steps you follow-up to catch the error? 

Regards!
Sivaprakash BKR 27 May, 2020
#14
Yes, this issues remains here.  Could not create any different reproducible PB test case than already provided.  The same settings, fields with different data produces the same issue here.  Could not understand what else to provide.  Will try something in my free time with different data to provide you.
#13
Hi Sivaprakash,
  
I'm just touching base with you about this ticket. 


Did we provide you with enough information to resolve this issue or have you resolved this issue?.


Please let us know if there is something else to support you with?. 


Regards!
#12
Hi Sivaprakash, 

I'm checking if you were able to reproduce this case?. 

Can we help you with something else?. 

Otherwise, please let us know if can we proceed to close this ticket?.

Keep in mind, that you are always welcome to open another ticket in case you need it.

Regards!
Mark Lee @Appeon 11 March, 2020
#11
Hi Sivaprakash,

Thanks for your feedback and for providing the test case!
Sorry that the Settings High DPI doesn’t work in Windows 7.

And yes, the transporttbranchname column (not the transport column you said) in dw_rep_reg_delivery doesn't display the full details in windows 10.
However, this is not the DPI settings issue. We found that the column doesn't have enough length for the content value. And it has the same result even we set the Display setting to 100%.
And we also checked the dw_rep_ledger and dw_rep_reg_delivery DataWindow, the test results in Windows 10 with 18 inches monitor are the same as that in Windows 10 with 27 inches monitor. 

So can you test it again or provide a new reproducible PB test case (with PBT / PBL) for us for more study. Thanks in advance.

Regards,
Mark Lee
Sivaprakash BKR 18 February, 2020
#10
https://www.appeon.com/developers/get-help/knowledgebase/ribbonbar-builder-c-class-importer-causing-ide-font-size-menus-and-toolbar-buttons-shrink-until-reopened.html

This setting is available in Windows 10 only.  I don't see the exact settings in Windows 7.  So couldn't check that in Windows 7.

Settings High DPI in windows made the correctly displayed datawindow also to miss it.   After the settings, the particulars column in dw_rep_ledger displays doesn't show the full details.   And no change in the other report as well.  So both reports got issues.
Sivaprakash BKR 18 February, 2020
#9
Autosize dw field_18022020.rar (18KB)

Mark Lee,
Just check the attached project, the datawindow to be checked is dw_rep_reg_delivery.  Just preview it, Transport column doesn't display the full data.

**********************
    2. Can you tell us how many inches is your screen and what is the display resolution in your OS system? 

I tried with the following.

Machine 1:    Windows 7, 22-inch monitor, resolution : 1920x1080 [Samsung monitor]
                          Both datawindows doesn't display full details
                         
Machine 2:    Windows 7, 18 inch monitor, resolution : 1366x768   [Compaq monitor]
                            dw_rep_ledger displays correctly,  
                            transport column in dw_rep_reg_delivery  doens't display in full.

Machine 3:    Windows 10, 22 inch monitor, resolution : 1920x1080 [Samsung monitor]
                            dw_rep_ledger displays correctly,  
                            transport column in dw_rep_reg_delivery  doens't display in full.
*************
Let me know if anything else you require.
Mark Lee @Appeon 17 February, 2020
#8
Hi Sivaprakash,

Thanks for reporting this problem.
1. We can't reproduce it on our side and I think maybe it is related to the actual Screen which you used.
2. Can you tell us how many inches is your screen and what is the display resolution in your OS system? If we have the same machine, we will test it.
3. We suggest you set the High DPI scaling to work it around, you can refer to the following link for detail:
https://www.appeon.com/developers/get-help/knowledgebase/ribbonbar-builder-c-class-importer-causing-ide-font-size-menus-and-toolbar-buttons-shrink-until-reopened.html

Regards,
Mark Lee
Sivaprakash BKR 15 February, 2020
#7
Chris,
Applied MR 1915 on top of 1880, skipping 1885, 1895.   The same issue prevails.  Now we could see the same issue in Windows 10 also, in other reports.
Sivaprakash BKR 14 February, 2020
#6
Autosize dw field_15022020.rar (79KB)

Attached another zip file.  This time the issue is in Win 10, whereas Win 7 displays correctly, both set to 125% in display setting.

I've attached two png files, images taken from the same report, run in both Win 7 & WIn 10.  

You could see MOOKAMBIGAI TRANSPORT - CALCUTTA (T1) in Win 7 and MOOKAMBIGAI TRANSPORT - CALCUTTA only in Win 10.  (T1) didn't get displayed in Win 10.  

Here the font size of MOOKAMBIGAI TRANSPORT - CALCUTTA (T1) is set to 8 [Palatino Linotype] where as other fields in that same row is set to 9 [Palatino Linotype].
Chris Pollach @Appeon 14 February, 2020
#5
Hi Sivaprakash;
  
  Thank you so much for that DataWindow test case!

  Since I do not have W7 installed any longer, I will now transfer this ticket over to the main Support / Engineering team to try and have them recreate this issue under one of their W7 testing environments.

  In the meantime, I noticed that you said that you were using build 1880 of PB2017R3. The current build is 1915 - which is the latest "MR" (Maintenance Release). You are welcome to try this MR in the mean-time to see if it might resolve your DW display issue.

Regards ... Chris
Sivaprakash BKR 14 February, 2020
#4
The current test case is to show that it appears in another report as well.
Sivaprakash BKR 14 February, 2020
#3
Autosize dw field.rar (11KB)

1.  Here it is, the simple Test case.   
          a.  Open the datawindow, dw_rep_ledger. 
          b.   View - Preview  [ Here you could see the full contents in the first row of Particulars column ]
          c.   File - Print Preview.   [The first row doesn't display the full contents.  The date value goes off ]

2.   Version 2017 R3 Build 1880

3.    We found this issue in Windows 7 only.   Works fine under Windows 10.

4.    This issue is there in both cases while running from IDE as well as from Exe.
Chris Pollach @Appeon 13 February, 2020
#2
Hi Sivaprakash;
  
Can you tell us ...

1) Would you have a simple Test Case PB App that you can attach to this ticket?
2) What build of PB2017R3 are you using?
3) Does this only happen in W7? Have you tried W10?
4) Is this issue only when running from the IDE, EXE or both?

Regards ... Chris
Sivaprakash BKR 13 February, 2020
#1
ToSupport-Autosizedwfield.rar (75KB)

*Phenomenon:
Full details not displayed in an auto size height field, When 
1.   Display settings in Windows set to 125%
2.   One field's property set to Autosize Height in a datawindow
3.   For a few values only.
4.   Set the band to Autosize height as well.

*Reproduce Steps:
1.  Switch to Medium - 125% in Display settings in control panel.   [ see: Display Setting.png ]
2.  Create a datawindow with a string field, set it to autosize height.
3.  Insert / Retrieve a lengthy value.  
4.  You could view full details when Display Settings is set to Small - 100%. [ See: In 100% Display setting.png ]
5.  Few values in that column didn't get displayed when the Display setting is set to Medium - 125%. [ See:  In 125% Display Setting.png ]
6.  This issue is found only in Windows 7 with display settings set to 125%.
7.  No issues in found so far in Windows 10.

Remarks:
1.  How to Switch Display Settings.   
          Select Control Panel - Personalization - Display 
           Under - 'Make it easier to read What's on your screen', one can switch to 100%, 125% or to 150%.    [ 

2.   So far no issues found while printing the same either to PDF or to Printers.  It prints in full. Only in the display, we found this issue.
OS:
Windows 7
Platform:
All
Database Type:
PostgreSQL
Database Version:
11