Bug 150

Just in Time Debugging 06 December, 2021

Niall Cronin
06 July, 2017
Product: PowerBuilder Category: IDE
Version: 2017 Build:
Classification: Sybase (legacy) bug Publishing: Public
Priority: P3
Status: Scheduling Reason:
Kai Zhao @Appeon 29 November, 2021
#3
Hi Niall, 

I have submitted this issue to the developers but they haven’t started to fix
it.

As for whether and when this issue can be fixed, I can't give you a specific
time at this moment as the fix for all bugs needs to be comprehensively
evaluated by the development team, and then the fix plan will be made according
to the priority, importance, risk and so on. I hope you can understand.


Regards,
Kai
Niall Cronin 26 November, 2021
#2
Any progress on this ? The issue still seems to be in PB2019. Just in time debugging. is way easier to use than the debugger.
Kai Zhao @Appeon 06 July, 2017
#1
HI,

Thanks for reporting this problem! We reproduced it on our end and will do further research to figure it out. We will keep you posted about the progress. 

BTW, PB 12.6 has same issue, and PB 12.5 work well.

Regards,
ZhaoKai
Niall Cronin 06 July, 2017
Just in Time Debugging not working

Add the stagement debugbreak( ) any where in a script. Turn on Just in time debugging in the system options. Then execute the script. The execution will stop at the point and revert to the debugger but when  I select F8 or click on Step IN the code continues to the End.


Remark:
OS:
Windows 7
Platform:
64-bit
Database Type:
Database Version: