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About This Book

Audience This book is for anyone using PowerBuilder® to build applications.
How to use this book This book provides information that enables you to start using
PowerBuilder:

e Part1 isan overview of the PowerBuilder development
environment.

e Part2 isa tutorial in which you build your first PowerBuilder

application.
Related documents This table lists the information in the PowerBuilder documentation set,
grouped by topic:
Topic Book Description
Installation Installation Guide Tells you how to install
PowerBuilder
Introduction Getting Started Introduces you to PowerBuilder
and use of and provides a tutorial you can step
PowerBuilder through to learn the basics
features
Programmer’s Users Guide Tells how to use the painters to
information build objects in PowerBuilder
Application Presents collections of techniques
Techniques for implementing many common
application features, along with
deployment details and tips for
cross-platform and international
development and deployment
Topic Book Description
DataWindow®™ Explains how to use DataWindows
Programmer’s Guide | in all the supported environments
(PowerBuilder, Web pages, Java)
and describes programming
techniques for accessing,
displaying, manipulating, and
updating data

Getting Started



Topic Book Description
NET targets Deploying Tells you how to create NET
information Components as .NET | assembly components and Web
Assemblies or Web services from PowerBuilder
Services nonvisual objects
Reference PowerScript® Describes syntax and usage
information Reference information for the PowerScript
language, including variables,
expressions, statements, functions,
and events
DataWindow Provides reference information for
Reference the DataWindow object, including
properties and functions for
expressions; syntax for accessing
properties and data; and reference
information for the methods,
events, and properties of
DataWindow controls and
DataStores in all supported
environments
Objects and Controls | Lists properties, events, and related
functions for PowerBuilder system
objects and controls
PowerBuilder Native | Contains how-to and reference
Interface (PBNI) information for using PBNI to
Programmer’s Guide | create PowerBuilder extensions
and Reference and interact with C++ applications
PowerBuilder Contains reference information for
Extension Reference | PowerBuilder extension modules
created with PBNI (such as
PBDOM, EJBClient, and Web
services)
Communicating | Connecting to Your Tells how to connect to a database

with a database

Database

from PowerBuilder; describes how
to set up, define, and manage
database connections accessed
through the ODBC interface or one
of the native database interfaces

Connection
Reference

Includes procedures for preparing,
defining, establishing, maintaining,
and troubleshooting your database
connections

PowerBuilder



About This Book

Other sources of
information

If you need help

Getting Started

Use the Appeon Product Manuals Web site to learn more about your product.
To access the PowerBuilder Product Manuals Web site, go to Product Manuals
at https://www.appeon.com/developers/library/product-manuals-for-pb.

The installation guide in PDF format can be accessed from the PowerBuilder
installation package. The release bulletin can be access from Online Help at
https://www.appeon.com/support/documents/appeon_online_help/pb2017/releas
e _bulletin_for_pb.

All customers are entitled to standard technical support for reproducible
software defects. You can open a standard support ticket at the Appeon
support site: https://www.appeon.com/standardsupport/ (login required).

If your organization has purchased a premium support contract for this
product, then the designated authorized support contact(s) may seek
assistance with your technical issue or question at the Appeon support site:
https://support.appeon.com (login required).


https://www.appeon.com/standardsupport/
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PART 1 Welcome to PowerBuilder

This part is an overview of the PowerBuilder development
environment.






CHAPTER 1

About this chapter

Contents

For more information

Introduction to PowerBuilder

This chapter introduces the PowerBuilder development environment,
which you use in the tutorials in Parts 2-4. It also describes the building
blocks of a PowerBuilder application.

Topic Page
What PowerBuilder is 3
The PowerBuilder environment 5
PowerBuilder objects 10

For a more detailed description of the PowerBuilder development
environment, see the PowerBuilder Users Guide.

What PowerBuilder is

What's in a PowerBuilder
application?

PowerBuilder applications
are event driven

Getting Started

PowerBuilder is an enterprise development tool that allows you to build
many types of applications and components. It is one of a group of
Appeon products that together provide the tools to develop client/server,
multitier, and Internet applications.

A PowerBuilder client application can contain:

A userinterface Menus, windows, and window controls that users
interact with to direct an application.

e Application processing logic Event and function scripts in which
you code business rules, validation rules, and other application
processing. PowerBuilder allows you to code application processing
logic as part of the user interface or in separate modules called custom
class user objects.

In a client application, users control what happens by the actions they take.
For example, when a user clicks a button, chooses an item from a menu,
or enters data into a text box, one or more events are triggered. You write
scripts that specify the processing that should happen when events are
triggered.



What PowerBuilder is

PowerScript language

PowerScript functions

Object-oriented
programming with
PowerBuilder

Multitier applications

Windows, controls, and other application components you create with
PowerBuilder each have a set of predefined events. For example, each button
has a Clicked event associated with it and each text box has a Modified event.
Most of the time, the predefined events are all you need. However, in some
situations, you may want to define your own events.

You write scripts using PowerScript, the PowerBuilder language. Scripts
consist of PowerScript commands, functions, and statements that perform
processing in response to an event.

For example, the script for a button’s Clicked event might retrieve and display
information from the database; the script for a text box’s Modified event might
evaluate the data and perform processing based on the data.

The execution of an event script can also cause other events to be triggered. For
example, the script for a Clicked event in a button might open another window,
triggering the Open event in that window.

PowerScript provides a rich assortment of built-in functions that can act on the
various components of your application. For example, there is a function to
open a window, a function to close a window, a function to enable a button, a
function to update the database, and so on.

You can also build your own functions to define processing unique to your
application.

Each menu or window you create with PowerBuilder is a self-contained
module called an object. The basic building blocks of a PowerBuilder
application are the objects you create. Each object contains the particular
characteristics and behaviors (properties, events, and functions) that are
appropriate to it. By taking advantage of object-oriented programming
techniques such as encapsulation, inheritance, and polymorphism, you can get
the most out of each object you create, making your work more reusable,
extensible, and powerful.

PowerBuilder lets you build applications that run in a distributed computing
environment. A multitier application lets you:

*  Centralize business logic on servers, such as JBoss, WebLogic,
WebSphere, or COM+

«  Partition application functions between the client and the server, thereby
reducing the client workload

*  Build scalable applications that are easy to maintain

For information about multitier applications, see the sections on distributed
application techniques in Application Techniques.

PowerBuilder



CHAPTER 1 Introduction to PowerBuilder

Database connectivity

Online Help and
documentation

PowerBuilder provides easy access to corporate information stored in a wide
variety of databases. Data can be accessed through the PowerBuilder ODBC or
JDBC interfaces, through a middle-tier data access server like the SAP
Direct CONNECT™ server, or through a native or direct connection to a
database.

For information on database connectivity, see Connecting to Your Database.

PowerBuilder online Help can be accessed using Help buttons and menu items,
or by selecting the F1 key from anywhere in PowerBuilder. There are jumps in
several places from the online Help to books in HTML format. Manuals are
also available on the Appeon Web site.

The PowerBuilder environment

Workspaces and
targets

Getting Started

In PowerBuilder, you work with one or more targets in a workspace. You can
add as many targets to the workspace as you want, open and edit objects in
multiple targets, and build and deploy multiple targets at once.

A PowerBuilder target can be one of several types:
e Application target A client/server or multitier executable application.

e .NET target A .NET target that you can use to deploy nonvisual custom
class components as .NET assemblies or Web services.

The first lesson in the tutorial shows you how to create a workspace and an
Application target. Later you learn how to create .NET targets.



The PowerBuilder environment

The development
environment

System Tree

Clip window

Output window

Painters

Wizards

When you start PowerBuilder, it opens in a window that contains a menu bar
and the PowerBar at the top, and the System Tree and Clip windows on the left.

-
ODE [PBE Demc DB V2017] - PowerBuilder

t

File Run Tools Window Help
PO R B (A | A ] i el
BXY@MO | EHINSEF @@

wanghui@

s|EEEm@ s % R

x|

(Mo Workspace)

(ol =l x] ]

MName Preview Description

Ready

The System Tree window can serve as the hub of your development activities.
You use it to open, run, debug, and build your targets, and for drag-and-drop

programming.

The Clip window lets you store code fragments that you use frequently.

The output of a variety of operations (migration, builds, deployment, project
execution, object saves, and searches) displays in an Output window at the
bottom of the main window. The Output window opens automatically when
output information is generated, but you can open the Output window at any
time by clicking the Output window toolbar button.

Once you have created a workspace and a PowerScript target, you build the
components of the target using painters. Painters provide an assortment of tools
for enhancing and fine tuning the objects in a target.

PowerBuilder provides a painter for each type of object you build. For
example, you build a window in the Window painter. There you define the
properties of the window and add controls, such as buttons and text boxes.

Wizards simplify the creation of applications, objects, components, Web sites,

and Web pages.

PowerBuilder



CHAPTER 1 Introduction to PowerBuilder

Design-time controls

To-Do List

Browser

PowerBar

PainterBar

StyleBar

Getting Started

Design-time controls (DTCs) create basic HTML and scripts from information
you provide in property sheets. The property sheets display when you drop a
DTC on a Web page in the HTML editor.

The To-Do List displays a list of development tasks you need to do for the
current target. Entries on the To-Do list can be created automatically by most
PowerBuilder wizards. You can also type in entries or import them from a text
file and then link them to a task that you want to complete.

The Browser lets you see all the objects, methods, variables, and structures that
are defined for or available to your PowerScript target. Objects in the Browser
can be displayed in alphabetic or hierarchical order. The Browser displays
methods with their complete prototypes (signatures), which include the
datatypes of all arguments and return values.

The PowerBar displays when you begin a PowerBuilder session. The
PowerBar is the main control point for building PowerBuilder applications.
You can use the New, Inherit, or Open buttons on the PowerBar to open all of
the PowerBuilder painters. From the PowerBar, you can also open the Browser,
debug or run the current application, and build and deploy the workspace.

When you open a painter or editor, PowerBuilder displays a new window that
has a workspace in which you design the object you are building. PowerBuilder
also displays one or more PainterBars with buttons that provide easy access to
the tools available in the painter or editor. For example, here is the PainterBar
for the DataWindow painter.

B a>/A-|xBhellz ¥|E x

The StyleBar displays when you open any painter that can contain text
controls, such as the Window painter. Using buttons on the StyleBar, you can
modify text properties such as the font and point size.

] I Tahoma -m CBl7 V==




The PowerBuilder environment

PowerTips

Customizing the
environment

PowerBar buttons

When you leave the mouse pointer over a button for a second or two,
PowerBuilder can display a brief description of the button (a PowerTip). The
ability to display PowerTips is toggled on and off by selecting the Show
PowerTips menu item in any toolbar pop-up menu.

r

zs| ODB [PB Demc DB V2017] - PowerBui

File Run Tools Window Help
BEI&] | A fe] E

Workspace)

You can also include brief descriptive texts on all toolbar buttons by selecting
ShowText from any toolbar pop-up menu.

In addition to displaying text in toolbar buttons, you can move the toolbars
around, add new toolbars, and customize existing ones. You can add buttons
for opening painters and performing other activities.

You can also rearrange the System Tree, Clip, and Output views, set up custom
layouts for each painter, choose whether PowerBuilder opens your last
workspace at start-up with or without painters and editors open, customize
shortcut keys, and change the colors and fonts used in scripts.

The buttons in the PowerBar give you quick access to the most common
PowerBuilder tasks:

PowerBuilder



CHAPTER 1 Introduction to PowerBuilder

Table 1-1: Buttons in the PowerBar

Button Use to
t_‘ Create new workspace, target, component, or other object, or open a
=+ tool.
N
%. Inherit from menu, user object, or window.
Inherit

Open an existing application, DataWindow, function, menu, pipeline,
project, query, structure, user object, window, HTML page, HTML

Open frame, style sheet, or script file.
Om Preview a window or DataWindow object.
o=
Previews
= Show or hide the System Tree window.
SysTree
Show or hide the Output window.
Ly
[a - T
o Move to the next line in the Output window.
e
" Move to the previous line in the Output window.
!
— Display a list of development tasks you need to do. These can be self
. — entered or entered automatically by PowerBuilder wizards.
io-Usa st
= View object information (such as object properties or global variables)
_ and copy, export, or print it.
SrowEer
% Show or hide the Clip window.
Chp
., Create and maintain libraries of PowerBuilder objects.
Library
B Specify how to connect to a database.
D& Prf
Maintain databases, control user access to databases, and manipulate
_ data in databases.
Lrianese
T Edit a file.
Ecit

Getting Started 9



PowerBuilder objects

Button Use to
Start an incremental build of the workspace.
L Baild
m Start a full build of the workspace.
F. Biuild
Deploy the workspace.
Dreglay
&) When a series of operations is in progress, such as a full deploy of the
N workspace, skip to the next operation.
20D
=) Stop a build or deploy operation or series of operations.
Soo
Debug the current target.
D=boug
4 Select a target and debug it.
Sl Dbg
P Run the current target.
ey
Run
e Select a target and run it.
In,
Sal Fun
I Exit from PowerBuilder.
=

PowerBuilder objects

The basic building blocks of a PowerScript target are objects:

10 PowerBuilder



CHAPTER 1 Introduction to PowerBuilder

Application object

Getting Started

Table 1-2: Basic building blocks of a PowerScript target

Object Use

Application Entry point into an application

Window Primary interface between the user and a PowerBuilder
application

DataWindow Retrieves and manipulates data from a relational database or
other data source

Menu List of commands or options that a user can select in the

currently active window

Global function

Performs general-purpose processing

Query

SQL statement used repeatedly as the data source for a
DataWindow object

Structure Collection of one or more related variables grouped under a
single name

User object Reusable processing module or set of controls, either visual or
nonvisual

Pipeline Reproduces data within a database or across databases

Project Packages application for distribution to users

These objects are described in more detail in the sections that follow.

The Application object is the entry point into an application. It is a discrete
object that is saved in a PowerBuilder library (PBL file), just like a window,
menu, function, or DataWindow object.

The Application object defines application-level behavior, such as which fonts
are used by default for text, and what processing should occur when the
application begins and ends.

When a user runs the application, an Open event is triggered in the Application
object. The script you write for the Open event initiates the activity in the
application. When the user ends the application, the Close event in the

Application object is triggered.

The script you write for the Close event typically does all the cleanup required,
such as closing a database or writing to a preferences file. If there are serious
errors during execution that are not caught using PowerBuilder’s exception

handling mechanism, the Application object’s SystemError event is triggered.

11
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Windows

12

Figure 1-1: Application life cycle

User =tarts application

Initial weind o opens
and ervironment set up

Liser imeracls
with wémd'one

Cloew event in gooication offect is dnggemd

N‘@tem T

Application runs: other
windawes apen and

clos e, data i retrieved
from the database, written
to the database, . ..

SystemErrar event in
applization object & triggered

U=ser ends application

Wrindowe close and

cleanup done

A window consists of:

A::faw Emor

Close ewerd in goolicaion ol ect iz figgemnd

Windows are the primary interface between the user and a PowerBuilder
application. Windows can display information, request information from a
user, and respond to the user’s mouse or keyboard actions.

Properties that define the window’s appearance and behavior (for
example, a window might have a title bar and a Minimize box)

Events triggered by user actions

Controls placed in the window

PowerBuilder



CHAPTER 1 Introduction to PowerBuilder

DataWindow objects

Getting Started

Windows can have various kinds of controls, as illustrated in the following
picture:

&5 Progress Bar Controls = | B s
Mave the Track Bar to zoom the datanindow
Options
Sl T 3 = Horizontal Tick Posiian
Description Title ) = S
Functions - Extemnal Display system informaSystem Informalic Page Size 5 z - TDE
windaw Controls This example shows a Sales Order Listy Start Position: 100 = @ Boltom
DataStores This example shows a Sales Order Listy Min Pasition: 10 = O Neither
User Objects This Window uses an Anslog Clock Mas Position 00 =
' = Vertical Tick Position
Miscellaneous This example s vari Perfomance Ber i S 5 =
(= ||Datawindows - Events & Fun This sxample is & simp Reporting With D i O Left & Right
" Tick Frequency: & = Left
User Objects & User Object that lool Drop Down Caler z A
i
Datawindows - Updating  This iz a simple addurAuta Increment - [ Shaws Slides N Ejthe.
Datawindows - Retrieval  Shows how to cancel Cancel Retieval -
Object Communication Shows how to cancel Cancel Relrieval
Drag & Diap Select a department ai Change Emplope
Diataw/indows - Events & Furn digital elack, bult us Digital Clock
DiatdWindaws - Events & Fun This example fists all e1Computed Fields

On the left of the window is a DataWindow control with horizontal and vertical
trackbars. On the right is a group box that contains static text controls
(containing descriptive labels), edit mask controls (as they appear when the
SpinControl property is on), a check box, and two smaller group boxes with
radio buttons. Under the main group box is a command button.

A DataWindow object is an object that you use to retrieve and manipulate data
from a relational database or other data source (such as an Excel worksheet or
dBASE file).

Presentation styles DataWindow objects also handle the way data is
presented to the user. You can choose from several presentation styles. For
example, you can display the data in Tabular or Freeform style.

13
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14

There are many ways to enhance the presentation and manipulation of data in
a DataWindow object. For example, you can include computed fields, pictures,
and graphs that are tied directly to the data retrieved by the DataWindow.

El DataWindow - d_sales_report [_ O] =]
Sales Summary Report 419101 =
October-December, 2000 Page dof 4

Product Product  Product Quantity
1D Hame Description Sold  Dollars Sales Summary
300 TeeShit  Tank Top 2384 SN276 | zipped sweashi
301 TeeShit  Veneck 2388 $33432 Wool eap
302 Tee Shirt Crew Neck 245 $30,072 Monede
400 Baseball Cap  Cotton Cap 3278 §29,502 Tank Top
Flastic Visor
401 Baseball Cap wiool cap O BMO | e
s00 visor Cloth visor 2652 $16,554 Crew Nek
s01 visor Plastic Visor 2508 $17556 Cotton Shars

Cotton Cap
Cloth Visor

600 Sweatshirt Hooded Swestshit 3060 §73,440
601 Sweatshirt Tipped Sweatshit 2724 §65376
700 Shorts Cotton Shorts 4536 $68,040

0 20000 40000 60000 &0000
Dollar

14 | Llﬂ

Display formats, edit styles, and validation You can specify how to
display the values for each column, and you can validate data entered by users
in a DataWindow object. You do this by defining display formats, edit styles,
and validation rules for columns.

For example:

¢ Ifacolumn can take only a small number of mutually exclusive values,
you can have the data appear as radio buttons in a DataWindow so users
know what their choices are.

1] Dept Hame Status Salary o
I—
102 1an ‘whitney | Fran = Aclive $45.700.00
0 Teminated
) On Leave
105 100 Cobb, Matthew & Active $62,000.00
0 Teminated
) On Leave
129 200 Chin, Phiip & Active $38,500.00
0 Teminated
) On Leave -
14 | LlJ
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»  Ifthe data includes phone numbers, salaries, and dates, you can format the
display to suit the data.

B DataWindow - d_formats M=l E3
11} Hame Phone Salary Start Date o
=
102 whitney [617) 555-3985 $45,700.00 02/26/96
105  Cobb [617) 555-3840 $62.000.00 07402496
129 Chin [404] 555-2341 $38.500.00 08/04/96
148 Jordan [617) 555-7835 $51.432.00 1040496
160 Breaul [617) 555-3093 $57.430.00 12116/96
14 | LIJ

*  Ifacolumn can take numbers only in a specific range, you can specify a
simple validation rule for the data. This can spare you from writing code
to make sure users enter valid data.

Web DataWindow This technique is not recommended and is considered to
be obsolete. The ability to use this technique has been retained for backward
compatibility.

Menus Menus are lists of items that a user can select from a menu bar for the active
window. The items on a menu are usually related. They provide the user with
commands (such as Open and Save As on the PowerBuilder File menu) or
alternate ways of performing a task (for example, the items on the Edit menu
in the Window painter correspond to buttons in the PainterBar).

You can select menu items with the mouse or with the keyboard, or use
accelerator (mnemonic access) keys defined for the items. You can define your
own keyboard shortcuts for any PowerBuilder menu item from a dialog box
that you open with the Tools>Keyboard Shortcuts menu item.

A drop-down menu is a menu under an item in the menu bar. A cascading menu
is a menu that appears to the side of an item in a drop-down menu.

MW Untitled

Current Row
All Rows

Cancel
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Global functions

Queries

Structures
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Each choice in a menu is defined as a Menu object in PowerBuilder. The
preceding window shows two Menu objects on the menu bar (File and Data),
three Menu objects on the drop-down Data menu (Update, Delete, and Cancel),
and two Menu objects on the cascading menu beside Update (Current Row and
All Rows).

PowerBuilder lets you define two types of functions:

*  Object-level functions are defined for a particular type of window, menu,
or other object type and are encapsulated within the object for which they
are defined. These are further divided into system functions (functions that
are always available for objects of a certain object class) and user-defined
functions.

*  Global functions are not encapsulated within another object, but instead
are stored as independent objects.

Unlike object-level functions, global functions do not act on particular
instances of an object. Instead, they perform general-purpose processing
such as mathematical calculations or string handling.

A query is a SQL statement that is saved with a name so that it can be used
repeatedly as the data source for a DataWindow object. Queries enhance
developer productivity, because they can be coded once but reused as often as
necessary.

A structure is a collection of one or more related variables of the same or
different data types grouped under a single name. In some languages, such as
Pascal and COBOL, structures are called records.

Structures allow you to refer to related entities as a unit rather than individually.
For example, you can define the user’s ID, address, access level, and a picture
(bitmap) of the employee as a structure called user_struct, and then refer to this
collection of variables as user_struct.

There are two kinds of structures:

e Object-level structures are associated with a particular type of object such
as a window or menu. These structures can always be used in scripts for
the object itself. You can also choose to make the structures accessible
from other scripts.

e  Global structures are not associated with any object or type of object in an
application. You can declare an instance of the structure and reference it in
any script in an application.

PowerBuilder
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User objects

Libraries

Projects

Getting Started

Applications often have features in common. For example, several applications
might have a Close button that performs a certain set of operations and then
closes the window, or they might have DataWindow controls that perform the
same type of error checking. Several applications might all require a standard
file viewer.

If you find yourself using the same application feature repeatedly, you should
define a user object. You define the user object once and use it as many times
as you need.

User objects can be visual or nonvisual. They can be further divided into
standard or custom user objects. Standard user objects, whether visual or
nonvisual, are system objects that are always available with PowerBuilder. You
can also use controls for external visual objects that were created outside
PowerBuilder. The main types of user objects are:

¢ Visual user objects These are reusable controls or sets of controls that
have a consistent behavior. For example, a visual user object could consist
of several buttons that function as a unit. The buttons could have scripts
associated with them that perform standard processing. Once the object is
defined, you can use it as often as you need.

¢ Nonvisual user objects These are reusable processing modules that
have no visual component. Standard class user objects inherit events and
properties from built-in system objects. You typically use nonvisual
objects to define business rules and other processing that acts as a unit.

For example, you might want to calculate commissions or perform
statistical analysis in several applications. To do this, you could define a
custom class user object. To use a custom class user object, you create an
instance of the object in a script and call its functions.

Custom class user objects, which define functions and variables, are the
foundation of PowerBuilder multitier applications. This is because you
typically use nonvisual components for applications that are run on a
server.

You save objects, such as windows and menus, in PowerBuilder libraries (PBL
files). When you run an application, PowerBuilder retrieves the objects from
the library. Applications can use as many libraries as you want. When you
create an application, you specify which libraries it uses.

You can create Project objects that build executable applications.

17
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CHAPTER 2 About the PowerBuilder Tutorial

About this chapter This chapter describes what you will do in the PowerBuilder tutorial and
how to get set up for it.

Contents

Topic Page
Learning to build a client/server application 19
How you will proceed 20
Setting up for the tutorial 22

Learning to build a client/server application

The PowerBuilder tutorial is divided into parts. The first part of the
tutorial is a set of eleven exercises in which you build a Multiple
Document Interface (MDI) database application for a fictional company
called SportsWear, Inc. The application allows you to retrieve customer
and product information from the database and perform insert, update, and
delete functions against the customer and product data.

Getting Started 19



How you will proceed

Customer and Product
windows

Login window

The MDI application includes two windows that provide access to the
Customer and Product tables in the Demo database.

Product Description-fankTop ]
Size:

%, Maintain Customersil (=@ ][=]
‘Customer First Name Last Name Company Name ‘
j0)
o 101 Michaels Devlin The Power Group
102 Beth Reiser AMF Corp.
103 Erin Niedringhaus Darling Assocates
104 Meghan =
105 Lar #, Maintain Products1 L [E=8 Mo =
108 Paul Product  Product Name Product Description Unit Price o
D
Cistomer 17— 101 b L HE Tee shin Tank Tap $9.00 E
haels 301 Tee Shirt V-neck §14.00
Frst Name: Mchoel | 302 Tee Shit Crew Neck $14.00
Last Name: Devlin 400 Baseball Cap Cotton Cap $9.00
Company Name: The Power 401 Baseball Cap Waool cap $10.00
Phone Number: (201) 555-8¢
Product 1D: Color: |White :
Product Name: Quanmy:

Unit Price: 59 00

These windows are master/detail windows: each allows you to display a master
list of rows in a particular table and also see detailed information for each row
in the table. For example, the top half of the Maintain Products window

contains a list of products with a pointer to a single product; the bottom half of
the window displays extra detail for the current product.

The MDI application also includes a login window that allows you to connect
to the database at start-up time.

& Welcome

(S

User ID:

Password:

How you will proceed

Table 2-1 describes what you will do in each of the tutorial lessons.

20

diy, Welcome to SportsWear, Inc.

PowerBuilder



CHAPTER 2 About the PowerBuilder Tutorial

Table 2-1: Tutorial lessons and what you will accomplish

Lesson

What you will do

1

Start PowerBuilder; begin familiarizing yourself with the
development environment; use the Workspace wizard and the
Template Application wizard to create an Application object,
windows, and menus in a PowerBuilder workspace and target.

Explore the PowerBuilder environment and customize the workspace.

Create a login window to allow the user to enter database connection
parameters (user ID and password).

Connect to the database using the Transaction object and user-entry
parameters; see how database profiles are defined in the PowerBuilder
environment.

Change the base sheet window by adding master and detail
DataWindow controls; add scripts to allow users to retrieve data and
perform insert, update, and delete operations against the database.

Modify the frame menu and create a new sheet menu for the
application.

Build the DataWindow objects that retrieve customer and product
information, then add them to the Customer and Product windows.

Run the tutorial application in debug mode; see how to set breakpoints
in scripts, step through the code, and display the contents of variables.

10

Create a new window to test exception handling in PowerBuilder.

11

How long it will take

Getting Started

Create an executable file that you can use to run the application outside
the PowerBuilder development environment.

You can do all the tutorials in about six hours, or you can stop after any lesson
and continue at another time.

If you are interrupted
You can save your work and exit PowerBuilder at any time. When you are

ready to continue, you can open the tutorial workspace and continue where you

left off.
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Setting up for the tutorial

What you will learn

Client/server
applications

This tutorial will not make you an expert in PowerBuilder. Only experience
building real-world applications can do that. It will give you hands-on
experience, though, and provide a foundation for continued growth.

You will learn basic PowerBuilder techniques and concepts, including those
listed in Table 2-2:

Table 2-2: Features demonstrated in the PowerScript tutorial
How to use the To

Application painter | Define an Application object and application-level scripts

Window painter Create SingleLineEdit controls, StaticText controls,
CommandButton controls, DataWindow controls,
window-level scripts, and control-level scripts

DataWindow Define selection and display options

painter

Menu painter Define menus, menu items, accelerators, and shortcut keys

Layout view Design how the windows, menus, and DataWindows will look
when you run the application

Script view Define scripts for applications, windows, window controls,
and menus

Debugger Identify logic errors that may cause problems when you run the
application

Project painter Create an executable version of an application

Setting up for the tutorial

Connecting to a
database

22

Before you start the tutorial, you need to make sure that you can connect to a
database and that you have the tutorial files.

The tutorial uses the PB PB Demo DB V2017 database that installs with
PowerBuilder. This is an SQL Anywhere database and requires the SAP SQL
Anywhere engine.

If you do not already have SQL Anywhere on your local machine or server, you
must install it now. You can download and install it from the SAP website. If
you installed PowerBuilder in a nondefault location, you must make sure that
the odbc.ini registry entry defining the Demo Database as a data source points
to the correct location of the SQL Anywhere engine.

PowerBuilder
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The Tutorial directory

The Tutorial\Solutions
directory

Getting Started

The PowerBuilder installation directory includes a Tutorial folder that contains
all the files you need to work with the tutorial. The installation also creates a
copy of that folder under your user profile directory. You will work with the
copy of the Tutorial folder, not the original source. The 7uforial folder locates
in drive:\Users\user\Documents\Appeon\PowerBuilder 17.0\Tutorial on
Windows:

The Tutorial folder includes the following files:
Table 2-3: Files required by the PowerScript tutorial

File Contents

tutor _pb.pbl PowerBuilder library that contains several objects that you
use in the tutorial

tutsport.bmp A bitmap

tshirtw,jpg A graphic

tutorial.ico An icon

When you have finished the tutorial, you can delete the files.

The Tutorial\Solutions directory contains a PowerBuilder library called
pbtutor.pbl that contains all the objects and scripts that you create in the first
part of the tutorial, as well as workspace and target files. You can use this
solutions library as a reference while you complete the first part of the tutorial.

23
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PART 2

Building a Client/Server
Application

This part is a tutorial that shows you how to get started
with PowerBuilder. It provides step-by-step instructions for
creating a simple database application.






LESSON

Getting Started

1

Starting PowerBuilder

This lesson provides the information you need to start PowerBuilder and
create an application.

In this lesson you:

Create a new workspace

Create a target

Specify an icon for the application
Change the size of the main window

Run the application

How long does it take?
About 20 minutes.
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Create a new workspace

Create a new workspace

28

Where you are

> Create a new workspace
Create a target
Specify an icon for the application
Change the size of the main window
Run the application

The workspace is where you build, edit, debug, and run PowerBuilder targets.
You can build several targets within a single workspace.

Now you start PowerBuilder and create a new workspace.

First read the Release Bulletin for this release
Any last-minute items are documented in the Release Bulletin. To make sure

you have all the files necessary to complete the tutorial, see Setting up for the
tutorial on page 22.

1 Double-click the PowerBuilder icon (representing PB170.EXE) in the
Appeon>PowerBuilder 17.0 path
or
Select All Programs>Appeon>PowerBuilder 2017>PowerBuilder 2017
from the Windows Start menu.

The Welcome to PowerBuilder dialog box displays.

Welcome to PowerBuilder fz|

PowerBuilder can be used to create Windows client applications,
server components, JNET Web and Windows Forms, JMET Web
services and assemblies, and much more,

Each component of component colleckion is skored as a target.
Multiple targets are grouped together as & workspace.

would vou like ka:

Create a new workspace and a new target

Create a new wotkspace and add an existing karget

Create just a new workspace
Open an existing workspace

Close this dialog boce

[ 5how this dislog box at startup with no workspace
Reload last waorkspace at startup

PowerBuilder



Lesson 1  Starting PowerBuilder

Getting Started

The Welcome to PowerBuilder dialog box allows you create a new
workspace and add a new target or an existing target to the workspace.

If you do not want PowerBuilder to display the dialog box again
You can leave the “Show this dialog box at startup with no workspace”

check box unchecked to keep PowerBuilder from displaying the welcome
dialog box every time you start PowerBuilder. Select the “Reload last
workspace at startup” check box to load the most recently used workspace
each time you start a PowerBuilder session. Then click “Close this dialog
box.”

The PowerBuilder development environment displays.

Ifthis is the first time you are opening PowerBuilder on your machine, you
see only a top-level entry in the System Tree to indicate that no workspace
is currently open. Otherwise, the System Tree might show a workspace
with targets and objects in it.

IS

‘ODEB [PB Deme DB V2017] - PowerBuilder =

File Run Tools Window Help wanghui@appeor
GREEEN A A cEE RO ¥ PR Eem ST R B
BXQBED r @2 ME GO0

=l

2] (No Workspace)

(8l P =H x| |4

Name Preview Description

Ready

Select New from the File menu
or
Click the New button in the PowerBar.

The Workspace page of the New dialog box displays.
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Create a new workspace

30

PowerBuilder displays the page of the New dialog box that was used
before the dialog box was last closed. In this exercise, make sure that the
Workspace page of the New dialog box displays.

I'New' I @1

Target: {Not Applicable)

Workspace | Target | Library | PB Object | DataWindow [ Database [ Project | Toal |

<
—_

'Workspace |

Select Workspace from the Workspace page of the New dialog box.
Click OK.

The New Workspace dialog box displays.

Choose the tutorial folder

If you have created a workspace before, the dialog opens to the location of
the most recently-used workspace. For this new workspace, change the
location to the path described in the next paragraph.

If this is your first workspace, the New Workspace dialog box opens to
<drive>:\Users\<username>\Documents. Navigate from this point to
Appeon\PowerBuilder 17.0\Tutorial. The solutions for the tutorial are in
the Solutions subfolder, but you will create your own solutions as you
work your way through the tutorial.

PowerBuilder
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5 Type MyWorkspace in the File name text box.

13 Mew Workspace @
Savein: . Tutorial & @ 3 BF i
L Name Date Type Size Tags
el . Solutions 2017/3/711:04  File folder

Recent Places

Desktop L‘\’

=

Libraries

LY

-

6 Click Save.

The New Workspace dialog box closes and the workspace you created
appears as the first item in the System Tree.
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Create a target

32

Where you are
Create a new workspace

> Create a target
Specify an icon for the application
Change the size of the main window
Run the application

Now you create a new target using the Template Application wizard. Based on
the choices you make, the Template Application wizard creates precoded
events, menus, windows, and user objects in addition to the application object.

1 Select New from the File menu and click the Target tab
or
Right-click MyWorkspace in the System Tree, select New from the
pop-up menu, and click the Target tab.

The Target page of the New dialog box displays.
r New ﬂ‘

[
by

Target: (Mot Applicable)

| workspace | Target |Library | PB Object | DataWindow | Database [ Project | Tool |

o v I < e

Application Template Existing Application .MET Web Service  .MET Assembly
Application

2 Select the Template Application icon and click OK.

The Template Application wizard displays. The first page of most wizards
explains what the wizard is used for. As you step through the wizard, you
can press F1 to get Help on most fields.

3 Click Next until the Specify New Application and Library page
displays.
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4 Type pbtutor in the Application Name text box.

The wizard automatically assigns file names to a library and target that use
this application name. It assigns the library a PBL extension and the target
a PBT extension.

5 Click Next.

The Specify Template Type page displays. The MDI Application with
Microhelp radio button is selected. You will create an MDI template
application, so you do not need to change this selection.

About MDI
MDI stands for multiple document interface. In an MDI application, the

main window for the application is called the MDI frame. Using the MDI
frame menu bar, you can open additional windows known as sheet
windows that display inside the frame window.

6 Click Next 4 times until the Name Individual Sheets page displays.

In this tutorial you accept the default application type, library search path,
frame and frame menu names, sheet menu and manager service, and MDI
base sheet.

If you have clicked Next too many times
You can use the wizard’s Back button to navigate back to the correct

wizard page.

7 On the Name Individual Sheets page, type w_customers for Sheet 1,
w_products for Sheet 2, and clear the Sheet 3 text box.
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34

PowerBuilder will generate two windows based on the default basesheet
(w_pbtutor_basesheet), one for customers and one for products. You will
add a third sheet window later—in the lesson on exception handling.

Name Individual Sheets

A=)

The wizard will create three sheets inherited from
w_pbtutor_basesheet. Enter the names for these sheets here, or
dear the field to eliminate a sheet.

Sheet 1:

w_customers

Sheet 2:
w_products

Sheet 3:

< Back ][ Mext = ][ Cancel

Click Next.

Type Maintain Customers as the display name for Sheet 1.
Type Maintain Products as the display name for Sheet 2.

The names you type will display in the title bars of these sheet windows.

-
Assign Display Names to Sheets

==

Title Bar and Menu.

w_customers Title (1)

Maintain Customers

w_products Title (2)

Enter a display value for the sheets. These values will appear in the

N

aintain Products

< Back ][ MNext > ][ Cancel
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Getting Started

10

1"

12

Click Next twice.

You do not need to change the names of the About and Toolbar windows.

On the Specify Connectivity page, select None.

You will add a Connection object later.

Click Next twice to display the Ready To Create Application page.
You will create a project later.

This is the last wizard page. It lists your current selections so that you can
review them and use the Back button to go back and change them if
necessary.

Ready to Create Applicat’lcr% l D

An Application with the following characteristics will be created or
generated. Click Finish when you are ready.

Property Value l
Target File C:\Usersiwanghui\Documents\AppeonPoy
Application Library C:\Usersiwanghui\Documents\AppeonPoy =
Application pbtutor

Application Type MDI with Help

Library Search Path C:\WUsersiwanghui\Documents\AppeonPoy b
MDI Frame Window w_pbtutor_frame

MDI Frame Menu m_pbtutor_frame

Base Sheet Mame w_pbtutor_basesheet

Sheet Menu m_pbtutor_sheet =
1 (1 | +

< Back ][ Finish ][ Cancel

Make sure the Generate To-Do List check box is selected.
Click Finish.

The Template Application wizard creates the pbtutor.pbt target and the
pbtutorpbl library, and sets the new pbtutor application as the default
application.

You can expand the System Tree to view all the objects that have been
created by the Template Application wizard. The System Tree does not
display the file extension of the pbtutor target, but it does display the
directory where the target file is saved.
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sl MyWorkspace - PowerBuilder h
File Run Tools Window Help
a %= B &b A /-
New khet Open  Prodew | SysTres | O Ne=x Prmios T

B X & B & » B =

éc«miggu_c«miglle Andfyze Code kmi. Degoy  Run Appeon. Informai. 7

E|-- MyWorkspace (C:\Userswanghui\Documents\Appeon \PowerBuil
=-(2) pbtutor (C:\Users) hui\D: ts\Appeon\Pc
- pbtutor. pbl (C:Users\wanghui\Documents\AppeonPow
+ pbtutor
- = m_pbtutor_frame
[#-[7 Properties
0[] Events
- Functions
-1 Structures

H- = m_pbtutor_sheet

H-- . n_pbtutor_sheetmanager
i-1 w_customers

#-1 w_pbtutor_about
#-] w_pbtutor_basesheet
#-1 w_pbtutor_frame
#-1 w_pbtutor_toolbars
=-] w_products

[-[] Properties

-] Events

-3 Functions

-7 Structures

i-[(] Controls

e W B e O e O B e B

The pbtutor.pbl library displays under the pbtutor target in the System
Tree. It contains the target Application object, which has the same name
as the target object but displays under the library file. Other objects
generated by the wizard also display under the library file.

PowerBuilder



Lesson 1  Starting PowerBuilder

Specify an icon for the application

Getting Started

Where you are
Create a new workspace
Create a target

> Specify an icon for the application
Change the size of the main window
Run the application

Now you specify an icon for the application. The icon appears in the workspace
when you minimize the application during execution. PowerBuilder includes
the icon automatically when you create an executable file. You specify an icon
from the Properties view in the Application painter.

1 Double-click the pbtutor Application object in the System Tree
or
Right-click the pbtutor Application object in the System Tree and
select Edit from the pop-up menu.

The pbtutor Application object is located under the pbtutor library, which
is under the pbtutor target object that you created with the Template
Application wizard. Different views of the Application object display in
the Application painter.

2 Make sure the Properties view displays in the Application painter.
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38

If the Properties view is not open, you can open it by selecting
View>Properties from the menu bar. The menu item is grayed out if the
Properties view is already open.

T.0\Tutonial\pbtutor.pbl) i... EI@

1
[ Properties - pbtutor inherited from afOf %}

General | Toolbar

pbiutor
DizplayMName

»

MicroHelpDefault

DWMessageTite

m

DDETimeout

u]

[T rightToLeft

|| FreeDBLibraries

4F

’ Additional Properties

Fliemmme Hmm Ml Wi s Pildmmd | imd

Click the Additional Properties button in the Properties view.
A tabbed Application property sheet displays.

Select the Icon tab.

Click Browse.
Navigate to the Tutorial directory.

Select the tutorial.ico file.
Click Open.

If you do not see the ICO file extension
You do not see ICO file extensions if the Hide File Extensions for Known

File Types check box is selected in the Options dialog box of your
Windows Explorer.
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The tutorial icon displays on the Icon page of the Application property

sheet.

r ~
Application ﬂ
Text Font | Column Font | Header Font | Label Font
Icon | variable Types | RichTextEdit

Icon Mame:

C:\Wsersiwanghui\Documents\Appeon

7 Click OK.
Click the Save button in PainterBar1 or select File>Save.
Click the Close button in PainterBar1 or select File>Close.
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Change the size of the main window

Change the size of the main window

Where you are
Create a new workspace
Create a target
Specify an icon for the application
> Change the size of the main window
Run the application

Now you change the size of the application’s main window. When you run the
application, the main window displays in the position and size that you specify.

1 Double-click w_pbtutor_frame in the System Tree.

The Window painter opens the application’s frame window.
2 Check the Center check box on the General page in the Properties

view.

Now when you run the application, the frame window will be centered.
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Getting Started

3

Scroll down and select normal! inthe WindowState drop-down list

box.

i
| Properties - w_pbtutor_frame inherited from O} %}
General |Scro|| |Too|bar | Other | Docking |
Tag | =

Menulame il
m jbmtor_fraie E]
Visible
Enabled
TitleBar
ControlMenu
MaxBox
MinBox
[T cClientEdge
Palette\Window

m

ContextHelp
[T rightToLeft
Center
Resizable
Border
WindowType
[mdihelp! - ]
WindowState
[normal! & ]
BackColor
[JButton Face hd

IProperties 4Control List yMon-Visual Object List

If your Properties view looks different
You can change the position of Properties view labels by right-clicking the

Properties view and selecting a preference from the pop-up menu. You can
position the labels either to the left of all fields, or on top of the text fields

and to the right of the check boxes.

Click the Other tab in the Properties view.

Type 3000 in the Width text box and 2400 in the Height text box.

The size of the window rectangle in the Layout view changes. The values
you type are in PowerBuilder Units (PBUs).
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Change the size of the main window
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6

Press the Tab key.

| General | Scroll |Too|bar | Other |Dod<ing |

lalepErlies— w_pbtutor_frame inherited from O} %}

= Position
X
258
¥
132
Width
3000
Height
2400

= Pointer
Pointer

-A ibility

AccessibleMName

AccessibleDescription

AccessibleRole

defaultrole!

Properties AControl List AMon-Visual Object List

Select File>Close from the PowerBuilder menu.
Click Yes when you are prompted to save your changes.

The Window painter closes.

Next you run the application. When you run the application, the frame

window will be centered and sized as you specified.
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Run the application

Getting Started

i@

Where you are

Create a new workspace

Create a target

Specify an icon for the application

Change the size of the main window
> Run the application

Now you run the application to see how it works. At this point the application
does not do very much. By running the application, you can see the windows
and menus that were created for you when PowerBuilder generated the
application based on your choices. You will modify them later.

1 Click the Run button on the PowerBar.

The MDI frame window displays and is maximized. All MDI applications
created using the Wizard have a menu bar and a toolbar with some items
already coded for you.

2 Select File>New>Maintain Customers.

The application opens a sheet window. The display name that you typed in
the Template Application wizard for Sheet 1 appears in the title bar. The
sheet window title has a number after it to indicate the instance of the
window that displays.
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Run the application

About the number in the window title bar
The number 1 appears following the window title because this is the first

instance of the w_customers sheet window that is open. The code that adds
the instance number to the title bar is in the ue_postopen event of the
w_master detail ancestor base sheet window.

= Frome [ [ |

37

File Edit Window Help

|e|&|m

3 Select File>New>Maintain Products.

A second application sheet window displays.

4 Select Window>Tile Horizontal.

The sheet windows are arranged horizontally inside the MDI frame, with
the active sheet window at the top.

5 Select File>Toolbars from the menu bar.

The application displays the Toolbars dialog box.
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Getting Started

10

Select Floating in the Toolbars dialog box.

The toolbar floats within the MDI frame. You might need to move the
Toolbars dialog box to see the floating toolbar.

Select Top.

The toolbar is repositioned at the top of the frame.
Click Done to close the Toolbars dialog box.

Select File>Exit.

The application closes and you return to the PowerBuilder development
environment.

When you exit and restart PowerBuilder, you might want to have
PowerBuilder in the state it was in when you exited, with the workspace
and painters you were working in open.

Select Tools>System Options from the menu bar and then click the
Workspaces tab.

r ~
System Opticns N @
Profiling | Firewall Setting | Java
General | Workspaces | systemFont | Printer Font
[Clh

Reopen workspace on startup
Reload painters when opening workspace
Automatically set current target

Recent objects list contains 8 items {Jimit 38)
Recent workspaces list contains 8 items {Jimit 38)

Recent connections list contains 5 items {Jimit 10)

PowerBuilder creates registry entries for each workspace
and target file you open. "Clean Up™ will remove the
registry entries for all workspace and target files that no

longer exist.
Clean Up

ok | [ cancel Apply
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Run the application

11 Make sure the Reopen Workspace On Startup and the Reload Painters
When Opening Workspace check boxes are selected.
Click OK.

Now when PowerBuilder starts up, it opens the workspace and the painters
that were open when you exited. If you were coding in PowerBuilder when
you exited, the last script you were working on opens at the last line you
edited.
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Getting Started

Customizing the PowerBuilder
Environment

This lesson provides the information you need in order to become familiar
with the PowerBuilder environment and to customize the workspace. This
lesson is optional—you can skip to Lesson 3 if you want to.

In this lesson you:

*  Manipulate the System Tree window
*  Open an object

*  Manipulate views

*  Set up the toolbars

How long does it take?
About 25 minutes.
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Manipulate the System Tree window

48

Where you are
> Manipulate the System Tree window
Open an object
Manipulate views
Set up the toolbars

The Workspace page in the System Tree provides you with an overview of your
work. By expanding the workspace and the objects it contains, you can see the
content and structure of your target.

You can work directly with all the objects in the workspace. For example, you
can edit, run, search, or regenerate a window using its pop-up menu in the
System Tree. In this exercise you reposition, close, and open the System Tree.
You can reposition the System Tree in relation to the main window using its
drag bar. You can also change the way the System Tree, Clip, and Output
windows are arranged.

1  Click the Output button in the PowerBar to display the Output
window.

2 Select Tools>System Options from the menu bar.
Clear the Horizontal Dock Windows Dominate check box on the
General page and click OK.

The System Tree and Clip windows now occupy the full height of the main
window.

3 Click and hold the drag bar at the top of the System Tree.
Drag the System Tree to position it above, below, or to the right of the
painter workspace.

The painter workspace is the gray (blank) area, initially to the right of the
System Tree, where painters display when you open an object.

When you start dragging the System Tree, a gray rectangular outline
displays. It indicates the area that the System Tree would occupy if you
released the mouse button.

4 When the gray rectangular outline is positioned where you want the

System Tree to display, release the mouse button.

The System Tree displays in the new location.
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Lesson 2 Customizing the PowerBuilder Environment

5 Close the System Tree by clicking the SysTree button in the
E;l. PowerBar.

SysT . .
= The current workspace remains open, but the System Tree closes. Closing

the System Tree leaves more space for the painter workspace views.

6 Reopen the System Tree by clicking the SysTree button in the
PowerBar again.

7 Select Tools>System Options from the menu bar.
Select the Horizontal Dock Windows Dominate check box on the
General page and click OK.

You change back to the default selection for this design-time property.

+ 8 Close the Clip and Output windows by clicking their buttons on the
L 35 PowerBar or by clicking the small x in the corner of each window.

9 Right-click MyWorkspace and select Close from the pop-up menu.

The workspace closes. No workspaces display in the System Tree.
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Open an object

Open an object

Where you are

Manipulate the System Tree window
> Open an object

Manipulate views

Set up the toolbars

Now you open an object created by the Template Application wizard.

1 Select File>Recent Workspaces from the menu bar, then
MyWorkspace from the cascading menu.

2 In the System Tree, expand MyWorkspace, the pbtutor target, and
pbtutor.pbl.

3 Double-click the pbtutor Application object
or
Right-click the pbtutor Application object and select Edit from the
pop-up menu.

The Application painter opens. It displays different views of the pbtutor
Application object. Your view layout scheme may look different. To
display the default layout, select View>Layouts>Default.

| pk (pk ) (CAU: RORDoT ts\Appeon\P Builder 17.0\Tutorial\pk EIE
[ Script - open for returns (None) by O x| [[ Properties - pbtutor inherited from applica O
1=l open ( string com + El | General | Toolbar

"= -

/{* open: Application Open Script: Apptiame

I 1) Opens frame window pbtutor

= Displayh

/* This prevents double toolbars */ MicroHelpDefault

thiz. ToolBarFrameTitle = "MDI Application Toolbar"

this. ToolBarSheetTitle = "MDI Application Toolbar" DWMessageTitle

/* Open MDI frame window */

Open ( w_pbtutor_frame ) DDETImeout

a +
[T rightToLeft
[~ FreeDBLibraries

- Additional Properties
] 1

2

open iEvent List 3Function List yDedare Instance Variables_ Properties 4Non-Visual Object List_

50 PowerBuilder



Lesson 2 Customizing the PowerBuilder Environment

Getting Started

The default Application painter layout displays two stacks of tabbed
panes. The left stack contains tabs for a Script view (Open tab—it is set to
the Open event on the Application object), an Event List view, a Function
List view, and the Declare Instance Variables view. The right stack
contains tabs for the Properties view and a Non-Visual Object List view.

Look at the code in the Open event in the Script view.

The PowerScript code that was generated by the wizard in the Application
Object Open event calls a PowerScript function to open the main window
in the application. You will modify this code later in the tutorial.
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Manipulate views

Manipulate views

52

Where you are
Manipulate the System Tree window
Open an object
> Manipulate views
Set up the toolbars

Now you learn to control the location and appearance of PowerBuilder painter
views. You can add views to a painter workspace by selecting them from the
View menu in the workspace menu bar.

You can add multiple views of the same type and you can combine views into
a stack of panes with selection tabs at the bottom. You can resize a view by
grabbing and dragging the separator bars that surround it or that surround
neighboring views in the painter workspace.

These exercises demonstrate how you can change the appearance of
Application painter views, but you can manipulate views in all painters in the
same way.

Now you:

* Add an extra Script view

» Display view title bars

*  Float and dock views

*  Manipulate tabbed views

¢ Save a view layout scheme

¢ Reset the default view layout scheme
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Lesson 2 Customizing the PowerBuilder Environment

Add an extra Script view

Getting Started

The default Application painter layout actually has two Script views. One of
the Script views displays the script for an Application object event, and the
other Script view displays the declared variables for the object instance or the
entire application. Both of these Script views are in the same stack of tabbed

views (panes).

Now you add a third Script view that is not part of a stack of tabbed panes. You
can add multiple Script views to your painter layout, but no two Script views

can display the same script at the same time.

Select View>Script from the menu bar.

A new Script view displays. It is not attached to a stack of tabbed panes. It
lists the Application object in the left drop-down list box. The other two
drop-down lists are empty and the right drop-down list is grayed out.

=] pbtutor (pbtutor) (Ch\Users\wanghui\Documents\Appeon'\PowerBuilder 17.0\Tutorial\pbtutor... EIE

i i
IUSG"pt—npmfnr returns (Mone) gﬂ laPmpErlies— pbtutor inherited from applica O
pbtutor | = open (string com ElEl General | Toolbar
"= -
/{* open: Application Open Script: |E| :
I 1) Opens frame window 2] | [potutor
Vs I DisplayMame
" |—"" o o o v MicroHelpDefault
open iEvent List )Function List aDedare Instance Variables _|Properties 4Non-Visual Object List

phiutor - -

|m

Select Objects, Functions, or Declares ]

If an existing Script view shows the Open event, the new Script view is
empty. Otherwise it displays the Open event.

Select the Close event from the second drop-down list box.

If another Script view is already open to the Close event, an error message
displays in the PowerBuilder status bar.
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Manipulate views

Display view title bars

54

Now you display a view title bar by pinning it to the painter workspace
background. If a title bar is unpinned, you see it only when your cursor pauses
near the top edge of a view.

1 Move the cursor to the top of the extra Script view you just added.

The view title bar rolls down. It contains a pushpin button on the left and
a maximize/minimize button and a close button on the right. The name of
the view displays on the left side of the title bar, next to the pushpin button.

|§ 2 Click the pushpin in the title bar
or
Right-click the view title bar and click Pinned from the pop-up menu.

The pushpin button and the Pinned menu item are toggle switches. You
can click the pushpin button or the pop-up menu item to pin and unpin the
view title bars.
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Float and dock views

Getting Started

Now you float and dock a view in the painter workspace. Floating a view
enables you to move it around outside the painter frame.

Right-click the title bar of an unstacked view you want to float
or
Right-click the tab of a view in a stack of tabbed panes.

Ifthe title bar is not pinned, move the cursor over the title bar area and wait
until it displays before you right-click it.

Click Float in the pop-up menu.

When a view is floated, the Float menu item is not enabled. When a view
is docked, the Dock menu item is not enabled.

Drag the view around the screen.

Notice that the floating property allows you to move the view outside the
painter workspace.

Right-click the title bar of the floating view.
Click Dock in the pop-up menu.

The view returns to its original location.

55



Manipulate views

Manipulate tabbed views

56

Now you separate a view from a stack of tabbed panes and place it above the
stack. You then return it to the stack and change its position in the stack.

Press and hold the mouse button on the Function List tab.

Drag the tab onto the separator bar that separates the two default
stacks in the Application painter.

Release the mouse button.

When you release the mouse button, the Function List view is no longer
part of a stack. If you drag the tab too far and release it over the right stack
with the Properties view and Non-Visual Object List, the Function List
becomes part of that stack.

Alternate way to float a view from a stack
If you hold the Ctrl or Shift key down as you drag a tabbed pane from a

stack, the pane becomes a floating view.

Press and hold the mouse button on the Function List title bar.
Drag it over the stack from which you separated it.

Release the mouse button when the gray rectangular outline of the
Function List view overlaps the stack.

The Function List view returns to its original stack, but it is added as the
last pane in the stack.

Press and hold the mouse button on the Function List tab.

Drag it sideways over the other tabs in the same stack.

Release the mouse button when the small gray rectangular outline
overlaps another tab in the stack of tabbed panes.

The Function List view moves to the position in the stack where you
release the mouse button.
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Lesson 2 Customizing the PowerBuilder Environment

Save a view layout scheme

You can save view layout schemes for a PowerBuilder painter and use them
every time you open the painter.

Getting Started

1

Arrange the views in the painter as you like.
Select View>Layouts>Manage from the menu bar.
Click the New Layout button in the Layout dialog box.

Enter a name for your layout in the text field, click the background of
the dialog box, and then click the x button in the upper right corner of
the dialog box to close it.

Your layout scheme is saved. Now, when you select View>Layouts, you
see your layout listed on the cascading menu.

Saving the toolbars and System Tree layouts
PowerBuilder saves the customizations you make to the toolbars and

System Tree separately from the view layout. It retains those settings and
reapplies them to every workspace you access and every view layout you
select.
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Manipulate views

Reset the default view layout scheme

Each PowerBuilder painter has a default view layout scheme. You can always
reset the layout scheme to this default layout.

1 Select View>Layouts from the menu bar.

2 Choose Default from the cascading menu.

The default view layout scheme displays in the painter workspace.
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Set up the toolbars

Where you are
Manipulate the System Tree window
Open an object
Manipulate views
> Set up the toolbars

A painter workspace always includes the PowerBar and other PainterBar
toolbars that you can use as you work. The buttons in the toolbars change
depending on the type of target or object you are working with. You can also
customize the toolbars to include additional functionality.

Now you change the appearance of the toolbars to:
*  Show labels on toolbar buttons
*  Float the toolbars

*  Reposition the toolbars
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Set up the toolbars

Show labels on toolbar buttons

60

You can learn a toolbar button’s function by placing the cursor over it to view
its PowerTip. A PowerTip is pop-up text that indicates a button’s function.

You can also display a label on each toolbar button.

1

Move the pointer to any button on the PowerBar, but do not click.

The button’s PowerTip displays.

A

Hemw

o

Infherit

Mew

Select Tools>Toolbars from the menu bar.

The Toolbars dialog box displays.

Select the Show Text check box, then click the Close button.

PowerBuilder displays a label on each of the buttons in the PowerBar and
the PainterBars.
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Float the toolbars

You can float the toolbars so that you can move them around the painter
workspace as you work.

Getting Started

Right-click anywhere in the PowerBar.

The pop-up menu for the toolbars displays. From the pop-up menu you can
set the toolbar’s location to the left, top, right, or bottom of the workspace.
You can also set it to floating.

PainterBar2

Left

Top
Right
Bottom
Floating
Customize...

New...

Show Text
Show PowerTips

About pop-up menus
Throughout PowerBuilder, pop-up menus provide a fast way to do things.

The menu items available in the pop-up depend on the painter you are
using and where you are in the workspace when you click the right mouse
button.

Select Floating from the pop-up menu.

The PowerBar changes to a floating toolbar. You can adjust its shape.

PowerBarl

G4 % ¢ wooIZ fd [ 4| M B
New Inherit Open D‘E\e\h S\'ST'EE OJ:I.I' Next Previous  To-Dolist Srowser Chp Library D& Prof

/I;I!rzlril
Swp

Danbase Edit L Build Build Deglay Skip Debug Sd

Move the pointer to an edge or border area in the PowerBar.
Press and drag the PowerBar toward the left side of the workspace.
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62

Release the mouse button when the PowerBar becomes a vertical bar.

2 MyWorkspace - PowerBuilder l}
File Edit View Insert Design Run Tools Window Help
= T Taal
= A F@ I <« = o B x HECET T (] Q (
I S Cat Capy Sz Unda Amda Soim Propeims Clase i SdectAl Comment Uncomm.  Find  Fin
]
ﬂ- E|-- MyWorkspace (C:\User: « F F ) ( 2l PP A
. B'"%) "ﬁm;gcp‘bﬁgﬂ [ Script - open for_returns (None) Ol x| [ e
-'l" {E‘ L ’ 1= open (stringo B|E|| cener:
Inherit =
=
/{* open: Application Open Script: Apptia
Cpen I 1) Opens frame window pbtut
E; 1= Display
Preview =
= /* This prevents double toolbars */ MicroH
P | sl this. ToolBarFrameTitle = "MDI Application Toolba
1, this. ToolBarSheetTitle = "MDI Application Toolbar] DWWMe
Cuspns /* Open MDI frame window */ ——
¢ Mame  Preview Descri.. Nnan { wr nhtitar frama b4 ]
. 4 m 3 1]
. open iEvent List 3Function List yDedare Instance Variables. Proper
. 5'| Default |
ZE

The PowerBar is docked at the left side of the frame.
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Reposition the toolbars

You can customize the position of the toolbars to suit your work style.

1 Select Tools>Toolbars from the menu bar.

The Toolbars dialog box displays. The selected Move radio button
indicates the position of the currently selected toolbar.

; -
Toolbars @
Select Toolbar:

[¥]show Text [V Show PowerTips

Font Name: Font Size:
Small Fonts * 6 -
L
2 Click Top.

This repositions the PowerBar at the top of the workspace.

Radio buttons are grayed if a selected toolbar is hidden
If a selected toolbar is hidden (not visible) in the painter, you cannot select

where it appears in the workspace. In this case, the radio buttons are
grayed and you must first click the Show button before you can select a
radio button. The Show button replaces the Hide button when a toolbar is
hidden.

3 Click PainterBar1 in the Select Toolbar list box and select Right.
Click Close in the Toolbars dialog box.

4 Right-click PainterBar2 and select Left from the pop-up menu.

You have swapped the locations of the two painter bars.
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Set up the toolbars

5 Arrange the toolbars to suit your preferences.

You can also drag the toolbars to the top, bottom, left, or right of the
painter workspace. When a toolbar is in a fixed location, it has a drag bar
at the left or top of its buttons. You can click the drag bar and drag the
mouse to move the toolbar around the painter workspace.

PowerBuilder applies toolbar configuration properties to all painters and
saves them for the next PowerBuilder session.

6 Close the Application painter.

If you are not continuing immediately with the tutorial
You can close PowerBuilder or the tutorial workspace if you want. In that case,

you must open the tutorial workspace before you continue with the next lesson.
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LESSON 3

Getting Started

Building a Login Window

Windows are the main interface between users and PowerBuilder

applications. Windows can display information, request information from
a user, and respond to mouse or keyboard actions.

Windows are separate objects that you create using the Window painter.
In PowerBuilder, you can create windows anytime during the application
development process.

In this lesson you:

Create a new window

Add controls to the window

Change the tab order on the window

Code some Help events and preview the window

Write the script to open the window

How long does it take?
About 25 minutes.
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Create a new window

Create a new window

Eg iy

66

Where you are
> Create a new window
Add controls to the window
Change the tab order on the window
Code some Help events and preview the window
Write the script to open the window

Now you create a new window for the application. The window you create is a
login window that allows the user to enter a user ID and password and connect
to the database. The login window is a response window.

About response windows
Response windows are dialog boxes that require information from the user.

Response windows are application modal. When a response window displays,
it is the active window (it has focus) and no other window in the application is
accessible until the user responds. The user can go to other applications, but
when the user returns to the application, the response window is still active.

1 Click the New button in the PowerBar.

The New dialog box displays.

2 Click the PB Object tab.
Select the Window icon and click OK.

The Window painter opens. Notice that you have two new toolbars, the
StyleBar (with character style and text alignment buttons) and PainterBar3
(with color and border buttons, as well as grayed out control alignment
buttons).

3 Make sure that the Layout view and the Properties view display in the
Window painter.

You can display these views by selecting them from the View menu. If
they are grayed out in the menu, the views are already displayed in the
painter.

The default view layout scheme contains both views.
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Getting Started

To retrieve the default painter layout
Select View>Layouts>Default from the workspace menu bar.

The rectangle in the Layout view represents the window you are building.
The default properties in the Properties view indicate that the window is
visible and enabled, and has the Main window type. You might need to
scroll down in the Properties view to see the window type.

[ (Untitled) (pbtutor) inherited from window - Window (=% EcR =<=|
o Toveut D] | Properties Gnited) v <)
« | General [
Title J~
Untitled
Tag
3 | Mdgname - 1
[¥] visible
[#]Enabled | |
TitleBar
[¥] ControlMenu
[¥] MaxBox
[@] MinBox
[T ClientEdge
Paletteindon
ContextHelp
~ | [[]RightToLeft
< [l v [ Ceonter -
Layout {ppen }Event ListjFunction ListjDedare Instance Variables ||« Iyproperties {Contral Listyar * |

If your window does not have a pegboard look
If the window in your Layout view displays as a solid color, the Show Grid

option has been disabled. To enable it, select Design>Options from the
menu bar. Then select the Show Grid check box on the General page of the
Options dialog box. Click Apply, then OK to save the change and close the
dialog box.

Type Welcome in the Title text box on the General page of the
Properties view.

Select response! in the Window Type drop-down list box.
Make sure the TitleBar and ControlMenu check boxes are selected.
Select the ContextHelp check box.
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Create a new window
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Ak

The ContextHelp property adds a question-mark button next to the
(ControlMenu) close button in the login window’s title bar. Users of your
application can click the question-mark button to trigger Help events for
the window controls. You can add a question-mark button to a response
window, but not to a main window.

Click the Other tab in the Properties view.
Type 2300 in the Width text box and 1000 in the Height text box.
Press the Tab key.

The size of the window rectangle in the Layout view changes. The values
you type are in PowerBuilder Units (PBUs). You might need to modify
these values later, while you are adding controls to the window.

Other methods for entering position properties
You can use the spin controls to enter values instead of typing them.

Alternatively, you can change the size of the login window in the Layout
view by moving the pointer to the bottom or right edge of the window.
When it turns into a double-headed arrow, you can drag the arrow to
change the window size.

Select File>Save from the menu bar.

The Save Window dialog box displays. The only library in the Application
Libraries text box is pbtutor.pbl, and it is selected.

Type w_welcome for the window name.
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Getting Started

9

10

The prefix w_ is standard for windows.

-

Save Window

Windows:

I
by

w_welcome

]
O

w_customers
w_pbtutor_about
w_pbtutor_basesheet
w_pbtutor_frame
w_pbtutor_toolbars
w_products

m_|»

1

Comments:

Application Libraries:

C:\Wserswanghui\Documents\Appeon\PowerBuilder 17.01Tuty

I

(Optional) Type the following lines in the Comments text box:

This is the login window. It requires the application
user to enter an ID and a password before continuing.

These comments are visible in the List view of the Library painter.

Click OK.

PowerBuilder saves the new login window. If you expand MyWorkspace,
pbtutor, and pbtutor.pbl in the system tree, you can see w_welcome listed
under it.
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Add controls to the window

Add controls to the window

70

Where you are
Create a new window
> Add controls to the window
Change the tab order on the window
Code some Help events and preview the window
Write the script to open the window

Controls allow users to interact with PowerBuilder objects, such as windows
and DataWindows. You set properties of these controls and later add script for
control events and functions.

Selecting a control button from the PainterBar You can add controls from
the Insert menu or by selecting a control button in PainterBarl. Unless you
customize your toolbars, there is only one control button that appears in the
PainterBar. When you first open a painter, PainterBar1 includes the
CommandButton control button, which has a down arrow to its right. Clicking
the down arrow displays a drop-down list of control buttons.

Some of the controls you can select from the drop-down list are described in
the table below:

Button
appearance Control type Use in tutorial
] CommandButton Default icon for the control button in
N PainterBarl. You add command buttons
Sunon . .
later in this lesson.
= Picture To add a picture to the login window.
PoiHiLank
PictureHyperlink Not used in tutorial. Its purpose is to
N provide a link to a Web site.
Piciure
PictureButton Not used in tutorial. It is like a command
button, but it displays a picture as well as
2nEm
text.
A StaticText To add text labels to the login window.
Tt
A StaticHyperLink To provide a link to a Web site.
HoyperLink
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Lesson 3 Building a Login Window

Button
appearance Control type Use in tutorial
SingleLineEdit To add user entry text boxes to the login
:I' window.
Sngl=Edit
MultiLineEdit Not used in tutorial. Its purpose is to add a
Q multiline edit text box.
MulsiEdi

After you select a control, it appears in place of the CommandButton button on
PainterBarl.

Adding controls with a 3D appearance
To make your controls look three dimensional, select Design>Options from the

menu bar and make sure that the Default To 3D check box is selected on the
General page of the Options dialog box. You can change the window
background color from the default color of ButtonFace gray using the
Properties view in the Window painter.

Now you modify the login window you just created by adding controls and
changing some of their properties. You:

e Add a Picture control

e Add StaticText controls

e Specify properties of the StaticText controls

e Add SingleLineEdit controls

e Specify properties of the SingleLineEdit controls
¢ Add CommandButton controls

e Specify properties of the CommandButton controls
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Add controls to the window

Add a Picture control

Now you add a Picture control to the login window.

1 Select the Picture button from the drop-down list of controls

] or

P Select Insert>Control>Picture from the menu bar.

2 Click inside the rectangular window in the Layout view.

A Picture control displays at the selected location. At the same time you
add the control, the Properties view switches from displaying the window
properties to displaying the control properties.

If you do not see the Properties view, select View>Properties from the
menu bar. If the Properties view does not display the control properties,
click the picture control in the Layout view.

How to delete controls
If you add a control to the window and later decide you do not want it,

select the control and press the Delete key. This deletes the control and its
scripts.

3 Select the text p_1 in the Name text box on the General tab of the
Properties view.
Type p_sports in the Name text box.

This names the Picture control. The prefix p_ is standard for Picture
controls.

4  Click the ellipsis button next to the PictureName text box.

The Select Picture dialog box displays.

5 Navigate to the Tutorial directory if it is not already selected.
Select the tutsport.bmp file.

The bitmap you selected appears in the control you added to the Layout
view. The Visible, Enabled, and OriginalSize check boxes are selected by
default in the Properties view.
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Getting Started

Make sure the picture control is selected in the Layout view.

Click the Other tab in the Properties view.
Type 40 in the X text box and 50 in the Y text box.

You can use the spin controls in the X and Y text boxes to enter these

values. You might want to adjust the position of the picture control again

after you preview the window at the end of this lesson.

Type 300 in the Width text box and 250 in the Height text box.

You change the size of the picture control. You might want to adjust the

picture size again after you preview the window.

m

*1(ed

1 w_welcome * (pbtuter) (C:\Users\wanghui\Documents\Appeon\PowerBuilder 1... EI@
i i
[ Layout 0| x| ||& Properties - p_sports inherit O] X f
* || General | Other
= Position
X
40
¥
50
Width
300
Height
250
= Pointer
Pointer
< [ » - Nran & Nron —————
Layout 4open yEvent List yFunction List jDedare Instance Variables £ | 4 |4Properties 4Control List Non—\n'isj
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Add StaticText controls

74

T

Now you add StaticText controls to the login window. You will use these
controls to add descriptive labels to the login window.

1 Select the Text button from the drop-down list of controls
or
Select Insert>Control>StaticText from the menu bar.

2 Click to the right of the Picture control you added in the Layout view.

A StaticText control displays at the selected location.

3 Right-click the StaticText control and select Duplicate from the
pop-up menu.

PowerBuilder creates a duplicate of the selected control.

4 Select Duplicate from the StaticText control’s pop-up menu again.
PowerBuilder creates another duplicate.

You now have three StaticText controls arranged vertically at the top of the
window.

5 Adjust the location of the Static Text controls so that there are at least
two grid lines between them.
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Specify properties of the StaticText controls

Now you specify the properties of the StaticText controls (label text boxes) to
define how they should appear on the login window.

1 Select the first StaticText control you added by clicking on it.

The Properties view displays properties of the StaticText control. If you do
not see the Properties view, select View>Properties from the menu bar.

2 Select the text st_1 in the Name text box on the General page of the
Properties view.
Type st_welcome in the Name text box.

Now the control has a more descriptive name. The prefix st _ is standard
for StaticText controls.

3 Select the text none in the Text text box.
Type Welcome to SportsWear, Inc.

If you press Enter, click to another field or tab to another page in the
Properties view, or click in a different view, the text you typed replaces
none in the Layout view.

4 Click the Font tab in the Properties view.
Change the TextSize property for this control to 18 points.

The size of the text in the control changes.

The default typeface is Arial TrueType. You can select a different typeface
and font size if this one is not available on your system.

Using the StyleBar
You can also use the StyleBar to change fonts. If you do not see the

StyleBar, select Tools>Toolbars from the menu bar, click StyleBar in the
Select Toolbar list box, and then select one of the Move positions such as
bottom or floating.
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5 Adjust the size of the StaticText control to fit the text you entered.
Keep adjusting the size until you see all of the text you entered.

To adjust the size, drag the upper-right corner of the control toward the
upper-right corner of the window in the Layout view. You can also adjust
the size by entering appropriate values on the Other page of the Properties
view for this control.

6 Select the second StaticText control you added in the Layout view.
Type st_userid in the Name text box on the Properties view General
page.

Type User ID: inthe Text text box and press the Tab key.

The text displayed in the control changes.

7 Select the third StaticText control you added in the Layout view.
Type st_password in the Name text box on the Properties view
General page.

Type Password: in the Text text box and press the Tab key.

Your changes display in the Layout view.

1 w_welcome * (pk ) (CAL huitDoc ‘IS\Appeon\PawelBuildel 170.. EI@
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Title L
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ControlMenu
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Add SingleLineEdit controls

Getting Started

Now you add two SingleLineEdit controls to the window to allow the user to
enter a user ID and password for connecting to the database. A SingleLineEdit
control is a text box in which the user can enter a single line of text.
SingleLineEdit controls are typically used for the input and output of data.

1 Select the SingleLineEdit button from the drop-down list of controls
or
Select Insert>Control>SingleLineEdit from the menu bar.

2 Click to the right of the st_userid StaticText control in the Layout view.

A SingleLineEdit control displays where you clicked.
3 Increase the width of the SingleLineEdit control.

4 Right-click the SingleLineEdit control and select Duplicate from the
pop-up menu.
Adjust the position of this SingleLineEdit control so that it is just to
the right of the st_password StaticText control.

You should now have two SingleLineEdit controls arranged vertically to
the right of the StaticText controls.

1 w_welcome * (pbtuter) (C:\Users\wanghui\Documents\Appeon\PowerBuilder 17.0\T... EI@
L L
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Specify properties of the SingleLineEdit controls

78

Now you define the properties of the SingleLineEdit controls you just added to
the login window.

Select the first SingleLineEdit control you added.

The General page of the Properties view displays properties of the
SingleLineEdit control. If you do not see the Properties view, select
View>Properties from the menu bar.

Select the text sle_1 in the Name text box.
Type sle userid in the Name text box.
Clear the default text none in the Text text box.

The prefix sle_ is standard for SingleLineEdit controls.

Select the second SingleLineEdit control you added.
Type sle password in the Name text box.

Clear the default text none in the Text text box.
Select the Password check box.

Because you checked the Password check box, the password the user types
at runtime will display as a string of asterisks.
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Add CommandButton controls

Getting Started

Now you add CommandButton controls. Later you define scripts that execute
when users click these buttons.

1 Select the CommandButton button from the drop-down list of
controls
or
Select Insert>Control>CommandButton from the menu bar.

2 Click to the right of the sle_userid SingleLineEdit control.
A CommandButton control displays where you clicked.

3 Right-click the CommandButton control and select Duplicate from the
pop-up menu.

PowerBuilder creates a duplicate of the selected control.

4 Adjust the location of the controls as needed so that there is some
space between them.
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Specify properties of the CommandButton controls

Now you define the properties of the CommandButton controls.

1 Select the top CommandButton control.

The General page of the Properties view displays properties of the
CommandButton control.

2 Type cb okinthe Name text box on the Properties view General page.
Type OK in the Text text box.
Select the Default check box.

This step changes the default name of the control to something more
descriptive and adds a text label (OK) to the button. Because you selected
the Default check box, when an application user presses the Enter key, the
Clicked event for this button will be triggered. (The user does not have to
click the button itself for the event to be triggered.)

3 Select the bottom CommandButton control.
Type cb_cancel in the Name text box.
Type Cancel in the Text text box.

Select the Cancel check box.

Because you selected the Cancel check box, when an application user
presses the Esc key, the Clicked event for this button will be triggered.

1 w_welcome * (pbtuter) (C:\Users\wanghuﬂ&)cumenis\Appeon\PowerBuilder 17.0... EI@
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Change the tab order on the window

Where you are
Create a new window
Add controls to the window
> Change the tab order on the window
Code some Help events and preview the window
Write the script to open the window

When you place controls in a window, PowerBuilder assigns them a default tab
order. The tab order determines the sequence in which focus moves from
control to control when the user presses the Tab key.

Now you change the tab order for the window you created.

1 Select Format>Tab Order from the menu bar.

PowerBuilder displays the default tab order. The number in red at the right
of each control shows the control’s relative position in the tab order.
Controls with the number zero are skipped when the user tabs in the
window.

2  Click the tab order number for the sle_userid control.
Type 10 if the tab order value for this control is not already 10.

You can type a new tab order number only when the old number turns blue
against a red background.

3 Make changes as needed so that the other controls have these

values:
Click this control Control name | Has this value
SingleLineEdit control for entering a sle_password 20
password
CommandButton control for the OK cb_ok 30
button
CommandButton control for the Cancel | cb_cancel 40
button
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Change the tab order on the window

4 Select Format>Tab Order from the menu bar.

This is a toggle switch. Selecting this menu item a second time saves your
changes and clears the tab order numbers from the login window. You can
also use the Tab Order button on the PainterBar.
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Code some Help events and preview the window

Where you are

Create a new window

Add controls to the window

Change the tab order on the window
> Code some Help events and preview the window

Write the script to open the window

Now you use the Script view to add context-sensitive Help messages to the
SingleLineEdit controls that you placed on the login window, and you preview

the window.

Using the Script view The Script view has three drop-down list boxes.

The first drop-down list box displays the list of available controls for the
current object plus two special entries, Functions and Declare. The contents of
the second drop-down list box depend on the selection in the first drop-down
list box. The third drop-down list box contains all ancestor objects of the

current object, if any.

Selection in first
drop-down list box

Contents of second
drop-down list box

Contents of third
drop-down list box

An object or control
name

List of events for the
selected object or control.

All of the ancestor objects of
the current object, if any

Functions

List of editable functions.
Displays (New Function) if
no editable functions exist.

All ancestor objects with
functions having the same
signature as selected function

Declare

List of declaration types:
global, shared, and instance
variables, and global and
local external functions.

Empty

If the Script view is not currently displayed in your Window painter, you can
open it by double-clicking an object in the Layout view.

1 Double-click the top SingleLineEdit control in the Layout view.

The object name, sle_userid, appears in the first drop-down list box in the

Script view.

Getting Started
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Select the Help event in the second drop-down list box in the Script
view.

The Help event has the prototype: help (integer xpos, integer
ypos) returns long [pbm help]

Type the following line of PowerScript code in the script area:
ShowPopupHelp ("pbtutor.chm", this, 100)

You can find the pbtutor.chm file in the Tutorial directory. The second
argument refers to the current SingleLineEdit control, and the last
argument refers to a context ID in the pbtutor.chm file.

L =
IUSG"pt—hebfnr returns long gﬂ
sle_userid - help (ifteger xpos, * ElEl

ShowPopupHelp("pbtutar.chm”, this, 100)| -

4 | i r

| avaut s heln {Fvent ity Function |ist W Nedare Tnetance Variahles

As you type text in the Script view, notice that PowerBuilder changes the
text colors to show what kind of syntax element you have entered (such as
keywords, variables, and comments).

Select sle_password from the first drop-down list box in the Script
view.
Select the Help event in the second drop-down list box.

PowerBuilder compiles the code you typed for the Help event of the
sle userid SingleLineEdit text box. You now add a Help event for the
sle_password SingleLineEdit text box.

Type the following lines in the script area:

ShowPopupHelp ("pbtutor.chm", this, 200)

Select File>Run/Preview from the menu bar
or
Click the Run/Preview Object in the PowerBar.

The Run dialog box displays. Be sure the Objects of Type list box displays
Windows and the w_welcome object is selected.
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Getting Started

10

Previewing the window
You can preview the window without running scripts by selecting

Design>Preview on the menu bar or the Preview button in PainterBarl
(which uses the same icon as the Run/Preview Object button in the
PowerBar). However, you must run scripts to view the results of the Help
event scripts you just entered.

Click OK.

A message box prompts you to save your changes.

Click Yes.

The login window appears as it would at runtime. If you do not like the
window layout, you can change the size, location, and fonts of the window
controls when you go back to the Window painter workspace.

rWeIcome h l ? &1

d@hy, Welcome to SportsWear, Inc.

User ID: 0K
Password:

Click the question-mark button in the login window title bar.
Click inside the sle_userid SingleLineEdit text box.

A message displays: Type your user ID here. This text is associated
with context ID 700 in the pbtutor.chm file. You entered the context ID as
an argument of the ShowPopupHelp call for the sle userid Help event.

Click anywhere in the window to close the message.
Click inside the sle_password SingleLineEdit text box.
Press F1.

A message displays: Type your password here. This text is associated
with context ID 200 in the pbtutor.chm file.

85



Code some Help events and preview the window

11 Click anywhere in the window to close the message.
Click the close button in the login window title bar.

You return to the Window painter workspace.

Later you add code to the Clicked event for the Cancel button that closes
the application.

12 Close the Window painter by clicking the close button in PainterBar 1.

The close button is labeled with an x.
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Write the script to open the window

Getting Started

Where you are

Create a new window

Add controls to the window

Change the tab order on the window

Code some Help events and preview the window
> Write the script to open the window

Now you add a one-line script to open the login window as soon as the
application starts executing. Although you could change the script in the
Application object Open event to open the login window, in this tutorial you
make the call to open the login window from the Open event of the MDI frame
window. This window (w_pbtutor frame) was created by the Template
Application wizard.

In wizard-generated script, the frame window is called by the Application
object Open event. When you add a call to open the login window from the
MDI frame window Open event, the login window still displays before the
frame window. Because the login window is a response window, it temporarily
blocks execution of the remainder of the frame window Open event script.

In this exercise you:
*  Modify the frame window Open event

*  Compile the script
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Modify the frame window Open event

88

Now you modify the frame window Open event script to open the login
window.

Wizard-generated script
The frame window Open event already has a script associated with it that was

generated by the Template Application wizard. The script creates an instance
of a wizard-generated user object that serves as a sheet (window) manager. The
Open script then calls the ue postopen event.

The ue_postopen event registers sheet windows with the sheet manager. The
event is posted to the end of the messaging queue for the window and is not
processed until the remainder of the Open script (that you add in this lesson) is
executed.

1 Select File>Open from the menu bar.
Make or verify the following selections in the Open dialog box:

Open dialog box item | Selection to make (or verify)

Target pbtutor—currently your only target

Libraries pbtutor.pbl—currently your only library; if you
cannot see the full library name, you can drag the
edge of the dialog box to increase its size

Object Name w_pbtutor_frame

Objects of Type Windows—you must make sure this is selected
before you can select a named object of this type

Using Painter

The w_pbtutor frame object is the main application window created by
the Template Application wizard.

2 Click OK.

The Window painter opens and displays views of the main application
window in the painter workspace.

If the Script view is not open, you can open it by selecting View>Script in
the workspace menu bar or by double-clicking inside the Layout view.
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Getting Started

Move the cursor to the top of the Script view.

The view title bar rolls down. It contains a pushpin button on the left and
a maximize/minimize button and a close button on the right.

Click the pushpin in the title bar of the Script view.
The title bar of the Script view reads:

Script - open for w pbtutor frame returns long

Make sure the Open event displays in the Script view.

[ Scrpt - open for returns fong ol x| |
w_pbtutor_frame v] EZopen() returnslong « EIEI
e — = |a

//* open: Create sheet manager and post event
e *

string Is_sheets[]

/¥ Create an instance of the sheet manager */
inv_sheetmgt = Create n_pbtutor_sheetmanager

this.Post Event ue_postopen ()

The PowerScript code in the Script view is preceded by comments.

Using comments
A comment in PowerScript is indicated by either two forward slashes (/)

at the start of a single-line comment, or a slash and an asterisk (/*) at the
start and an asterisk and a slash (*/) at the end of a single-line or multiline
comment. Comments are not parsed by the script compiler.

You now modify the Open event script to cause the login window to
display.
Click after the parentheses in the line that reads:

this.Post Event ue postopen ( )

The ue_postopen event does not take any arguments.

Press Enter twice.

This adds a blank line in the Script view for legibility. The cursor moves
to a new line following the blank line.
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Commeant

8

Type Open the login window on the new line in the Script view.
Click the Comment button in PainterBar2.

Two slashes appear in front of the line you typed—it is changed into a
comment.

Move the cursor to the end of the comment.
Press Enter to add a new line.
Type open (w_welcome) on the new line.

This calls the Open function to display the login window you created.

Loy

L
[ Script - open for returns long gﬂ_
w_pbtutor_frame v] 2 ppen () returnslong ElEI
S A
//® open: Create sheet manager and post event
e *

string Is_sheets[]

[* Create an instance of the sheet manager =/
inv_sheetmgt = Create n_pbtutor_sheetmanager

this.Post Event ue_postopen ()

//Open the login window
open (w_welcome)

Accessing context-sensitive Help
To access context-sensitive Help for a function or reserved word (such as

Open), select the function or reserved word in the Script view and press
Shift+F1. You can always open the main Help screen by pressing F1.
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Compile the script

Getting Started

Now you compile the script you just typed. In this exercise, you use a pop-up
menu item to compile the script. PowerBuilder also compiles a script when you
close the Script view or when you select a different object, event, or function
for display in the Script view.

Handling errors in scripts
When there is an error in a script, an error window displays at the bottom of the

Script view with the line number of the error and the error message.

To find an error Click on an error message to move the cursor to the line that
contains that error. After you correct the error, you can try to compile the script
again.

Commenting out errors PowerBuilder does not save scripts that have
errors. If you want to save a script that has errors, select the entire script and
click the Comment button to comment out the code. You can come back later,
uncomment the code, and fix the problem.

1 Right-click anywhere in the Script view script area.
Select Compile from the pop-up menu.

The script compiles. You do not leave the Script view or the Window
painter workspace.

2 Select File>Save from the menu bar.
Select File>Close from the menu bar.

The Window painter closes.
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LESSON 4

Getting Started

Connecting to the Database

This lesson shows you how to make the application connect to the

Enterprise Application Sample demonstration database (Demo Database)
at execution time and how to use the Database painter to look at the table

definitions and database profile for this database.

In this lesson you:

Look at the Demo Database

Run the Connection Object wizard
Declare a global variable

Modify the connection information
Complete the login and logout scripts

Run the application

How long does it take?
About 30 minutes.

93



Look at the Demo Database

Look at the Demo Database
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Where you are

> Look at the Demo Database
Run the Connection Object wizard
Declare a global variable
Modify the connection information
Complete the login and logout scripts
Run the application

In many organizations, database specialists maintain the database. If this is true
in your organization, you might not need to create and maintain tables within
the database. However, to take full advantage of PowerBuilder, you should
know how to work with databases.

Defining a data source Using the ODBC administrator or other database
connection utilities, you can define a database as a data source for your
application. You can access the ODBC Administrator from the DataBase
Profiles dialog box. The definitions of ODBC data sources are stored in the
odbc.ini registry key.

Using database profiles to connect Once you define a data source, you can
create a database profile for it. A database profile is a named set of parameters
that specifies a connection to a particular data source or database. Database
profiles provide an easy way for you to manage database connections that you
use frequently. When you are developing an application, you can change
database profiles to connect to a different data source.

When database connections occur PowerBuilder can establish a
connection to the database in either the design-time or runtime environment.
PowerBuilder connects to a database when you open certain painters, when
you compile or save a PowerBuilder script that contains embedded SQL
statements, or when you run a PowerBuilder application that accesses the
database.

To maintain database definitions with PowerBuilder, you do most of your work
using the Database painter. The Database painter allows you to:

*  Create, alter, and drop tables

*  Create, alter, and drop primary and foreign keys

e Create and drop indexes

*  Define and modify extended attributes for columns

e Drop views
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Getting Started

In this exercise you:

Look at the database profile for the Demo Database

Look at table definitions in the Demo Database
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Look at the database profile for the Demo Database
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If you installed PowerBuilder with standard options, you already have a data
source and a database profile defined for the Demo Database. You use the
Demo Database in this tutorial.

Demo Database is an SQL Anywhere database that is accessed through ODBC.
In this lesson you look at the database profile for the Demo Database.
PowerBuilder stores database profile parameters in the registry.

1 Click the Database Profile button in the PowerBar
or
Select Tools>Database Profile from the menu bar.

PowerBuilder displays the Database Profiles dialog box, which includes a
tree view of the installed database interfaces and defined database profiles
for each interface. You can click the + signs or double-click the icons next
to items in the tree view to expand or contract tree view nodes.

2 Expand the ODB ODBC node by clicking on the plus sign, and select
PB Demo DB V2017.

PowerBuilder created this profile during installation.

Database Profiles

|
% Installed Database Interfaces - Connect
v ADO Microsoft ADO JNET
9 ASE SAP ASE 15.x16.x Clase
4 DIR Direct Connect
&4 110 Informix v10.x|v12.x
3 IN9 Informix v3.x
4 1DB 10BC
£ 010 Crade 10g Delete
5 090 Orade 5i
E4 ODB ODBC Help

=

-E4 PB Demo DB ¥2017 IM
-4 PB Demo DB ¥2017 IM Unicode
-E4 PB Demo DB ¥2017 Unicode
-7 Utilities -

Edit...

..

UH Mg
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Getting Started

If you do not see the PB Demo DB V2017 database profile
If there is no profile for the PB Demo DB V2017 database, you may not

have installed the database. You can install it now from the product
installation package.

If you did install the database and it is defined as a data source in the
ODBC Administrator, select ODBC in the tree view of the Database
Profile painter and click New. In the Database Profile Setup dialog box,
select the data source from the Data Source drop-down list and type pB
Demo DB V2017 in the Profile Name text box. Type dba for the user ID
and sql for the password, then click OK to return to the painter.

Click Edit.

PowerBuilder displays the Connection page of the Database Profile Setup
dialog box.

Select the Preview tab.
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The PowerScript connection syntax for the selected profile is shown on the
Preview tab. If you change the profile connection options, the syntax

changes accordingly.

.

Database Profile Setup - ODEC

S

Connection | System

| Transaction

Metwork

Options

| Syntax
Preview

Database Connection Syntax:

'/ Profile PB Demo DB V2017
QLCA.DBMS = "ODBC"
QLCA.AutoCommit = False
QLCA.DBParm = "ConnectString="DSN=PB Demo DB V2017;

] m |

2
Test Connection

OK

] [ Cancel

] Apply

Click the Test Connection button.

A message box tells you that the connection is successful.

If the message box tells you the connection is not successful
Close the message box and verify that the information on the Connection

page of the Database Profile Setup dialog box is correct. Then check the
configuration of the data source in the ODBC Administrator. You can run
the ODBC Administrator by expanding the Utilities folder under the
ODB ODBC node of the Database Profile painter and double-clicking the
ODBC Administrator item.

Click OK to close the message box.
Click Cancel to close the Database Profile Setup dialog box.
Click Close to close the Database Profiles dialog box.

PowerBuilder



Lesson 4 Connecting to the Database

Look at table definitions in the Demo Database

Now you look at the definitions for the Customer and Product tables in the
Demo Database. This helps you become familiar with the Database painter and
the tables you will use in the tutorial.

What happens when you connect To look at the table definitions, you have
to connect to the database. When you connect to a database in the development
environment, PowerBuilder writes the connection parameters to the Windows

registry.

Each time you connect to a different database, PowerBuilder overwrites the
existing parameters in the registry with those for the new database connection.
When you open a PowerBuilder painter that accesses the database, you
automatically connect to the last database used. PowerBuilder determines
which database this is by reading the registry.

1 Click the Database button in the PowerBar.

Dmssame PowerBuilder connects to the database and the Database painter opens.
The Database painter title bar identifies the active database connection.

The Objects view of the Database painter displays all existing database
profiles in a tree view under the Installed Database Interfaces heading. The
PB Demo DB V2017 database is visible under the ODB ODBC node in
the tree view.

If the Objects view is not open
The Objects view is part of the default view layout scheme. To reset to this

scheme, select View>Layouts>Default. You can also open an Objects
view by selecting View>Objects from the menu bar.

2 Expand the PB Demo DB V2017 database node in the Objects view.
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Notice the folders under the PB Demo DB V2017 database node.

L i
| |Objects =4
-4 JDBJDBC -
v-f4 010 Oracle 10g
0-d 090 Oracle 9i
=-&3 ODB ODBC
=
-3 Driver Information
-1 Events
-1 Groups
-3 Metadata Types
-3 Procedures & Functions
[E
[
£

=
=

m

H-[1 Tables
i1 Users
H-L1 Views
..... &4 PB Deme DB V2017 IM |
----- E4 PB Deme DB V2017 IM Unicode

..... 4 PB Demo DB V2017 Unicode

-0 Utilities

r Ed NNT NNata

Expand the Tables folder.
You see the list of tables in the database.

Table names might have a prefix
The table names in the Select Tables dialog box might have a prefix such

as dba or dbo. This depends on the login ID you are using. You can ignore
the prefix.

Right-click the customer table and select Add To Layout from the
pop-up menu

or

Drag the customer table from the Objects view to the Object Layout
view.

Dragging an object from one view to another
When you start dragging an object from the Objects view to another view,

the pointer changes to a barred circle. If you continue moving the cursor
to a view that can accept the object, the barred circle changes back to a
pointer with an additional arrow symbol in a small box. When you see this
symbol, you can release the object.

Repeat step 4 for the product table.
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Widening the Object Layout view
You can widen the Object Layout view by dragging its separator bars

toward the painter frame. If the Object Layout view is part of a stack, you
might find it easier to separate it from the stack before you change its size.

The Object Layout view shows the two tables you selected.

Ilalttliectla\mut@BDmnmmlﬂ alx||

|
A list of customers

Unigue Identification number of the customer
First name of the customer

Last name of the customer

Mailing address of the customer

City where the customer is located

State where the customer is located

zip Zip Code where the customer is located
phone Phone number of the customer
company_name Mame of the company

id Unigue Identification Cot}of the product
name Mame of the product
description Describes what the product is
prod_size Measurements of the product

L color Color of the product
quantity Amount of the product in stock
unit_price Unit price per product
picture_name  .bmp filename that shows what the product looks like
catalog_picture  Blob containing a catalog picture of the product in RLE format

4 | b

Object Layout 4Extended Attributes
I

Viewing table data types, comments, keys, and indexes
In the Object Layout view, you can see a description for each column, as

well as icons for keys and indexes. If you do not see this, right-click a
blank area inside the view and select Show Comments, Show Referential
Integrity, and then Show Index Keys from the pop-up menu. If you select
Show Datatypes, you also see the data type for each column in the selected
tables.

Right-click the title bar of the customer table in the Object Layout view
and select Alter Table from the pop-up menu

or

Right-click the customer table in the Objects tree view and select Alter
Table from the pop-up menu.

The Columns view displays the column definitions for the table.
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Right-click a column in the customer table in the Object Layout view.
Select Properties from the pop-up menu.

In the Database painter, the Properties view is also called the Object
Details view.

The title bar and tab headings for the Object Details view change
dynamically depending on the current object selection. The title bar gives
the object type, the database connection, and the object identifier.

The Object Details view for a column has five tabs, one for general
database properties, one for column header information, and the others for
column extended attributes.

[ Column (P& Demo DE V2017) - customer:id
General | Headers | Display | Validation | EditStyle |

Ol x|

Table: -
customer
Column:
id

- Column Details
Column Mumber:

1
Data Type:

integer
Nullable:

No
Default:

{MNone)

Comments:

m

Unigue Identification number of the customer -

About extended attributes
PowerBuilder stores extended attribute information in system tables of the

database. Extended attributes include headers and labels for columns,
initial values for columns, validation rules, and display formats.

You can define new extended attributes or change the definitions of
existing extended attributes from the pop-up menus of items in the
Extended Attributes view of the Database painter.

Close the Database painter.
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Run the Connection Object wizard

Getting Started

Tao-DsaLim

Where you are
Look at the Demo Database

> Run the Connection Object wizard
Declare a global variable
Modify the connection information
Complete the login and logout scripts
Run the application

Now you run the Connection Object wizard to create a connection service
manager, which you use to establish the runtime database connection.

The connection service manager is a nonvisual user object. It is nonvisual
because it does not have a graphic representation in the runtime application; it
is a user object because it is a customized object. You use it to perform database
connection processing in a PowerBuilder application.

Why you run a second wizard
If you had specified connection information in the Template Application

wizard, you would have created the connection service manager when you
generated the application. You can use multiple wizards in building your
application.

1 Click the To-Do List button in the PowerBar.
The To-Do List was generated by the Template Application wizard.
(2= 7o Do List [E=SREEN)

~
() pbtutor (C:'n,Users'\wanghui'n,Documents\AppeoJ&'owerBuilder 17.0\Tutorial) -

Design Maintain Customers sheet: w_customers

Design Maintain Products sheet: w_products

Create additional new sheets inheriting from w_pbtutor_basesheet

Register new sheets with the sheet manager service: n_pbtutor_sheetmanager
Add copyright information to the About dialog: w_pbtutor_about

Run Connection Object Wizard for additional connections

Run the Project Wizard to Build Project

2 Double-click the Run Connection Object Wizard item in the list
or
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Right-click the Run Connection Object Wizard item.
Select Go To Link from the pop-up menu.

This is the next-to-last item in the list. The To-Do List lists what you need
to do to complete the application. You can also use the list to make
comments to yourself or other developers working on the application.

You can also run the Connection Object wizard from the PB Object page
of the New dialog box. You used the New dialog box to run the Template
Application wizard in Lesson 1, Starting PowerBuilder.

The first page of the wizard tells you what it can do.

Click Next until the Choose Database Profile page displays.

You accept the wizard’s default selections for the destination library
(pbtutorpbl) and the database connectivity options (SQL). The Choose
Database Connection Profile page lists all the database profiles stored in
the registry.

Choose the PB Demo DB V2017 in the Database Profiles list box if it
is not already selected.

Click Next until the Ready To Create Connection Object page
displays.

You accept the default settings for the following items:

Wizard page Option Default selection
Specify Source of Connection Application INI File
Connectivity Source | Information
Info
Connection Service n_pbtutor connectservice
Object
Name Application Application INI File pbtutor.ini
INI File

The wizard creates the n_pbtutor connectservice user object to manage
your database connections. If you change an instance variable in this
connection service object, you can change the source of connection
information to the registry or to a script file. Otherwise, the pbtutor.ini
file—created by the wizard—is used for application connection
information.
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Getting Started

The last wizard page contains a summary of your choices, including the

default selections.

r o
Ready to Create Connection Object I\é @Iﬂ

A Connection Object with the following characteristics will be created
or generated. Click Finish when you are ready.

Property Value

Current Application pbtutor
Application Library C:\serswanghui\Documents\Appeon\Powerk
Library Search Path C:\serswanghui\Documents\Appeon\Powert

Selected Library C:\Userswanghui\Documents\Appeon\Powerk
Connectivity To? 5SQL Database

Database Profile PB Demo DB V2017

Connection Object n_pbtutor_connectservice

Connection Source IMI File

IMI File C:\serswanghui\Documents\Appeon\Powerk

4 [ | +

< Back ][ Finish ][ Cancel

Click Finish.

The wizard creates the connection service object and opens it in the User
Object painter. You can see n_pbtutor_connectservice in the System Tree.
The wizard also creates the application INI file. The To-Do List is still

open.

Close the To-Do List.
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Where you are
Look at the Demo Database
Run the Connection Object wizard

> Declare a global variable
Modify the connection information
Complete the login and logout scripts
Run the application

You will next examine the new connection service manager and create a global
variable to reference it. A global variable is available to all objects in the
application.

In more complex applications, you might prefer to reference the connection
service manager with local variables. This would release more memory as soon
as the local variable went out of scope. But in the tutorial, you should keep an
instance of the connection service manager available as long as the database
connection is open.

Establishing a connection To make it possible for an application to
connect to the database at execution time, the connection service manager calls
a wizard-generated function to set properties for a Transaction object that
serves as a communications area between the application and the database.

SQLCA Transaction object The connection service manager uses a built-in
nonvisual system object, the SQL Communications Area (SQLCA) object, as
the default Transaction object. The SQLCA object has several default
properties (including database name, login ID, and password) that are
populated by the connection service manager.

If an application communicates with multiple databases, you can create
additional Transaction objects as needed, one for each database connection.

What is required and what is not
You must have a Transaction object to connect to a database. The connection

service manager is not required, but is used in the tutorial because it generates
Transaction object properties you would otherwise have to type in an
application script.
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1 Make sure n_pbtutor_connectservice is open in the User Object
painter.

Opening the connection service manager
If the n_pbtutor connectservice object is not open in the User Object

painter, double-click n_pbtutor connectservice in the System Tree.

The default view layout scheme for the User Object painter includes a
Script view and a Declare Instance Variables view as part of a stack of
tabbed panes.

2 Make sure n_pbtutor_connectservice is selected in the first drop-
down list box of the Script view.
Make sure the Constructor event is selected in the second drop-down
list box.

The Script view displays the script created by the Connection Object
wizard for the Constructor event.

IﬁSa'pt - constructor for returns long gﬂ
n_pbtutor_connectservice '] 1= constructor () returns long [pbm_constructor = BE
fr= = =
/{* Connection Information is obtained from either: I'm
= - An INI File
= - The Windows Registry
1= - Seript
"=
/{* The source of connection information can be changed by k
J/* altering the value of the 'is_connectfrom' variable.
1= *

étrlng Is_dbms, |s_database, Is_userid, Is_dbpass, Is_logid, Is_logpass
string Is_server, |s_dbparm, Is_lock, Is_autocommit

m

If of_GetConnectionInfo ( Is_dbms, Is_database, Is_userid, Is_dbpass, Is_logid, Is_logpass, Is_server, |s_dbparm, Is_|

SQLCA.DBMS =Is_dbms

SQLCA.Database = |s_database

SQLCA.UserlD = Is_userid

SQLCA.DBPass = |s_dbpass

SQLCA.LogID = Is_logid

SQLCA.LogPass = Is_logpass

SQLCA.Serverlame = Is_server —
SQLCA.DBParm = Is_dbparm

SQLCA.Lock = Is_lock

Choose Case Lower ( Is_autocommit )
Case "1, "true’, "on”, "yes"
SQLCA.AutoCommit = True
Case "0". "false", "off". "no"
4| 1 +

constructor 4Fvent List yFunction List 4Dedare Instance Variables,

The script calls the function of GetConnectionInfo to obtain connection
information. You will next look at the script for this function.

3  Select Functions in the first drop-down list box in a Script view.
Select of_GetConnectioninfo in the second drop-down list box.
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The script for this function passes database connection information to the
Constructor event of the connection service manager. The information
passed depends on an instance variable. In this case, the value of the
is_connectfrom variable is 1. You will verify this in a moment. The
instance variable is available to all functions and events of the
n_pbtutor_connectservice object.

Because the is_connectfrom variable is 1, the connection service manager
looks to the Database section of the named INI file to get database
connection information using ProfileString function calls. In this case, the
named INI file is pbtutor.ini. You created this file with the Connection
Object wizard.

Later you modify the pbtutor.ini file and the of GetConnectionInfo
function to make sure that user ID and password information comes from
the login window instead of the INI file.

Select of_ConnectDB in the second drop-down list box.

This is the connection service manager function that actually connects to
the database using the SQLCA Transaction object. You call this function
from the login window you created in Lesson 3, Building a Login
Window.

Notice that the wizard-generated script for this function also opens a
message box if the database connection fails.

Select of_DisconnectDB in the second drop-down list box.

This is the connection service manager function that disconnects from the
database. You call this function from the application Close event.

Click the Declare Instance Variables tab.
Make sure Instance Variables is selected in the second drop-down list
box.

Selecting Declare in Script views
The Declare Instance Variables view is a special instance of the Script

view. It displays when you select Declare in the first drop-down list box of
the Script view. However, you cannot select Declare if a second Script
view already displays instance variables.
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You can now verify that the value of the is_connectfrom variable is 1.

L -
| Dedare Instance Variables ol =]
{Dedare) = Instance Variables ElEl

string is_connectfrom = "1" -

nqn
ngn "I
ngn

CONSTANT string IS_USE_INIFILE
COMNSTANT string IS_USE_REGISTRY
CONSTANT string IS_USE_SCRIFT

4 | i b

of_disconnectdb yEvent List }Function List sDedare Instance Variables

Select Global Variables in the second drop-down list box.
Drag n_pbtutor_connectservice from the System Tree to the Script
view.

Dragging object and function names from the System Tree to the Script
view saves time and helps avoid typing errors.

Complete the line by typing the variable name after the object name:
n pbtutor connectservice gnv connect

Although you declare this object in the Script view for the
n_pbtutor_connectservice user object, it is available everywhere in the
application.

Naming conventions for variables
To make scripts easier to read, it is best to follow a standard naming

convention. The recommended standard is to give each variable a 2-letter
or 3-letter prefix followed by an underscore (). The first letter of the
prefix identifies the scope of the variable (for example: g for global, 1 for
local) and the next letter or letters identify the data type (for example: s for
string, | for long, or nv for nonvisual object).

Click the Save button in the PainterBar
or
Select File>Save from the menu bar.

PowerBuilder compiles the script and saves it. If you had typed the global
variable data type (instead of dragging it from the System Tree) and you
made a typing error, an error message would display. You would then
correct the error and select Save again.
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Modify the connection information

Where you are
Look at the Demo Database
Run the Connection Object wizard
Declare a global variable

> Modify the connection information
Complete the login and logout scripts
Run the application

You can now call the connection service manager to establish a database
connection, but you should open a database connection only if the user enters
a valid ID and password in the login window. You will therefore add the
connection service call to the Clicked event of the OK button on this window,
substituting user-entered information for information from the pbtutor.ini file.

However, before you add the call to the OK button, you remove or comment
out the ProfileString calls that the connection service manager makes to get
user ID and password information from the INI file. Then you modify the
DBParm parameter in the pbtutor.ini file, because it includes hard-coded user
ID and password values that were copied from the pb.ini file.

In this exercise you:
*  Modify the of GetConnectionInfo function

*  Call the connection service manager
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Modify the of _GetConnectioninfo function

You looked at the of GetConnectionInfo function in the last exercise. Now you
comment out the information that the function returns for the user ID and
password information.

If you closed the User Object painter, you must open it again for the
n_pbtutor connectservice user object. You can use the File>Recent Objects
menu to redisplay it.

1 Select Functions in the first drop-down list box in the Script view.
Select of_GetConnectioninfo in the second drop-down list box.

2 Select the two ProfileString assignment lines that begin:

as userid = ProfileString (...)
as dbpass = ProfileString (...)

The four arguments of a ProfileString call are the INI file name or variable,
the INI file section, the INI file key, and the default value to be used if the
INI file name, section, or key is incorrect. These lines are part of the

IS _USE_INIFILE case of the CHOOSE CASE statement for the

of GetConnectionInfo function.

3 Click the Comment button in PainterBar2.

Camman By commenting out these lines, you make sure that the user ID and
password information do not come from the pbtutor.ini file.

4 Click anywhere in the line that begins:

as_dbparm = ProfileString ( ... )

5 Click the Comment button in PainterBar2.

The DBParm parameter in the pbtutor.ini file includes hard-coded values
for the user ID and password as well as the database name. You do not use
these values. Instead, you assign values to the DBParm parameter from
user-entry information for user ID and password.

Getting Started 11



Modify the connection information

About the SQLCA DBParm parameter
Although the user ID and password are not required for the DBParm

ConnectString, assigning them to the ConnectString overwrites SQLCA
user ID and password values in the data source definition for an SQL
Anywhere database. For this DBMS, the DBParm parameter also takes
precedence over the SQLCA UserID and DBPass parameters.

6 Click the Save button in PainterBar1.
Click the Close button in PainterBar1.
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Call the connection service manager

Getting Started

You will next call the connection service manager to connect to the database.
Because you eventually need to add user-entry information from the login
window, you add the call to the Clicked event for the OK button on this
window.

An object is considered to be the parent of the controls that are added to it. The
login window is therefore the parent of the OK button.

When referring to a parent object in a script, it is usually better practice to use
the qualifier parent than to name the object explicitly. This allows the code to
be reused more easily for controls placed on a different object. In the script for
the Clicked event, you refer to the login window as parent.

Using a single wizard to create the application and connection
If you had created the connection service user object with the Template

Application wizard, the code you enter in this exercise to call the connection
service manager would have been generated automatically, but it would have
been added to the application Open event, not to a Clicked event in a login
window. It would also have used a local variable, not a global variable.

1 Double-click w_welcome in the System Tree.

The Window painter opens.

2 Select cb_ok in the first drop-down list box of the Script view
or
Double-click the OK button in the Layout view.

The Clicked event should be the selected event in the second drop-down
list box. If it is not, select it. The Clicked event script is empty.

3 Type these lines:

// 1) Instantiate the Transaction object
// 2) Close login window if connection successful

These lines explain the code you add to the Clicked event. Adding double
slash marks at the front of a line turns it into a comment.

4 Type the following assignment statement below the comments:

gnv_connect = CREATE &
n pbtutor connectservice
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Do not type the ampersand (&) if you combine the lines of the script into
a single line. The ampersand character indicates that a line of script is
continued on the next line.

The CREATE statement instantiates the SQLCA Transaction object with
all the values retrieved by the of GetConnectionInfo function from the
pbtutor.ini file. Because you previously commented out the lines for the
user ID and password, this information is not retrieved.

For ease of reading, you can add blank lines between the comments and
the assignment statement for the global variable gnv_connect.

Type the following lines below the CREATE statement:

IF gnv_connect.of ConnectDB ( ) = 0 THEN
Close (parent)
END IF

The of ConnectDB function connects the application to the database. As
you saw earlier in this lesson, if the connection fails (the SQLCode is
not 0), a message box opens and displays the SQL error text.

If of ConnectDB returns a zero (the SQLCode for a successful
connection), the lines that follow the IF-THEN statement line are parsed.
In this case, the parent window for the cb_ok control (w_welcome) closes.

lalsmpt-cided for returns long ol =] IEIPmperlies- ch_ok inhe Ok xf
dicked () returnslong ElEl
/{ 1) Instantiate the Transaction object - R
MName
/{ 2) Close login window if connection chcessfuI cb_ok
gnv_connect = CREATE & Text
QK
n_pbtutor_connectservice Tag
IF gnv_connect.of_ConnectDB () = 0 THEN E
[¥] visible
Close (parent) [@lEnabled
END IF [¥] Default
[¥] cancel =
= | [ClFlatstyle
< | i | [ Transnarency (%) bt
Layout holicked 4Event List sFunction List 4Dedare Instance Variables _;l\Properﬁes Control List Ntﬂ

Click the Compile button in PainterBar2

or

Right-click inside the Script view and click Compile in the pop-up
menu.
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The script should compile without error. If you get an error message, make
sure you have typed object and function names correctly and saved
gnv_connect as a global variable.

Toggling the Error window of the Script view
You can show or hide the Error window by clicking the icon at the far right

of the Script view just under the title bar.

You still need to code the Clicked event to instantiate the Transaction
object with user-entered connection information.
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Complete the login and logout scripts

Where you are
Look at the Demo Database
Run the Connection Object wizard
Declare a global variable
Modify the connection information

> Complete the login and logout scripts
Run the application

Earlier in this lesson, you called the connection service manager from the
Clicked event for the login window OK button. Next you add code to the same
Clicked event to instantiate the Transaction object with information entered by
the user.

You also add code to the login window Cancel button Clicked event and to the
application Closed event.

Minimizing typing errors in the Script view

If you right-click inside the scripting area, you open a pop-up menu that
includes Paste Special commands. You can use these commands to paste
statements, objects, functions or even the contents of text files into the event
script. This reduces the risk of typing errors. You can also use AutoScript to
complete code, as you will see in this lesson.

In this exercise you:

e Setup shortcuts for AutoScript

* Add code to the OK button Clicked event

* Add code to the Cancel button Clicked event

¢ Add code to the application Close event
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Set up shortcuts for AutoScript

When you are coding scripts, AutoScript provides help by completing the
statement you are typing or displaying a list of language elements that are
appropriate to insert in the script at the cursor location.

1 Select Design>Options from the menu bar and click the AutoScript
tab.

2 Make sure all the check boxes in the first three group boxes are
selected.

3 Make sure the Activate Only After A Dot and Automatic Popup check
boxes in the fourth group box are cleared, and click OK.

With these settings, AutoScript provides Help wherever it has enough
information to determine what code to insert, but it does not pop up
automatically when you pause. By selecting the Statement Templates
check box (not selected by default), you can use AutoScript to enter
structures for a multiple line PowerScript statement.

4 Select Tools>Keyboard Shortcuts from the menu bar.
Expand the Edit node in the tree.

5 Scroll down and select Activate AutoScript.
With your cursor in the Press Keys For Shortcut box, press
Ctrl+Space.

6 Expand the Edit>Go To node in the Current Menu list and select Next
Marker.
With your cursor in the shortcut box, press Ctrl+M.

Now whenever you want help completing code, you can press Ctrl+space
to see a list of possible completions. If you paste a statement or function
with comments, you can press Ctrl+M to move to the next comment.

7 Click OK.
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Add code to the OK button Clicked event
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As is often the case when you are developing production applications, you get
some of the connection properties from an initialization file and some from
user input.

For the tutorial application, you should not get the user ID and password from
the tutorial INI file. Get them directly from the user in the login window and
then pass the database information in a script.

1 Make sure you are looking at the Clicked event script for the cb_ok
control.

This is the script in which you added the call to the Connection Service
object.

2 Click before the IF-THEN statement.
Type the following lines:

//Local variable declarations
string 1ls database, ls userid, ls password

//Assignment statements

ls userid = Trim ( sle userid.text )

1s password = Trim ( sle password.text )

1s database="ConnectString='DSN=PB Demo DB V2017;"

With these lines you declare local variables and assign them values. Do not
use blank spaces around the = signs in the ConnectString text. Do not
worry about the lone single quotation mark. You will add a single
quotation mark in the next step to complete the connection script.

Using AutoScript to help code the assignment statements
When you type the assignment statements, if you type the letters before the

underscore in a variable name and then press Ctrl+space, AutoScript pops
up a list of possible completions. Use the arrow keys to move to the correct
completion and the Tab key to paste it into your script. If you type the
underscore and the first letter after the underscore and then press
Ctrl+space, AutoScript pastes the completion directly into your script, as
long as there is a unique completion.

The Trim function removes leading and trailing spaces from the user ID
and password values passed as arguments to the function from the
SingleLineEdit boxes on the login window.
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3 Click after the lines you just added (which follow the CREATE
statement) but before the IF-THEN statement.
Type the following lines:

//Instantiate with user-entry values
SQLCA.userid = ls userid
SQLCA.dbpass = 1ls password
SQLCA.dbparm = ls database + "UID=" + &
1s userid + ";PWD=" + ls password + "'"

These lines instantiate SQLCA parameters with values from the
SingleLineEdit text boxes.

The lines must be added to the script after the CREATE statement to keep
them from being overwritten with blank values from the Constructor event
of the connection service manager. They must be added before the IF-
THEN statement or their values are not used by the Transaction object
when it is called by the of ConnectDB function of the connection service

manager.

L | 3
[ Saript - dicked for returns long & ol x|
|cb_ok ~| 5 dicked () returns long [pbm_bnciicks + 2=

/{ 1) Instantiate the Transaction object

/{ 2) Close login window if connection successful
gnv_connect = CREATE n_pbtutor_connectservice

//Local variable declarations
string |s_database, Is_userid, Is_password

/{Assignment statements

Is_userid = Trim ( sle_userid.text )

Is_password = Trim ( sle_password.text )
|s_database="ConnectString="DSN=PB Demo DB V2017;"

m

/{Instantiate with user-entry values

SQLCA.userid = |s_userid

SQLCA.dbpass = |s_password

SQLCA.dbparm = |s_database + "UID="+ &
Is_userid + ";PWD=" + |s_password + "

IF gnv_connect.of_ConnectDB () = 0 THEN
Close (parent) | 4
END IF

] 1 v
Layout holicked 4Event List sFunction List 4Dedare Instance Variables

4 Click the Compile button in PainterBar2
or
Right-click inside the Script view and click Compile in the pop-up
menu.
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The script should compile without error. If you get an error message, make
sure you have typed object and function names correctly.
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Add code to the Cancel button Clicked event

Now you add code to the Cancel button to stop the application when this button
is clicked.

1 Double-click the Cancel button in the Layout view
or
Select cb_cancel in the first drop-down list box of the Script view.

The script area for the Cancel button is blank.

2 Type this one-line script for the Clicked event:
HALT

This statement terminates the application immediately when the user
clicks Cancel on the login window.

3 Click the Save button in the PainterBar
or
Select File>Save from the menu bar.

PowerBuilder compiles the script.

4 Click the Close button in the PainterBar
or
Select File>Close from the menu bar.

The Window painter closes.
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Add code to the application Close event
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Because the connection service manager was called by a global variable, it is
still available to the application and does not need to be instantiated again (as
it would if you had used a local variable).

Now you call the connection service manager disconnect function to close the
database connection.

1 Double-click the pbtutor application icon in the System Tree.

The Application painter displays different views of the tutorial application
object. The Script view is part of a stack in the default layout, but you
might find it easier to detach it from the stack or open a second Script view.

2 Selectclose () returns (none) inthe second drop-down list box
of the Script view.

There is no code yet for the application Close event.

3 Type the following lines for the Close event comment:

Application Close script:
Disconnect from the database

4 Select all or part of the lines you just added.
Click the Comment button.

5 Type the following line below the comment you typed (you can use
AutoScript to complete the variable name and the function name):

gnv_connect.of_DisconnectDB ()

[ Seript - dose for returns (None) gﬂ_
1= dose () returns ([ * ElEl
/{Application Close script: -

I/ Disconnect from the database

gnv_connect.of_DisconnectDB ()

4 | i b

dose 4Event List jFunction List jDedare Instance Variables
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Releasing memory by setting global variables to null
If this were not the application Close event and you no longer needed an

instance of the global connection variable, you could release the memory
it occupies by calling the SetNull function.

PowerBuilder also provides a DESTROY statement to destroy object
instances. Do not use the DESTROY statement for local or global
variables for nonvisual objects. PowerBuilder garbage collection removes
any local variables that go out of scope.

Right-click anywhere in the script area of the Script view.
Click Compile in the pop-up menu.

PowerBuilder compiles the Close script. If you get an error message, look
carefully at the lines you typed to make sure there is no mistyped variable
or object name.

Click the Close button in PainterBar1.

A message box asks if you want to save your changes to the Application
object in the application library file.

Click Yes.

This saves your changes and closes the Application painter.
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Run the application
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E®

Where you are

Look at the Demo Database

Run the Connection Object wizard

Declare a global variable

Modify the connection information

Complete the login and logout scripts
> Run the application

Now you run the application.

1  Click the Run button in the PowerBar.
If a message box prompts you to save changes, click Yes to save
them.

The workspace closes and your application runs.

2 Type dba in the User ID box.
Type sql in the Password box.

The password text is displayed as asterisks. Because you set the tab order
for this window, you can tab from the User ID box to the Password box,
and then to the OK button.

3 Click OK.

The database connection is established and the MDI frame for your
application displays.

If you enter an invalid user ID or password
If you mistyped the user ID or password, the Connect to SQL Anywhere

(ODBC Configuration) dialog box displays. You get a second chance to
enter a valid user ID and password on the Login page of this dialog box. If
you click the Test Connection button on the ODBC page of the dialog box
without changing this information, a message box tells you that your user
ID or password is not valid.

4 Select File>Exit from the menu bar.

The application terminates and you return to the development
environment.
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Getting Started

Modifying the Ancestor Window

In this lesson you create a window that inherits from the basesheet
window that you generated with the Application Template wizard. You
add predefined user objects containing DataWindow controls to the
inherited window. You then create new w_customers and w_products
windows that inherit from this extension layer window instead of from the
original basesheet. Finally you make sure that the sheet windows open at
runtime with the size you set at design time.

But first you add a library to the library list that contains the predefined
user objects with DataWindow controls. In this lesson you:

Add a library to the search path

Create a new ancestor sheet window

Add user events and event scripts

Add scripts to retrieve data for the DataWindow controls

Adjust a runtime setting for sheet window size

How long does it take?
About 30 minutes.
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Add a library to the search path

Add a library to the search path

Where you are
> Add a library to the search path
Create a new ancestor sheet window
Add user events and event scripts
Add scripts to retrieve data for the DataWindow controls
Adjust a runtime setting for sheet window size

Next you add a library to the tutorial application search path. You must add all
libraries on which an application depends.

The library you add to the current application contains some precoded objects,
including the user object (u_dwstandard) that you will later add to the base
sheet window.

1 Right-click the pbtutor target (not the pbtutor application object) in
the System Tree.

The pbtutor target contains the pbtutor.pbl and the pbtutor application.

2 Select Library List from the pop-up menu.
The pbtutor target Properties dialog box displays the Library List page.

3 Click Browse.

The Select Library dialog box displays.

4 Navigate to the Tutorial folder.
Select tutor_pb.pbl and click Open.
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You return to the Library List page. The tutor _pb.pbl file is now included

in the search path for the tutorial application.

Properties of Target pbtutor

=

s

Library search path:

C:Wserswanghui\DocumentsAppeon'PowerBuilder 17,0 Tutorial\pbtutor. pbl;
C:\Userswanghui\Documents\Appeon\PowerBuilder 17,0 Tutorial\tutor_pb.phbl;

Click OK.
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Create a new ancestor sheet window

Where you are
Add a library to the search path
> Create a new ancestor sheet window
Add user events and event scripts
Add scripts to retrieve data for the DataWindow controls
Adjust a runtime setting for sheet window size

Now you create a window that inherits from the basesheet window you
generated with the Template Application wizard and add DataWindow controls
to it. In the Source editor, you change the inheritance of the generated sheet
windows (w_customers and w_products) to use the new window.

The DataWindow controls you add to the new ancestor window inherit their
definitions from a user object that was created for the tutorial application. The
user object is provided in the PBL file that you just added to the target library
list. The user object is a customized DataWindow control that includes scripts
to perform standard database error checking.

Why use a user object
You can build a user object in PowerBuilder to perform processing that you use

frequently in applications. Once you have defined a user object, you can reuse
it as many times as you need without any additional work.

In this exercise you:

*  Create a new sheet window inheritance hierarchy

* Add a DataWindow control for the master DataWindow
* Add a DataWindow control for the detail DataWindow

*  View the scripts inherited from the user object
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Create a new sheet window inheritance hierarchy

The new window you create now is an extension layer between the basesheet
window and application sheet windows. Later in this lesson you make changes
to the extension layer window. The changes you make are automatically
extended to any new sheet windows that you inherit from the extension layer
window.

In the current tutorial application, the w_customers and w_products windows
already inherit from the w_pbtutor basesheet window. Because you have not
yet added any non-generic property values or functions to these sheet windows
(other than their names and display text), you can write over these
wizard-generated windows without having to transfer any code to the
replacement windows. In this lesson you overwrite these windows with new
windows that inherit from the extension layer window.

1 Select File>Inherit from the PowerBuilder menu.

The Inherit from Object dialog box displays.

2 Make sure that pbtutor.pbl is selected in the Libraries list box and that
Windows is selected in the Objects Of Type drop-down list.

If you cannot see the full library list, you can change the size of the dialog
box by clicking on one of its edges and holding down the mouse button
while you drag the edge toward a corner of the screen. The pbtutor.pbl
should be the first of two libraries listed in the Libraries list box.

3 Select w_pbtutor_basesheet in the Object column of the main list box
and click OK.

4 Select File>Save As, and in the Save Window dialog box, select
w_master detail ancestor in the Windows field for the new
window name.

5 (Optional) Type the following text in the Comments box:

New ancestor basesheet for the w customers and
w_products sheet windows.
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10

1

12

Make sure that pbtutor.pbl is selected in the Application Libraries list
box and click OK.
Select File>Close to close the new ancestor basesheet.

You cannot create descendant windows if an ancestor window is open in
the Window painter.

Select File>Inherit from the PowerBuilder menu.

Make sure that pbtutor.pbl is selected in the Libraries list box and that
Windows is selected in the Objects Of Type drop-down list box.
Select w_master_detail_ancestor and click OK.

Type Maintain Customers in the Tag text box on the General page
of the Properties view.

Select File>Save As from the PowerBuilder menu and select
w_customers in the Windows list box.

Change the Comments text to:

Customer sheet window inheriting from
w master detail ancestor.

Click OK, then click Yes in the Save Window message box that asks
if you want to replace the existing w_customers window.

The new sheet window inherits from w_master detail ancestor instead of
from w_pbtutor basesheet.

Repeat steps 7-11, with the following modifications:

Step Modified instruction

9 Type Maintain Products in the Tag text box on the General
page of the Properties view. Select File>Save As from the
PowerBuilder menu and select w_products in the Windows list

box.

10 Change the Comments text to: Product sheet window
inheriting from w master detail ancestor.

11 The message box prompts you to replace the existing w_products
window.
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13 Close the new w_customers and w_products windows.

You cannot open an ancestor window in the Window painter if any of its
descendants are already displayed in the painter.

14 From the PowerBuilder menu, select Run>Full Build Workspace.

You should rebuild the workspace after changing the inheritance hierarchy
and before making modifications to the new ancestor window. You can see
the status of the build in the Output window, which displays below the
System Tree at the bottom of the PowerBuilder main window. The build is
finished when the Output window displays Finished Full build of
workspace MyWorkspace.

15 Close the Output window.
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Add a DataWindow control for the master DataWindow
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Now you add a DataWindow control (saved as the user object, u_dwstandard)
to the w_master detail ancestor window. It serves as the master DataWindow
for the ancestor window and its descendants.

How to create a user object like u_dwstandard
You can create a user object based on a DataWindow control by clicking the

New button and selecting Standard Visual from the PB Object page of the New
dialog box. This opens the Select Standard Visual Type dialog box. You can
then select DataWindow in the Types text box and add user events as needed.
You see how to add user events later in this tutorial.

1 Double-click w_master_detail_ancestor in the System Tree.

The w_master detail ancestor window opens in the Window painter. You
generated this window with the Template Application wizard. The wizard
also created and attached a menu to this window, m_pbtutor_sheet. The
menu is indicated in the Properties view for the window. You change this
property later.

2 Make sure the Layout view is visible in the Window painter.

3 Expand tutor_pb.pbl by double-clicking it in the System Tree.
Drag u_dwstandard from the System Tree to the
w_master_detail_ancestor window in the Layout view.

4 Widen the window so that the control is completely visible inside the
window.
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PowerBuilder creates a DataWindow control that inherits its definition
from the user object.

! -

[ Layout ol x|

- -

: Sl
(N

5 Make sure the new control is selected in the Layout view.

Small black squares at the corners indicate that the control is selected. The
Properties view displays the properties of the selected control.

6 Select the text dw_1 in the Name text box in the Properties view.
Type dw master in the Name text box.
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Select the VScrollBar check box.

[ Properties - dw_master inherited from u_dwstz 3f X|
General | Othey

Name *

dw_master
DataObject

RichText Toolbar Activation Made
richtexttoolbaractivationonedit! - ]
Title

Tag

Visible
Enabled
[ TitleBar
[ contralMenu
[ MaxBox
[©] MinBox
[T HSeroliBar
VScrollBar
LiveScrol
[~ Hsplitscroll
[ rightToLeft
[T Resizable
Border
BorderStyle

™ StyleLowered! -

m

[iProperties {Control List jMon-Visual Object List 4|

PowerBuilder adds a vertical scroll bar to the control. It also changes its
name to dw_master. The prefix dw_ is standard for DataWindow controls.
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Add a DataWindow control for the detail DataWindow

Now you add a second DataWindow control that is the detail DataWindow in
the application.

1 Resize the window so that there is room for a second DataWindow
control below the first.
Drag u_dwstandard from the System Tree to below the dw_master
control in the Layout view.

PowerBuilder creates another DataWindow control that inherits its
definition from the user object u_dwstandard.

2 Move the DataWindow control so that it is completely visible inside
the window.

If you need to, you can maximize the Layout view and enlarge the window
object inside it to make more room for the DataWindow controls.

= ot Ol

3 Make sure that the new control is selected in the Layout view.

The Properties view displays the properties of the selected control.

4 Replace the text dw_1 in the Name text box in the Properties view with
dw detail.
PowerBuilder changes the name of the control to dw_detail.
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View the scripts inherited from the user object
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Now you view the scripts the DataWindow controls inherited from
u_dwstandard.

Double-click the dw_detail DataWindow in the Layout view

or

Select dw_detail from the first drop-down list box in the Script view if
it is not already selected.

The Script view opens to the empty script for the dw_detail control’s
ItemChanged event.

Unscripted events are alphabetized separately from scripted events.
Scripted events are listed at the top of the drop-down list box. You will
next look at the dberror event, which contains an ancestor script, so you
need to scroll up in the event drop-down list box to find it.

Select dberror from the second drop-down list box in the Script view.

This script is also empty, but a purple script icon displays next to the event
name. This indicates that the ancestor control (u_dwstandard) has an
associated script.

Select Edit>Go To>Ancestor Script from the menu bar

or

Select u_dwstandard in the third drop-down list box.
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PowerBuilder displays the script for the DBError event in the Script view.
The ancestor script is read-only when it is accessed from the Script view
for one of its descendants.

[ Script - dberror for returns long (Ancestor Saript - Read Only) =E
[dw_detail v] B dberror (long sqldbcode, ~ | 15 u_dwstar + ElEl
/¥ Event profile -
Mame: DBError =
Applies to:  u_dwstandard
Kind: System
Processing: See below
*f
T
I /
/f Qverview -- !
I
/f When a database error occurs in the DataWindow control !

J{ (resulting from a Retrieve function or an Update function), /
J// then get the error code and message that the DBMS returned [

J// and display them nicely to the user. :[ /

I

/' Also, suppress the default error messagebox that the /

/{ DBError event normally displays. /

/i ! 2
4| i r

4 Scroll through the window to view the database error-handling logic
defined for the DBError event.

The script suppresses the default error message that the DBError event
normally displays. Instead, it causes an appropriate message to be
displayed for each database error that might occur. The script makes calls
to user events that were declared for the user object.

Because you used the u_dwstandard object to define both DataWindow
controls in the window, this logic is automatically reused in both controls.

5 Select Edit>Go To>Descendant Script from the menu bar

or
Right-click inside the script area of the Script view.
Select Go To>Descendant Script from the pop-up menu.

The third drop-down list box again displays w_master detail ancestor, the
identifier of the object that contains the current control. The script for the
DBError event of this control (dw_detail) is still blank.
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Add user events and event scripts
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Where you are
Add a library to the search path
Create a new ancestor sheet window
> Add user events and event scripts
Add scripts to retrieve data for the DataWindow controls
Adjust a runtime setting for sheet window size

Windows, user objects, and controls have predefined events associated with
them. Most of the time, the predefined events are all you need, but there are
times when you want to declare your own events. Events that you define are
called user events.

Purpose of user events One reason to define a user event is to reduce
coding in situations where an application provides several ways to perform a
particular task. For example, a task like updating the database can be
performed by clicking a button, selecting a menu item, or closing a window.
Instead of writing the code to update the database in each of these places, you
can define a user event, then trigger that user event in each place in which you
update the database.

Now you define some user events to handle retrieval, insert, update, and delete
operations against the tutorial database. You make these changes in the Script
view of the Window painter. Later in the tutorial, you add code in the Menu
painter to trigger these events.

1 Select w_master_detail_ancestor in the first drop-down list box of the
Script view.

2 Select Insert>Event from the menu bar
or
Select New Event in the second drop-down list box of the Script view.

The Script view displays the Prototype window for defining a new event.
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The first button to the right of the third drop-down list box is a toggle
switch that displays or hides the Prototype window.

L -
[& {Untitied) ol x|
[w_masher_detail_ancestor - ] (Mew Event) - EEI

Access Return Type Event Mame o
public (None)| - |

Pass By Argument Type Argument Name

Throws: |
4 + ¥
N
[

Type ue_retrieve in the Event Name text box in the Prototype
window.

Click inside the Script view below the Prototype window.

Type these lines (or use AutoScript as described below):

IF dw master.Retrieve() <> -1 THEN
dw master.SetFocus ()
dw master.SetRowFocusIndicator (Hand!)

END IF

Using AutoScript instead of typing
You can use AutoScript to paste in the [F THEN template as well as the

variables and function names:

Type IF, then press Ctrl+space.

Press Tab to paste an IF THEN statement.

Type dw_m, then press Ctrl+space.

Place the cursor after dw_master, type a dot, then type Ctrl+space.
Scroll and select retrieve( ), press Tab, and type the rest of the line.
Press Ctrl+M to jump to the next comment.

Enter the other function calls by typing them or using AutoScript.

As soon as you clicked in the script area, the text in the second drop-down
list box of the Script view changed from New Event to ue retrieve. It has
no arguments, does not return a value, and does not throw user-defined
exceptions. For information on throwing user-defined exceptions, see

Lesson 10, Exception Handling.
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The script lines you entered execute the Retrieve function and place the
retrieved rows in the dw_master DataWindow control. If the retrieval
operation succeeds, the script sets the focus to the first row in the
DataWindow control and establishes the hand pointer as the current row
indicator.

If the retrieve fails
If the retrieval operation does not succeed, PowerBuilder triggers the

DBETrror event. The logic for the DBError event is handled in the user
object u_dwstandard. You looked at this script in the previous exercise.

L =
laScrbt -ue_retrieve for w_master_detail_ancestor inherited from w_pbmhor_basedweeg'ih
[w_masher_detail_ancestor v] ue_retrieve () returns (nor = EEI

Access Return Type Event Mame =
public {(Mone) * |ue_retrieve
Pass By Argument Type Argument Name
Throws: |
E— -
4 ¥

IF dw_master.Retrieve() <> -1 THEN -

dw_master.SetFocus()
dw_master.SetRowFocusIndicator(Hand!)
END IF
1

Select File>Save from the menu bar.
Right-click the Prototype window and select New Event from the

pop-up menu.

PowerBuilder compiles the script you entered for the ue_retrieve event.
The Script view displays the Prototype window for another new user
event.

If you get an error message
Mistyped or incomplete script entries generate compiler errors. If you

select No when prompted to ignore compilation errors, a compiler error
area displays at the bottom of the Script view, identifying your error. If this
happens, retype the script for the ue retrieve event.

You can display or hide the compiler error area by clicking the second
toggle switch at the top right of the Script view.

Repeat steps 3 and 4 for the following entries:
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Event name Script

ue_insert dw_detail.Reset ()
dw detail.InsertRow (0)
dw detail.SetFocus()

ue_update IF dw_detail.Update() = 1 THEN
COMMIT using SQLCA;

MessageBox ("Save", "Save succeeded")
ELSE

ROLLBACK using SQLCA;

END IF

ue_delete dw_detail.DeleteRow (0)

What the scripts do The first line of the script for the ue_insert event
clears the dw_detail DataWindow control. The second line inserts a new
row after the last row in the DataWindow (the argument zero specifies the
last row). The third line positions the cursor in the dw_detail control.

Theue_insertand ue_delete events operate on the DataWindow buffer, not
on the database. When these events are triggered, a row is not inserted or
deleted from the database unless the Update function is also called (the
ue_update event calls this function). If the Update function returns the
integer 1, changes made to the buffer are committed to the database. If it
returns a different integer, changes to the buffer are rolled back.

In the script for the ue_delete event, the argument zero in the DeleteRow
function specifies that the current row in the dw_detail control be deleted.

6 Make sure your work is saved.

If you repeated step 4 for each new event and script that you added, you
have already saved your work.
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Add scripts to retrieve data for the DataWindow

controls

142

Where you are
Add a library to the search path
Create a new ancestor sheet window
Add user events and event scripts
> Add scripts to retrieve data for the DataWindow controls
Adjust a runtime setting for sheet window size

The scripts you just typed have no effect on the dw_master DataWindow
control, but now that you have a script for the ue_retrieve event, you need only
trigger this event to retrieve data into the dw_master DataWindow.

You trigger the ue retrieve event from the sheet window Open event. This
retrieves data into the dw_master DataWindow as soon as the window (or one
of its descendent windows) opens. Then you add a script for the
RowFocusChanged event of dw_master to retrieve data into the dw_detail
DataWindow. The RowFocusChanged event is triggered each time the focus is
changed inside the dw_master DataWindow.

RowFocusChanged occurs upon DataWindow display
The RowFocusChanged event also occurs when the w_master DataWindow is

first displayed. This allows the application to retrieve and display detail
information for the first row retrieved in the master DataWindow.

Here is how the script works for the w_master detail ancestor window and its
descendants when you are done:

e When a sheet window first opens, a list (of all customers or products)
displays in the top DataWindow control. Detail information for the first
item in the list displays in the bottom DataWindow control.

*  When a user moves through the list in the top DataWindow control using
the up arrow and down arrow keys or by clicking in a row, the details for
the current row display in the bottom DataWindow control.

1 Select open from the second drop-down list box in the Script view for
w_master_detail_ancestor.

The Open event has a purple script icon indicating it has an ancestor script.
If you check the ancestor script, you see that it calls the ue_postopen event
and posts it to the end of the window’s message queue.
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Type these new lines in the script area for the
w_master_detail_ancestor Open event:

dw master.settransobject ( sglca )
dw detail.settransobject ( sglca )
this.EVENT ue retrieve()

The first two lines tell the dw_master and dw_detail DataWindows to look
in the SQLCA Transaction object for the values of the database variables.
The third line triggers the ue_retrieve event. The pronoun 7This refers to the
current object. In this example, the w_master detail ancestor window is
the current object.

Select dw_master in the first drop-down list box of the Script view.
Select rowfocuschanged in the second drop-down list box.

Read the event name carefully
Make sure you select the RowFocusChanged event, and not the

RowFocusChanging event.

You now add a script for the RowFocusChanged event of the dw_master
DataWindow control. This script sends a retrieval request and the 1D
number of the selected row to the dw_detail DataWindow control.

Type this line in the script area for the RowFocusChanged event:
long 11 itemnum

This line declares the local variable 11_itemnum (1 is a letter, not a number),
which has the long data type.

Type this line below the variable declaration line you just typed:

11 itemnum = this.object.data[currentrow, 1]

Use square brackets
The expression shown above requires square brackets, not parentheses.

This line uses a DataWindow data expression to obtain the item number in
column 1 of the currently selected row of dw_master. It stores the number
in the variable 11_itemnum.
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CurrentRow is an argument passed to the RowFocusChanged event that
specifies the current row in the DataWindow control. The current row is
the row the user has selected by clicking or by scrolling with the arrow or
tab keys.

Type these lines below the data expression line you just typed:

IF dw _detail.Retrieve(ll itemnum) = -1 THEN
MessageBox ("Retrieve","Retrieve error-detail")
END IF

This group of lines sends a retrieval request to the dw_detail DataWindow
along with the argument the DataWindow expects (an ID number stored in
the 1_itemnum variable). The IF statement that encloses the Retrieve
function checks for successful completion. If the retrieval operation fails,
it displays an error message box.

! |
las‘r'pt focusch i for dw_master inherited from u_d: dard returns long gﬂ |
[dw_masher v] rowfocuschanged (long cur + w_master EEI

Access Return Type Event Mame -
public long rowfocuschanged
Pass By Argument Type Argument Name
value long currentrow E
Throws:

External EventID |pbm_dwnrowchange =
4 »

long II_itemnum -

Il_itemnum = thiz.object.data currentrow, 1]

IF dw_detail.Retrieve(ll_itemnum) = -1 THEN

MessageBox("Retrieve","Retrieve error-detail")

END IF

Click the Save button in PainterBar1.
Click the Close button in PainterBar1.

PowerBuilder compiles the script you typed and saves it.

Click the Full Build Workspace button in the PowerBar.

It is a good idea to rebuild all your objects after modifying an ancestor
object.

Close the Output window.
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Where you are

Add a library to the search path

Create a new ancestor sheet window

Add user events and event scripts

Add scripts to retrieve data for the DataWindow controls
> Adjust a runtime setting for sheet window size

The Template Application wizard creates a sheet manager that makes the
OpenSheet function call to open a sheet window. The OpenSheet function has
an argument that can affect the sheet window size at runtime. By default the
wizard sets this argument to the Cascaded! value that overrides the sheet
window size you set at design time. Now you change this value to allow the
runtime window size to be the same as the design time size.

1 Double-click n_pbtutor_sheetmanager in the System Tree
or
Right-click n_pbtutor_sheetmanager in the System Tree and select
Edit from the pop-up menu.

2 In the Script view, select (Functions) in the first drop-down list box.
Select of_opensheet in the second drop-down list box.

3 Go to the following line in the script:

1i rc = OpenSheet ( lw sheet, as sheetname,
w_pbtutor frame, 0, Cascaded! )

4 Change the Cascaded! argument to Original!:

1i rc = OpenSheet ( lw sheet, as sheetname,
w_pbtutor frame, 0, Original! )

5 Click the Save button in PainterBar1.
Click the Close button in PainterBar1.

The next time you run the tutorial application, the sheet windows will open
in the size you set at design time. They will still be cascaded relative to
other open sheets.

145



Adjust a runtime setting for sheet window size

146 PowerBuilder



LESSON 6 Setting Up the Menus

In this lesson you set up the menus for the application. You:
*  Modify the frame menu

*  Create a new sheet menu

*  Add menu scripts to trigger user events

+  Attach the new menu and run the application

Menus are separate objects that you create using the Menu painter. After
you create a menu, you can attach it to as many windows as you want. You
can create menus at any time during the application development process.

How long does it take?
About 30 minutes.
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Modify the frame menu

Where you are
> Modify the frame menu
Create a new sheet menu
Add menu scripts to trigger user events
Attach the new menu and run the application

The frame menu was created automatically by the Template Application
wizard. The m_pbtutor frame menu is the ancestor of all the other menus you
work with in the tutorial. Changes you make to this menu are automatically
propagated to descendant menus.

In the WYSIWYG (What You See Is What You Get) view of the Menu painter,
you see menus as they appear when the application is running. In this tutorial,
you use the WYSIWYG view to make changes to the application menus, but
you can make the same changes from the Tree Menu view. You use the
Properties view to change a toolbar button.

In this exercise you:
*  Modify the File menu

*  Enable Help menu items
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Modify the File menu

Getting Started

Now you modify the File cascading menu of the m_pbtutor frame menu.

Double-click m_pbtutor_frame in the System Tree.

The Menu painter displays the menu associated with the MDI frame
window in the application. Because m_pbtutor sheet inherits from
m_pbtutor frame, changes you make to the frame menu are propagated to
the sheet menu.

In the WYSIWIG view, the menu items appear across the top of the view.
Ifa WYSIWYG view is not open, you can select it from the View menu in
the Menu painter menu bar.

Click the File menu in the WYSIWYG view of m_pbtutor_frame.

When you click a menu item in the WYSIWYG view, its menu items
appear just as they would at runtime.

If the File menu does not display its menu items
The File menu is selected when you display the WYSIWYG view. You

might need to click one of the other menus (Edit, Window, or Help) and
then click again on the File menu to display its menu items.

Right-click New under the File menu.

Select Edit Menu Item Text in the pop-up menu.

Click in the New field and replace &New with sReport.
Press Enter.

You change the display name of the New menu item to Report. The menu
name remains m_new and its purpose (to open new sheet windows)
remains the same.

Define accelerator keys with the ampersand character
The character following the ampersand is used as an accelerator key

(mnemonic) and appears with an underscore in the WYSIWYG display. In
the runtime application, the user can access the File>Report menu by
pressing Alt+F+R.
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Make sure that &Report appears in the Text text box in the Properties
view.
Click the Toolbar tab in the Properties view.

The toolbar item text is New, Open New Sheet. There is no selection in
the ToolbarltemName box, so no toolbar button appears at runtime for the
Report menu item. You do not add a toolbar button here, because you use
the Report menu item to access cascading menu items rather than as a
command to open a new sheet.

Click the Open menu item under the File menu in the WYSIWYG view.
Click the General tab in the Properties view.

Clear the Visible and Enabled check boxes on the General page of the
Properties view.

You hide the Open menu item in all runtime menus. When you clear the
Visible property, the WYSIWYG view displays the menu item with a
dithered (broken) appearance. It is not visible at runtime. When you clear
the Enabled property, the WYSIWIG view displays the menu item with a
very faint and inverted relief appearance. If it is visible at runtime, the
menu item will still be grayed out.

File Edit Window Help
Report L4

Print Setup...

Toolbars...

Exit

Click the Toolbar tab of the Properties view.
Clear the ToolbarltemVisible check box.

This prevents the toolbar button for this menu item from appearing in the
frame menu toolbar (a button can be included in a toolbar even if its
corresponding menu item is not visible or enabled).
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7 Click Exit under the File menu in the WYSIWYG view.

The Toolbar page of the Properties view remains open. The
ToolbarltemText and ToolbarltemName values change to show the values
for the m_exit menu item.
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Enable Help menu items
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The Help menu has three items, but only one, Help>About, is enabled. Now
you enable the other menu items, using commented-out code that was provided
by the Template Application wizard and the pbtutor.chm file in the Tutorial
directory.

You call application Help topics with the ShowHelp function, passing it an
enumerated value that identifies whether you want the Help contents or index
to display, or a specific topic or keyword. ShowHelp can open Windows Help
or compiled HTML Help (CHM) files.

1 Click the Help menu in the WYSIWYG view and then double-click the
Help Index menu item.

You can double-click the Help Index item even though it is not currently
enabled. The full name of the Help Index menu item,
m_help.m_helpindex, displays in the Script view. It includes the m_help
prefix to indicate that it is in the Help menu.

2 Select Clicked in the second drop-down box if it is not already
selected.

3 Position the cursor in the line that contains the ShowHelp function
and click the Uncomment button in the PowerBar.
Change myapp.hlp to pbtutor.chm:

ShowHelp ("pbtutor.chm", Index!)

This displays the default topic in the Help file.

4 Select the Enabled check box on the General page of the Properties
view for the m_helpindex menu item.

5 Repeat the preceding steps for the Search For Help On menu item
using the following Show Help function.

ShowHelp ("pbtutor.chm", Keyword!, "")

If the third argument contained a string that was a keyword in the Help file,
the associated topic would display. Because the argument is an empty
string, the Help Search window displays.

6 Select File>Save from the main PowerBuilder menu bar.
Select File>Close from the main PowerBuilder menu bar.
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Create a new sheet menu

Where you are
Modify the frame menu
> Create a new sheet menu
Add menu scripts to trigger user events
Attach the new menu and run the application

Now you create a new menu that displays whenever the user opens an MDI
sheet to look at customer or product information. The menu you create is a
descendant of the m_pbtutor _sheet menu that was generated by the Template
Application wizard.

The m_pbtutor sheet menu inherits in turn from m_pbtutor frame, but has
some additional menu items enabled. In the menu you create, you add menu
items that are not present in the ancestor menus.

In this exercise you:
¢ Inherit and save a new menu
¢ Add items to the new menu

¢ Add a new toolbar for the new menu items

Getting Started 153



Create a new sheet menu

Inherit and save a new menu
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By inheriting from the application sheet menu, you retain the sheet menu
characteristics without modifying the ancestor menu. It is good practice to save
the new menu immediately, then save it again after you modify it.

1 Click the Inherit button in the PowerBar.

The Inherit From Object dialog box displays.

2 Make sure Menus is selected in the Objects of Type drop-down list
box.
Select m_pbtutor_sheet in the Object list box and click OK.

PowerBuilder displays an untitled menu that has all the characteristics of
m_pbtutor_sheet.

On the inherited sheet menu, the Window menu items are enabled to allow
for tiling and cascading windows, just as they are for the m_pbtutor sheet
menu. These items are disabled on the m_pbtutor frame menu.

Changes made to the MDI frame menu
If you click the File menu in the WYSIWYG view, you see that the first

item is now Report. The Open item is dithered to indicate that it is not
visible and is grayed to indicate that it is disabled. These characteristics
were propagated through the inheritance chain from m_pbtutor frame.

3 Select File>Save from the menu bar.

The Save Menu dialog box displays.

4 Typem my sheet as the menu name in the Menus box.
Type the following line in the Comments box:

New sheet menu for w master detail ancestor and its
descendants.

5 Click OK.

This names the menu. The prefix m_ is standard for menus.

The name you just assigned to the new menu displays in the title bar of the
Menu painter workspace and the m_my_sheet menu appears in the system
tree.
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Add items to the new menu

Getting Started

Next you add items to the Edit menu of the menu you just inherited from
m_pbtutor_sheet. You use the WYSIWYG and Properties views.

1 Click the Edit menu in the WYSIWYG view for the new menu.

The list of Edit menu items appears just as it would in a runtime
application. All items of the Edit menu are visible but disabled (they
appear gray—but not dithered—in the WYSIWYG view).

2 Right-click a menu item under the Edit menu in the WYSIWYG view.
Select Insert Menu Item At End from the pop-up menu.

The cursor moves into a blank box that appears at the end of the Edit menu
list.

3 Click in the box that appears at the bottom of the menu, and type -
(hyphen). Press Enter.

The hyphen changes into a separator line. In the Properties view, the menu
item name changes to m 0. Even the separator lines between menu items
must have unique names. Other separator lines in the menu have a unique
index number preceded by the prefix m_dash.

4 Clear the Enabled check box in the Properties view for the new
separator line.

5 Right-click the new separator line in the WYSIWYG view.
Select Insert Menu Item At End from the pop-up menu.
Type sInsert in the box that appears under the new separator and
press Enter.

The menu item name is set automatically to m_insert. If PowerBuilder
displays a message that the default name is incorrect, it suggests an
alternative name. If this occurs, click OK to accept the suggested name.

Alternative method of inserting menu item names
You can type &lInsert in the Text box in the Properties view instead of

typing it in the box that appears in the WYSIWYG view. In this case, you
do not need to press Enter afterwards. First, however, you have to clear the
Lock Name check box if the Name box is grayed (otherwise, the menu
name does not reset to m_insert).
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Type Insert a row in the MicroHelp box in the Properties view.

The new menu item is visible and enabled by default.

The text Insert a row displays in the MicroHelp line at the bottom of
the application window whenever the user selects the menu item.

Repeat steps 5 and 6 for the following menu items:

Menu item

MicroHelp text

Upd&ate

Update the database

&Delete

Delete the current row

You add Edit menu items for updating and deleting database records. Even
though it is not enabled, the Undo item already uses the letter U as an
accelerator key, so you should not use the same accelerator key for the
Update menu item. Instead, you use the letter A for this purpose.

, .
[ommy sObx| | gile PETH Window Help

-5 m_my_shes
B &File =
=3 &Edit

Cu
aC

Cle
&l

Upr
&D

Bvinde
&Help

]
=

[l
=

Insert
Update

Delete

. -
|7 Properties - m_edit inherited from m_edit O] x|

General |Toolbar

m_pbtutor_sheet::m_edit
Lock Mame
Text
&Edit
MicroHelp

Tag

MenuAnimation
Visible
Enabled

Checked
7] Mmool

"

m
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Add a new toolbar for the new menu items

Getting Started

Now you add toolbar buttons for the menu items you just defined and then
place them in a second toolbar.

1 Click the new Insert menu item in the WYSIWYG view Edit menu.

2 Click the Toolbar tab in the Properties view.
Type Insert in the ToolbarltemText box.
Type or select Insert! in the ToolbarltemName drop-down list.

This defines a toolbar button for the Insert menu item that uses the stock
picture called Insert!. When the Show Text option in the runtime
application is enabled for toolbars, the text Insert appears on the button.

3 Type or click to 1 in the ToolbarltemSpace spin control.
Type or click to 1 in the ToolbarltemOrder spin control.
Type or click to 2 in the ToolbarltemBarindex spin control.

When you start a new toolbar for the added menu items, the Insert button
will be the first item in this toolbar.

4 Click the new Update menu item in the WYSIWYG view Edit menu.
Make sure it is also displayed on the title bar in the Properties view.

5 Click the Toolbar tab if the Toolbar page is not already open.
Type Update in the ToolbarltemText box.
Type or select Update! in the ToolbarltemName drop-down list box.

This defines a toolbar button for the Update menu item that uses the stock
picture called Update!. The button text is Update.

6 Type or click to 2 in the ToolbarltemOrder spin control.
Type or click to 2 in the ToolbarltemBarindex spin control.

This will add the Update button after the Insert button in the new toolbar.

7 Click the new Delete menu item in the WYSIWYG view Edit menu.
Make sure it is also displayed on the title bar in the Properties view.

8 Click the Toolbar tab if the Toolbar page is not already open.
Type Delete in the ToolbarltemText box.
Type or select DeleteRow! in the ToolbarltemName drop-down list
box.
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This defines a toolbar button for the Delete menu item that uses the stock
picture called DeleteRow!. The button text is Delete.

9 Type or click to 3 in the ToolbarltemOrder spin control.
Type or click to 2 in the ToolbarltemBarindex spin control.

You add the Delete button after the Update button in the new toolbar.

10 Select File>Save from the PowerBuilder menu bar.
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Add menu scripts to trigger user events

Getting Started

Where you are
Modify the frame menu
Create a new sheet menu
> Add menu scripts to trigger user events
Attach the new menu and run the application

Now you add scripts to trigger user events from the sheet window menu bar.
You added these user events in Lesson 5, Modifying the Ancestor Window.
The Menu painter should still be open for the m_my_sheet menu. If it is not,
you can open it using the Open button in the PowerBar.

1 Select m_edit.m_insert in the first list box in the Script view
or
Double-click the Insert menu item in the WYSIWYG view.

The full name of the Insert menu item displays in the first list box of the
Script view. It includes the m_edit prefix to indicate that it is in the Edit
menu.

2 Select Clicked in the second drop-down box if it is not already
selected.
Type these lines for the Clicked event:

w master detail ancestor lw_activesheet
lw_activesheet = w pbtutor frame.GetActiveSheet ()
lw _activesheet.EVENT ue insert ()

The first two lines determine which sheet in the MDI frame is currently
active. The third line triggers the user event ue_insert for the active sheet.

3 Repeat steps 1 and 2 for the following menu items and scripts:

Menu name Script for Clicked event

m_edit.m_update | w_master detail ancestor lw_activesheet
lw_activesheet=w_pbtutor _frame.GetActiveSheet()
Iw_activesheet. EVENT ue_update()
m_edit.m_delete w_master_detail ancestor lw_activesheet

Iw_activesheet = w_pbtutor frame.GetActiveSheet()
Iw_activesheet. EVENT ue_delete()

159



Add menu scripts to trigger user events

160

Select File>Save from the PowerBuilder menu bar.

PowerBuilder compiles and saves the menu scripts.

Click the Close button in PainterBar1
or

Select File>Close from the PowerBuilder menu bar.
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Attach the new menu and run the application

Getting Started

Where you are
Modify the frame menu
Create a new sheet menu
Add menu scripts to trigger user events
> Attach the new menu and run the application

Now you attach the new sheet menu and run the application again.

Double-click w_master_detail_ancestor in the System Tree.

If you cannot see the Properties view
Select View>Properties from the menu bar.

The menu listed in the MenuName box in the Properties view of the
Window painter is still m_pbtutor sheet.

Click the ellipsis button next to the MenuName box.

The Select Object dialog box displays.

Select m_my_sheet in the Menus list box and click OK.

This is the sheet menu you modified after inheriting it from
m_pbtutor sheet. It is now listed as the menu name in the Properties view.

Click the Save button in PainterBar1.
Click the Run button in the PowerBar.

The application login window displays.

Type dba in the User ID box.
Type sqgl in the Password box and click OK.

The database connection is established, and the MDI frame for the
application displays. The File menu now includes a Report cascading
menu in place of the New menu item. The Open menu item is no longer
visible.
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Select File>Report>Maintain Customers from the menu bar.

Notice that a second toolbar appears and the Edit and Window cascading
menus include enabled menu items.

Select the Edit menu.

The Edit menu has the Insert, Update, and Delete options you added.
These options do not function yet, because the DataWindow controls in
the Customer window do not have DataWindow objects associated with
them.

Select the Window menu.

Notice that a new menu item has been added for the sheet you just opened.

Select File>Report>Maintain Products from the menu bar.

A second MDI sheet opens. This sheet cascades relative to the first sheet.
The menu bar does not change. That is because m_my_sheet is the menu
for both w_customers and w_products.

Select the Edit menu.

Because the w_products window uses the m_my_sheet menu, the Insert,
Update, and Delete options are also available when the Product window is
open.

Select the Window menu.

Another menu item has been added for the second sheet you opened. The
checkmark next to this menu item indicates that it is the active sheet.

Select File>Exit from the menu bar.

The application terminates and you return to the Window painter
workspace.

Close the Window painter.
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LESSON 7

Getting Started

Building DataWindow Objects

The DataWindow object is one of the most powerful and useful features

of PowerBuilder. A DataWindow object can connect to a database,

retrieve rows, display the rows in various presentation styles, and update
the database.

In this lesson you:

Create and preview a new DataWindow object

Save the DataWindow object

Make cosmetic changes to the first DataWindow object
Create a second DataWindow object

Make cosmetic changes to the second DataWindow object

How long does it take?
About 20 minutes.
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Create and preview a new DataWindow object

Create and preview a new DataWindow object

Where you are
> Create and preview a new DataWindow object
Save the DataWindow object
Make cosmetic changes to the first DataWindow object
Create a second DataWindow object
Make cosmetic changes to the second DataWindow object

Now you create a new DataWindow object and display it in the DataWindow
painter. Like other painters, the DataWindow painter has an assortment of
views that you can open simultaneously.

About the Design view of the DataWindow painter
The Design view in the DataWindow painter is similar to the Layout view in

other painters. You can open only one Design view at a time.

The Design view is divided into four areas called bands: header, detail,
summary, and footer. You can modify the contents of these bands. For example,
you can change their sizes, add objects (controls, text, lines, boxes, or ovals),
and change colors and fonts.

In the Preview view of the DataWindow painter, you can see how the object
looks in an application at runtime, complete with table data.

[‘ 1 Click the New button in the PowerBar.
+
K The New dialog box displays.

2 Click the DataWindow tab.
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Getting Started

3

Select Tabular from the list of presentation styles.

New u

Target: @ pbtutor {C:\Wserswanghui\Documents\Appeon'PowerBuilder 17.0YTutorial) -
| Workspace I Target I Library I PB Ob]ect| Datawindow |Database I Project I Tool

Composite Crossiab Freeform Graph Grid

Group Label N-Up OLE 2.0 RichText
TreeView
OK ] [ Cancel
Click OK.

The Choose Data Source for Tabular DataWindow page of the

DataWindow wizard displays.

-
Choose Data Source for Tabular DataWindow

2 i

Which data source would you like to use?

Quick Select | SGQL Select Query External
8 @ R
Stored Web Service OData Service
Procedure
[V]Retrieve on Preview
< Back Next = ] ’ Cancel
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Select Quick Select as the data source and select the Retrieve On
Preview check box if it is not already selected.
Click Next.

PowerBuilder connects to the Demo Database, and the Quick Select dialog
box displays.

Click the customer table in the Tables list box.

This opens the table and lists its columns. For this DataWindow, you will
select four columns.

Click id, fname, and Iname in the Columns list box in the order listed.
Scroll down the list and click company_name.

r M
Quick Select ==
1. Click on table(s) to select or deselect To display comments for a

2. Select one or more columns. table or column, dick
3. (Optional) Enter sorting and the right mouse button.
selection criteria below.
Add all
Tables: Columns:
sales_order
L | b
Comments:
Mame of the company
Calumn: Id Frame Lname Compa =
Sort: [
Criteria:
Qr: -
[EE] I - | 3]
be
L.

PowerBuilder displays the selected columns in a grid at the bottom of the
Quick Select dialog box.

Selection order determines display order
The order in which you select the columns determines their left-to-right

display order in the DataWindow object. If you clicked a column by
mistake, you can click it again to clear the selection.
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Getting Started

You can use the grid area at the bottom of the dialog box to specify sort
criteria (for the SQL ORDER BY clause) and selection criteria (for the
SQL WHERE clause). Now you specify sort criteria only. You sort the id
column in ascending order.

8 Inthe grid area of the Quick Select dialog box, click in the cell next to
Sort and below Id.
A drop-down list box displays.
9 Choose Ascending from the drop-down list box.
This specifies that the id column is to be sorted in ascending order.
" Quick Select ===
1. Click on table(s) to select or deselect To display comments for a oK
2. Select one or more columns. table or column, dick
3. (Optional) Enter sorting and the right mouse button,
selection criteria below.
Tables: Columns:
sales_order
« [Lm ] b
Comments:
Mame of the company
Column: Id Frame Lname Compa =
Sort: | PR 0
Criteria:
Qr: -
4 m 3
L.
10 Click OK.
The DataWindow wizard asks you to select the colors and borders for the
DataWindow object. By default, there are no borders for text or columns.
11 Click Next.

You accept the border and color defaults. The DataWindow wizard
summarizes your selections.
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12 Click Finish.

PowerBuilder creates the new DataWindow object and opens the

DataWindow painter.

In the Design view, PowerBuilder displays a Header band with default
headings and a Detail band with the columns you selected:

|:| (Untitled) * (pbtutor) - DataWindow

i
[ Design - (untitled)
Customer  First Name
1D

Last Name

=[]

Company Name

Header{

id fname Iname

Detail t

fompany_name
"

Summary {

Footert

Al
=

The Preview view displays the DataWindow as it appears during
execution. PowerBuilder displays data for all customers. The data is sorted
in ascending order by customer ID, just as you specified.

laPreview - (untitled)

Customer  First Name Last Name
1D
Wiktmichaels Deviin
102Beth Reiser
103Erin Nigdringhaus
104 Meghan Mason
105Laura McCarthy
106Paul Phillips
107 Kelly Colburn

ol x|

Company Name

The Power Group
AMF Corp.

Darling Associates
P.5.C.

Amo & Sons
Ralston Inc.

The Home Club

Displaying the Preview view

If the Preview view is not displayed, select View>Preview from the menu
bar. If Preview is grayed, it is already displayed and you cannot select it.
You can open only one Preview view at a time.
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Save the DataWindow object

Where you are
Create and preview a new DataWindow object
> Save the DataWindow object
Make cosmetic changes to the first DataWindow object
Create a second DataWindow object
Make cosmetic changes to the second DataWindow object

Now you name the DataWindow object and save it in the pbtutor.pbl library.

Saving to another library
You can save objects to different application libraries, but to avoid

complications, you save all your new tutorial objects in one library. You can
also copy or move objects from one library to another using the Library painter.

1 Select File>Save from the menu bar.

The Save DataWindow dialog box displays with the insertion point in the
DataWindows box.

2 Make sure pbtutor.pbl is selected in the Application Libraries box.
Type d_custlist in the DataWindows box.

This names the DataWindow object. The prefix d_ is standard for
DataWindow objects.

3 (Optional) Type the following comments in the Comments box:

This DataWindow object retrieves customer names and
company associations.

4 Click OK.

PowerBuilder saves the DataWindow object and closes the Save
DataWindow dialog box.
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Make cosmetic changes to the first DataWindow object

170

Where you are
Create and preview a new DataWindow object
Save the DataWindow object
> Make cosmetic changes to the first DataWindow object
Create a second DataWindow object
Make cosmetic changes to the second DataWindow object

Now you can make cosmetic changes to the DataWindow. You reposition the
columns and column headings to make room for the hand pointer, which
displays to the left of the currently selected row. You also move some of the
columns to make them line up with their headings.

You make these changes in the Design view. You can keep the Preview view
open at the same time to see how the changes you make affect the appearance
of the DataWindow at runtime.

1 Select Edit>Select>Select All from the menu bar
or
Press Ctri+A.

All of the controls in the DataWindow object are selected in the Design
view.

2 Position the mouse pointer over one of the selected objects.
Drag the object to the right about one inch.

All of the selected objects move together.

3 Click in a blank area in the Design view.

You clear the object selection.

4 Click the Customer ID header above the Header band.
Hold down the Ctrl key and click the id column above the Detail band.
Release the Ctrl key and drag the id column to the left about one-half
inch.

The column and its header move together.
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Getting Started

Tl

B!

Click the Center button in the StyleBar.
Click in a blank area in the Design view.

This centers the Customer ID column header text and the column data.

Click the First Name header.

Hold down the Ctrl key and click the Last Name and Company Name
headers.

Click the Left button in the StyleBar.

When you have finished, the Design view should look something like this:

[ d_custlist * (pbtutor) (C:\Users\wanghui\Documents\Appeon'PowerBuilder 17 0\ Tutorial\pbtutor.pbl) - |
I =
[ Design - d_custlist =] 3
Customer  First Name Last Name *

Company Name
D Il
Headerf [

id fname Iname
Detail
Summary |
Footert

company_name

< [ ’
|

Select File>Close from the menu bar.

A message box asks if you want to save your changes.

Click Yes.

PowerBuilder saves the DataWindow object and closes the DataWindow
painter.
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Create a second DataWindow object

172

Where you are

Create and preview a new DataWindow object

Save the DataWindow object

Make cosmetic changes to the first DataWindow object

> Create a second DataWindow object

Make cosmetic changes to the second DataWindow object

When you built the first DataWindow object, you used Quick Select to specify
the table and columns. This let you retrieve all the customers without having to
use the Select painter.

To build the second DataWindow object, you use the Select painter. You need
to define a retrieval argument and WHERE criteria so you can pass an
argument to the DataWindow object during execution. In this case, you will
pass the customer ID.

In this section, you:

Select the data source and style

Select the table and columns

Define a retrieval argument

Specify a WHERE clause

View the DataWindow in the DataWindow painter

Save the DataWindow object
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Select the data source and style

Now you select a data source and define how the data is to be presented.

[l 1 Click the New button in the PowerBar.
+
M The New dialog box appears.

2 Click the DataWindow tab if it is not already selected.
Select Freeform from the list of presentation styles and click OK.

3 Select SQL Select as the data source and select the Retrieve On
Preview check box if it is not already selected.

Since the data source is SQL Select, you go to the Select painter and the
Select Tables dialog box displays.

Selecting the Retrieve On Preview check box allows you to view the data
returned by a query in the development environment, but you need to
provide initial values for any retrieval arguments that you specify.

4 Click Next.
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Select the table and columns

174

Now you select the table and the columns to use in the DataWindow object.

Select customer in the list of tables and click Open.

The Select painter displays the customer table and its columns.

Alternative method
If you double-click the customer table instead of selecting it and clicking

Open, the Select Tables dialog box remains open. In this case, you must
click Cancel to continue.

Right-click the header area in the Table Layout view.
Choose Select All from the pop-up menu.

The column names appear in the Selection List area above the table.

The columns appear in the order in which you selected them. Because you
selected all the columns at once, the original order of the columns in the
database is used. You change the column presentation order later.

You can also see the selection order in the Syntax view: click the Syntax
tab at the bottom of the stack of tabbed panes to display the generated
Select statement.

inteqer ique Identification number of the customer
char{ ame of the customer

Code where the cu
char(12) Phone number of the customer
company_name Company Name: char(35) Name of the compan

| 3
—

Drag and drop columns in the order in which you want

“tustomer”,id” -

“customer”, “fname”

“customer”, Tname”

“tustomer”, "address™

“customer”, "city”

“customer”, “state”

“customer”,"zip"” -

Sort (iPere) Gaup g Compe s iz A
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Define a retrieval argument

Now you define a retrieval argument.

1 Select Design>Retrieval Arguments from the menu bar.

The Specify Retrieval Arguments dialog box displays.

2 Type cust id in the Name box.

The default data type is Number, which is what you want.

Specify Retrieval Arguments

Argument %
K
Position Mame Type

:[_j.‘ |_1 cust_id Murmber -

Cancel

Help

Insert

Delete

Dk BE g

About retrieval argument names
You can choose any name you want for the retrieval argument; it is just a

placeholder for the value you pass during execution. Nonetheless, it is a
good idea to make the name meaningful.

3 Click OK.

The retrieval argument is defined.

Getting Started 175



Create a second DataWindow object

Specify a WHERE clause

Now you specify a WHERE clause using the retrieval argument to retrieve a
specific customer.

1 Click the Where tab in the stack.
The Where view displays.

2 Click in the box below Column in the Where view.

A down arrow displays, and the box becomes a drop-down list box.

3 Select "customer"."id".

Your selection displays immediately below the Column heading. An equal
sign (=) appears in the Operator box. This is correct, so do not change it.

Column | Operator | Value | Logical
customer”."id" |=

Kot where Fam}ame) Corpri )y AN

4 Right-click in the box below the Value column header in the Where

view.
Select Arguments from the pop-up menu, select : cust_id, and click
Paste.
= 5]
Column Cperator Value Logical
“customer™,id” = scust_id And

N ey e e T A
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5 Click the Syntax tab in the stack.
The Syntax view displays the modified SELECT statement.

6 Scroll down until you see the generated WHERE clause.

You have now created a complete SQL SELECT statement that retrieves
data from several columns in the customer table where the id column is
equal to an argument that will be supplied during execution.
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View the DataWindow in the DataWindow painter

Now you view the DataWindow in the DataWindow painter using the Design
and Preview views.

1 Click the Return button in the PainterBar
or
Select File>Return To DataWindow Painter from the menu bar.

The DataWindow wizard asks you to select the borders and colors for the
new DataWindow object.

2 Select Raised from the Border drop-down list box for columns.
Click Next.

You have added raised borders to the DataWindow columns, but not to the
labels. The DataWindow wizard summarizes your selections.

3  Click Finish.

Because you selected the Retrieve On Preview check box and because the
Preview view is part of the default layout scheme for the DataWindow
painter, the Specify Retrieval Arguments dialog box appears.

This dialog box prompts you for an argument value. When you put this
DataWindow object into the tutorial application, you write a script that
passes the required argument to the DataWindow object automatically.

Specify Retrieval Arguments IéJ
Argument
Position MName Type Value
77 |1 |ustd fumber [] il

R.emember retrieval arguments

Ok ] [ Cancel Cancel All

4 Type a customer ID (such as 101, 102, or 103) in the Value field.
Click OK.
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Getting Started

The DataWindow painter opens. The Design view displays the new

DataWindow object.
[T d_customer * (pbtuter) (c\users\wanghui\documents\appeon\powerbuilder 17
L |
laDes'gw - d_customer Ly
Header{

Ol x|

Customer ID: id

First Name: fname
Last Name: Iname

Company Name: company_name

Phone Number: phane

Address: address

City: city

State: state
Zip Code: zip
Detail t
Summary {
Footer {

Changing font sizes

If you cannot see all letters in a label, press Ctrl+A to select all the items
in the DataWindow, then select a smaller font size in the StyleBar.

The DataWindow Preview view retrieves the requested customer data.

=

+

L
[ Preview - d_customer
Customer ID: 101

First Name: Michaels
Last Name: Devlin

Company Name: The Power Group

Phone Number: (201) 555-8966

Address: 3114 Pioneer Avenue

City: Rutherford
State: NJ

Zip Code: 07070-
l 4 n

ol x|

m
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Create a second DataWindow object

Retrieving other records
If you want to preview the record for another customer, you can right-click

inside the DataWindow Preview view, select Retrieve from the pop-up
menu, then specify a different customer ID in the Specify Retrieval
Arguments dialog box.
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Save the DataWindow object

Getting Started

Now you name the DataWindow object and save it. You could wait to save it
until you leave the painter, but it is good practice to save your work frequently.

1

Select File>Save from the menu bar.

The Save DataWindow dialog box displays.

Make sure pbtutor.pbl is selected in the Application Libraries box.
Type d_customer in the DataWindows box.

Earlier you saved a DataWindow object as d_custlist.

(Optional) Type the following comments in the Comments box.

This DataWindow retrieves all columns for the
Customer table. It is useful as a detail DataWindow.

Click OK.
[ Save DataWindow ﬁ
DataWindows:
d_customer
d_custlst

Comments:

This DataWindow retrieves all columns for the Customer table, Itis usefulasa =
detail DataWindow,

Application Libraries:

C: \JJsers\,U\anghm\,Documents\Appeon\PomerBwIder 1? D\,Tubarlal\,mbarjb phbl

h

You return to the DataWindow painter.
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Make cosmetic changes to the second DataWindow object

Make cosmetic changes to the second DataWindow
object

Where you are
Create and preview a new DataWindow object
Save the DataWindow object
Make cosmetic changes to the first DataWindow object
Create a second DataWindow object
> Make cosmetic changes to the second DataWindow object

Now you modify the DataWindow object. You:
*  Rearrange the columns and labels
e Align the columns and labels

* Display the arrow for a drop-down DataWindow edit style

Columns on freeform DataWindows
Data fields on freeform DataWindow objects are still called columns, even

though they are shown in a nontabular display.
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Rearrange the columns and labels

Getting Started

Now you rearrange the columns and labels in the new DataWindow object. You
can maximize the Design view for greater ease in manipulating the columns
and their labels.

1 Click the Address: label in the Design view.
Hold the Ctrl key and click the address column.

The two items are selected.

2 Keep the Ctrl key pressed and click the following column labels and
column controls:

Label Column
City: city
State: state

Zip Code: Zip

If necessary, scroll down until you can see all the columns in the
DataWindow.

3 Release the Ctrl key.
Position the cursor on one of the selected objects and drag it to the
top-right corner of the DataWindow object.

The objects move together.

4 Use the Ctrl+click technique to move the following label and column
controls to the location indicated:

Label Move with column Move under
Company Name: company name Last Name:
Phone Number: phone Company Name:

5 Drag the Detail band up below the last column label.
This removes any extra space at the bottom of the detail area.

Some of the fields might be misaligned. You fix this in the next exercise.
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Make cosmetic changes to the second DataWindow object

Align the columns and labels

Now you align the columns and labels on the new DataWindow.

1 Select the Zip Code: label in the Design view.
Move left edge of the Zip Code: label’s text close to the right edge of
the company_name column.

2 While the Zip Code: label is still selected, use the Ctri+click technique
to select the Address:, City:, and State: labels.

3 Select Format>Align from the menu bar.

A cascading menu of align options displays.

O+ | ef 4 Select the first option (Align left).
e et

PowerBuilder aligns the left edges of the selected objects with the left edge
of the first item you selected (the Zip Code: label).

Selecting an alignment tool from the PainterBar
You can access a drop-down list of alignment tools by clicking the Align

button on PainterBar2.

5 Move the zip column so that it is next to the Zip Code: label.
Align the address, city, and state columns with the zip column, just as
you aligned the column labels.

The DataWindow should now look like this in the Design view:

!
laDesg'l -d_customer ol =]
Customer ID: id Address: address | |5
[
First Name: fname City: city
Last Name: Iname State: state
Company Name: company_name IZip Code: zip | +
Phone Number: phane
Detail t
Summary {
Footer {

< [ r
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The DataWindow Preview view looks like this:

4 ol x|
Customer ID: 101 Address: 3114 Pioneer Avenue
First Name: Michaels | City: Rutherford |
Last Name: Devlin | State:NJ_l
Company Name: The Power Group l} |Ep Code: 07070- |
Phone Number: (201) 555-896
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Make cosmetic changes to the second DataWindow object

Display the arrow for a drop-down DataWindow edit style

186

The column for the customer state of residence has a DropdownDataWindow
edit style. This is an extended attribute associated with the State column in the
Demo Database. The (drop-down) DataWindow with which the column is
associated has a list of states and their two-letter postal codes.

You can make the state selection list visible at all times in your application or
you can display an arrow at all times to indicate that a selection list is available.
Now you change the property for the state column to show the arrow at all
times.

1 Click the state column in the Design view.
Make sure the Properties view displays.

The Properties view displays properties of the column.

2 Click the Edit tab in the Properties view.

You might need to click the arrow keys near the top of the Properties view
to display the Edit tab before you can click it. Notice that the Style Type
selection is DropDownDW.

3  Select the Always Show Arrow check box.
Make sure the state column in the Design view is wide enough to
display two characters plus the arrow symbol.

An arrow appears next to the state column in the Design and Preview
views. While the column is selected in Design view, you can make the
column wider by holding the cursor over the right edge of the column until
the cursor symbol changes to a double-headed arrow, then dragging the
edge toward the rightmost frame of the view.

[ Design - d_customer olx|
Header{ -
Customer ID: id Address: address
First Name: fname City: city
Last Name: Iname State: state v
Company Name: company_name |zip Code: zip |
Phone Number: phone
Detail
Summary|
Footer!
1] b

4 Click the Save button in PainterBar1.
Click the Close button in PainterBar1.
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LESSON 8

Getting Started

Attaching the DataWindow
Objects

After you create and save a DataWindow object, you can use it in a
window. You have already created the d_custlist and the d_customer
DataWindow objects. Now you associate each of these DataWindow
objects with a DataWindow control in the w_customers window.

In this lesson you:

Attach the DataWindow object to the master DataWindow control
Attach the DataWindow object to the detail DataWindow control
Run the application

Attach DataWindow objects to the Product window

Run the application again

How long does it take?
About 15 minutes.
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Attach the DataWindow object to the master DataWindow control

Attach the DataWindow object to the master
DataWindow control

Where you are

> Attach the DataWindow object to the master DataWindow control
Attach the DataWindow object to the detail DataWindow control
Run the application
Attach DataWindow objects to the Product window
Run the application again

Now you attach the DataWindow object to a DataWindow control in the
w_customers window.

1 Expand the pbtutor.pbl branch in the System Tree.
=
E|-- MyWorkspace (C:\Userswanghui\Documents\Ap
E|® pbtutor (C:\Users\wanghui\Document
- pbtutor. pbl {C:YUsers\wanghui\Documen:
{29 pbtutor
+ D d_custlist
D d_customer
m_my_sheet
m_pbtutor_frame
m_pbtutor_sheet
n_pbtutor_connectservice
+ n_pbtutor_sheetmanager
Bl csoners
D w_master_detail_ancestor
D w_pbtutor_about
D w_pbtutor_basesheet
D w_pbtutor_frame
D w_pbtutor_toolbars
D w_products
BD w_welcome
(-7 Properties
(-7 Events
(-3 Functions
[ Structures
(-] Controls
[-M% tutor_pb.pbl (C:Userswanghui\Documer

4 I 2

2 Right-click w_customers and select Edit from the pop-up menu
or
Double-click w_customers in the System Tree.

The Window painter displays the w_customers window.

3 Right-click the top DataWindow control (dw_master) in the Layout
view.
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Getting Started

If the Properties view is not displayed, select Properties from the
pop-up menu.

Click the ellipsis button next to the DataObject box in the Properties
view.

The Select Object dialog box displays.

Select d_custlist in the DataWindows list box and click OK.

PowerBuilder associates the d_custlist DataWindow object with the
dw_master DataWindow control.

The Layout view now shows the d_custlist DataWindow headings inside
the dw_master control, but you do not see any data yet. The DataWindow
does not execute its SELECT statement until you run the application.

(| w_customers * (pbtutor) (C\Users\wanghui\Decuments\Appecn'\PowerBuilder... EI @

L L
& Layout K 0| %] |[oProperties - dw_detail inhe I} x}
. s . * | General
Customer  First Name ~ Last Name L
1]
w_master_detail_ancestor::dw
DataChject

RichText Toolbar Activation M...

richtexttoolbaractivationor v

Title

Tag

[¥] visible
m -
L : 7] Enabled

= = [ TitleBar il

Layout open xEvent List sFunction List sDedare Instance Variables

L hProperties Control List Nonfvj

Adding DataWindow objects to the window using drag and drop
In this tutorial, you use a custom DataWindow control that has built-in error

handling. If you want to use the standard DataWindow control, you do not need
to add the control to the window and then attach a DataWindow object to it as
you did in this lesson. You can simply select the DataWindow object you want
from the System Tree and drag it onto the window in the Layout view.

PowerBuilder creates the DataWindow control for you.




Attach the DataWindow object to the detail DataWindow control

Attach the DataWindow object to the detail
DataWindow control

190

Where you are

Attach the DataWindow object to the master DataWindow control
> Attach the DataWindow object to the detail DataWindow control

Run the application

Attach DataWindow objects to the Product window

Run the application again

Now you attach a DataWindow object to the detail DataWindow control. The
Window painter should still be open for the w_customers window.

1 Select the bottom DataWindow control (dw_detail) in the Layout view.
Click the ellipsis button next to the DataObject box in the Properties
view.

Select d_customer in the Select Object dialog box and click OK.

PowerBuilder associates the d_customer DataWindow object with the
dw_detail DataWindow control. The Window painter workspace now
shows the d_customer DataWindow object inside the dw_detail control.

2 In the Layout view, make the dw_detail control larger so that you can
see all of the columns you added to the DataWindow object.

If you need to, you can also enlarge the window to make more room. If you
make the dw_detail control wider, you may also want to make the
dw_master control the same width.

| Tt [=1ES]|

Customer  First Name Last Name Company Name [
1D

Customer ID:_I Address:
First Name: | City: |
Last Name: I State: :I
Company Name: |I|p Code: - |
Phone Number: [ ) -
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Lesson 8 Attaching the DataWindow Objects

Run the application

Getting Started

§ @

Where you are

Attach the DataWindow object to the master DataWindow control

Attach the DataWindow object to the detail DataWindow control
> Run the application

Attach DataWindow objects to the Product window

Run the application again

Now you run the application again to test the insert, update, and delete
capabilities of the second DataWindow.

1 Click the Run button in the PowerBar.

PowerBuilder prompts you to save your changes.

2 Click Yes.

The application begins running, and the login window displays.

3 Type dba in the User ID box.
Type sql in the Password box and click OK.

The database connection is established, and the MDI frame for the
application displays.
4 Select File>Report>Maintain Customers from the menu bar.

The Customer window displays.

& Maintain Custemers:1 EI@
I
Y
Customer First Name Last Name Company Name =
—" (
I | 1 Michaels Devlin The Power Group
102 Beth Reiser AMF Corp.
103 Erin Niedringhaus Darling Associates
104 Meghan Mason P.5.C.
105 Laura McCarthy Amo & Sons
106 Paul Philips Ralston Inc.
Customer ID: 101 Address: 3114 Pioneer Avenue
First Name: Michaels I City: Rutherford
Last Name: Devin State: NJ :l
Company Name: The Power Group |Z'|p Code: 07070- |
Phone Number: (201) 555-896
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Run the application

192

The top DataWindow control (dw_master) shows all of the rows retrieved
from the Customer table. The hand pointer shows which row is selected.

The bottom DataWindow control (dw_detail) shows further information
about the selected customer.

In the running application, click the Insert button in the toolbar
or
Select Edit>Insert from the Frame window menu bar.

This clears (resets) the dw_detail DataWindow, allowing you to add
information for a new row that you will insert into the data source. The
cursor is in the Customer ID box in the dw_detail control.

Add a new customer row by entering information in the boxes in the
detail DataWindow.

Typing information for a new customer
The Customer ID number must be unique. To avoid duplicate numbers,

use a four-digit number for your new database entry, or scroll down the list
of three-digit customer numbers in the master DataWindow and select an
ID number that does not appear in the list.

Enter values for the remaining fields.

The phone number and zip code use edit masks to display the information
you type. You must enter numbers only for these data fields. To specify the
state in which the customer resides, you must click the arrow next to the
state column and select an entry from the drop-down list box.

Click the Update button in the toolbar
or
Select Edit>Update from the menu bar.

This sends the new customer data to the database and displays a
confirmation message, as coded in the script for the ue_update event.

The new customer does not yet display in the master DataWindow. (You
could add code to include this feature). However, if you open another
instance of the w_customers sheet, the new customer data is visible in both
the master and detail DataWindow controls.
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Lesson 8 Attaching the DataWindow Objects

8 Click OK in the message box.
Click a customer in the master DataWindow.

That customer data displays in the lower DataWindow.
9 Change the customer address in the detail DataWindow.

10 Click the Update button in the toolbar
or
Select Edit>Update from the menu bar.

This sends the revised customer data to the database and displays another
confirmation message.

11 Click OK in the message box.
Select another customer in the master DataWindow.

That customer data displays in the detail DataWindow.

12 Click the Delete button in the toolbar
or
Select Edit>Delete from the menu bar.

The customer is deleted from the DataWindow immediately but is not
deleted from the database unless you select the Update option on the Edit
menu. In this particular situation, the Update operation may fail, because
rows in other tables in the Demo Database may refer to the row that you
are trying to delete.

You should be able to delete any row that you have added to the database.

13 Select File>Exit from the menu bar.

The application terminates and you return to the Window painter.

14 Close the Window painter.
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Attach DataWindow objects to the Product window

Attach DataWindow objects to the Product window

194

Where you are
Attach the DataWindow object to the master DataWindow control
Attach the DataWindow object to the detail DataWindow control
Run the application

> Attach DataWindow objects to the Product window
Run the application again

Now you add two DataWindow objects to the w_products window. These
DataWindow objects are provided for you in the tutor _pb.pbl library.

1 Right-click w_products in the System Tree and select Edit from the
pop-up menu
or
Double-click w_products in the System Tree.

The Window painter displays the w_products window.

2 If the Control List view is not open, select View>Control List from the
View menu.
Select the dw_master DataWindow control in the Control List view.
Click the ellipsis button next to the DataObject box in the Properties
view.

PowerBuilder displays the Select Object dialog box.

3  Select tutor_pb.pbl in the Application Libraries box.
Select d_prodlist in the DataWindows box and click OK.

The Data Object box in the Properties view of the Window painter now
displays d_prodlist.
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Lesson 8 Attaching the DataWindow Objects

PowerBuilder associates the d_prodlist DataWindow object with the
dw_master DataWindow control in the w_products window. You see the
headings for the DataWindow object in the Layout view. You might need
to resize the control and/or the window.

Layout

Product  Product Name Product Description Unit Price TR

4 Click the dw_detail DataWindow control in the Control List view.
Click the ellipsis button next to the DataObject box in the Properties
view.

The Select Object dialog box displays.

5 Select tutor_pb.pbl in the Application Libraries box.
Select d_product in the DataWindows list box and click OK.

PowerBuilder associates the d product DataWindow object with the
dw_detail DataWindow control. The Layout view now shows the
d_product DataWindow object inside the dw_detail control. The
d_product DataWindow object has seven columns labeled Product ID,
Product Name, Product Description, Size, Color, Quantity, and Unit Price.

If necessary, in the Layout view, make the dw_detail control larger so that
you can see all of the columns in the DataWindow object. You can also
enlarge the window to make more room.
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Run the application again

Run the application again

E®

196

Where you are

Attach the DataWindow object to the master DataWindow control
Attach the DataWindow object to the detail DataWindow control
Run the application

Attach DataWindow obijects to the Product window

> Run the application again

Now you run the application again to test the Product window.

At this point the Product window should have all of the capabilities of the
Customer window. Like the Customer window, the Product window functions
as a master/detail window, providing support for retrieval, insert, update, and
delete operations against the database.

Click the Run button in the PowerBar.

PowerBuilder prompts you to save your changes.

Click Yes.

The application begins running, and the login window displays.

Type dba in the User ID box.
Type sgl in the Password box and click OK.

The database connection is established, and the MDI frame for the
application displays.

Select File>Report>Maintain Products from the menu bar.

The Product window displays. The top DataWindow control shows all of
the rows retrieved from the Product table.
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Getting Started

The bottom DataWindow control shows information about the product
selection in the top DataWindow control.

"g Frame =NACE X
File Edit Window Help
=L s
o 2 o
:& Maintain Products:1 EI@
Product  Product Name Product Description Unit Price i
| Tee Shit Tank Top 59.00 3
Tee Shirt V-neck $14.00
Tee Shirt Crew Neck $14.00
Baseball Cap Cotton Cap $9.00
Product ID: 300 Color: [White |
Product Name: Quantity:
Product Description: [Tank Top Unit Price: $9.00
Size:

Select Edit>Insert from the menu bar.

This clears the dw_detail DataWindow and allows you to add a new row
to the DataWindow. The cursor is in the Product ID box in the dw_detail
control.

Add a new product row by entering information in the boxes in the
lower DataWindow.

Use the Tab key to move from box to box.

Select Edit>Update from the menu bar.

This sends the new product data to the database and displays a
confirmation message, as coded in the script for the ue_update event.

The new product does not display yet in the top DataWindow, but if you
open another product sheet, the new information displays. If you want, you
can add code to the Clicked event of the update button to automatically
refresh the data in the master DataWindow control.
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Run the application again

8 Click OK in the message box.
Click a product in the master DataWindow.

That product data displays in the detail DataWindow.

9 Change the product’s unit price.
Select Edit>Update from the menu bar.

This sends the revised product data to the database and displays another
confirmation message.

10 Click OK in the message box.
Select another product in the master DataWindow.

That product’s data displays in the detail DataWindow.

11 Select Edit>Delete from the menu bar.

The product is deleted from the DataWindow immediately but is not
deleted from the database until you select the Update option on the Edit
menu.

12 Select File>Exit from the menu bar.

The application closes and you return to the Window painter.

13 Close the Window painter.
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LESSON 9

Getting Started

Running the Debugger

Sometimes your application does not behave the way you think it will.
Perhaps a variable is not being assigned the value you expect, or a script
does not do what you want it to. In these situations, you can closely
examine your application by running it in debug mode.

In debug mode, you can set breakpoints (stops) in scripts and functions,
step through the code line by line, and display the contents of variables to
locate logic errors and mistakes that result in errors during execution.
When you run your application in debug mode, PowerBuilder suspends
execution just before it hits a line containing a breakpoint. You can then
look at and correct the values of variables.

In this lesson you:
*  Add breakpoints in application scripts
*  Run in debug mode

*  Set a watch and a conditional breakpoint

How long does it take?
About 20 minutes.
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Add breakpoints in application scripts

Add breakpoints in application scripts

Where you are

> Add breakpoints in application scripts
Run in debug mode
Set a watch and a conditional breakpoint

Now you open the Debugger and add breakpoints to examine the behavior of
the login and Customer windows. When PowerBuilder runs the application in
debug mode, it stops just before executing a line containing a breakpoint.

When you insert breakpoints in a script, you should select lines that contain
executable statements. If you try to set a breakpoint in variable-declaration
lines, comment lines, or blank lines, PowerBuilder sets the breakpoint at the
next executable line.

1 Click the Debug button in the PowerBar.

PowerBuilder opens the Debugger. There are three stacks of tabbed panes
in the default view layout scheme. The Source view is visible in a single
pane at the top left of the Debug window. The Source Browser view is
open in the pane at the top right.

If the Debug window looks different
If you have opened the Debug window before and opened, moved, or

closed any views, your display may look different. To restore the default
view layout scheme, select View>Layouts>Default from the menu bar.

L
> open ( string commandiine ) for pbtutor
= *!
/{* open: Application Open Script:
I 1) Opens frame window

= *f

-Eﬁ open ( string commandline )
Windows
Menus

J* This prevents double toolbars =/ : User Objects

thiz. ToolBarFrameTitle = "MDI Application Toolbar" 4 Functions

this. ToolBarSheetTitle = "MDI Apolication Toolbar" i
1| 111} | v \Source Browser

Local {Global jInstance jParent yShared »Objects in Memory, | |1Call Stack 4Breakpoints jWatch
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The source code for the application Open event displays in the Source
view at top left. If it does not display, expand the Application node in the
Source Browser view’s tree view and double-click the Open event under
the pbtutor application.

2 In the Source view, double-click the line containing the following
assignment statement:

this.ToolBarSheetTitle = "MDI Application Toolbar"

A black breakpoint symbol displays at the start of the line to show that a
breakpoint has been set on the statement.

! [ open ( string commandiine ) for pbtutor ol x|
e e o *f -
[/* open: Application Open Script:
If 1) Opens frame window
[P *
I

[* This prevents double toolbars */
thiz. ToolBarFrameTitle = "MDI Application Toolbar"
® thiz. ToolBarSheetTitle = "MDI Application Toolbar"

/* Open MDI frame window */
Open ( w_pbtutor_frame )

4| i 2

3 Expand the following node in the Source Browser view:
Windows>w_welcome>cb_ok

The Source Browser view lists only events that have been coded. The only
event for the login window OK button is the Clicked event.

4 Double-click the Clicked event for the cb_ok button in the Source
Browser view.

The code for the Clicked event displays in the Source view.
5 Double-click the following line:

gnv_connect = CREATE &
n pbtutor connectservice
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Add breakpoints in application scripts

A breakpoint symbol displays at the start of the line.

'alcidwd {) returns long for cb_ok of w_welcome

/{ 1) Instantiate the Transaction object

/{ 2 Close login window if connection successful
gnv_cennect = CF!F_)'-\TE n_pbtutor_connectservice

/{Local variable declarations
string Is_database, Is_userid, |s_password

[{Assignment statements

Is_userid = Trim { sle_userid.text )

Is_password = Trim ( sle_password.text )
Is_database="ConnectString="DSN=PB Demo DB ¥2017;"

[{Instantiate with user-entry values

SQLCA.userid = Is_userid

SQLCA.dbpass = |s_password

SQLCA.dbparm = Is_database + "UID=" + &
Is_userid + ";PWD=" + Is_password + ""

IF gnv_connect.of_ConnectDB ( ) = 0 THEN

Close (parent)
.

Ojx]

m

"
=] @ Application
-5 pbtutor
-E8 dose ()
5--5‘5 open { string commandiine )
=0 Windows

B w_customers

-] w_master_detail_ancestor
[ w_pbtutor_about

-] w_pbtutor_basesheet
-] w_pbtutor_frame

- w_pbtutor_toolbars

-5 w_products

B w_welcome

- [a cb_cancel

B cb_ok

e -Eﬁ dicked {} returns long
p_sports
sle_password
sle_userid

[}@ st_password

B [a st_userid

[ st_welcome

- E-E-E-E

Source Browser £Source History

6 Double-click w_master_detail_ancestor in the Source Browser view.
Double-click dw_master, then rowfocuschanged.

PowerBuilder displays the script for the RowFocusChanged event of the
dw_master DataWindow control in the Source view.

7 Double-click this line:
IF dw _detail.Retrieve(ll itemnum) = -1 THEN

A breakpoint symbol displays at the start of the line.
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8 Select the Breakpoints tab in the lower-right stack.

= (long ) for dw_master of w_mas O] X} £ open (string commandine ) .
long Iitemnum » | B0 Windows
Il_itemnum = thiz.object.data[currentrow, 1] B w_customers
#® IF dw_detail.Retrieve(ll_itemnum) = -1 THEN -0 w_master_detail_ancestor
MessageBox("Retrieve","Retrieve error-detail") £ open () returns long L
END T £ ue_delete () 3

£F ueinsert ()
P ue_retrieve ()
P ue_update ()
+1-[ dw_detail
- dw_master
E" rowfocuschanged (long currentrow ) ref
= w_pbtutor_shout
] w_pbtutor_basesheet
5 w_pbtutor_frame -
A (i me—r—
#* pbtutor.open.8
* w_nelcome.cb_ok.clicked. 4
® \y_master_detail_ancestor.dw_master.rowfocuschanged.3

Local 4Biobal jInstance yParent jshared yObjects in Memory A0 [sCal Stack jBreakpoints

You should see the breakpoints you set in the Breakpoints view. To
complete this lesson, you need to have these breakpoints set correctly.

If you have additional breakpoints
You can clear any excess breakpoints using the pop-up menu in the
Breakpoints view.
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Run in debug mode

Run in debug mode
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£ &

Where you are
Add breakpoints in application scripts
> Run in debug mode
Set a watch and a conditional breakpoint

Now you run the application in debug mode. You step through the code line by
line.

About the Step buttons
You can use either Step In or Step Over to step through an application one

statement at a time. They have the same result except when the next statement
contains a call to a function.

Use Step Over to execute the function as a single statement. Use Step In if you
want to step into a function and examine the effects of each statement in the
function.

If you have stepped into a function, you can use Step Out to execute the rest of
the function as a single step and return to the next statement in the script that
called the function.

1 Click the Start button in PainterBar1
or
Select Debug>Start pbtutor from the menu bar.

The application starts and runs until it hits a breakpoint (in this case, the
call to the assignment statement for the toolbar title for sheet windows).

You return to the Debug window, with the line containing the breakpoint
displayed. The yellow arrow cursor means that this line contains the next
statement to be executed.

2 Click the Global tab in the lower-left stack.
The Global Variables view displays.

3 Double-click transaction sqlca.
Find the DBMS property, which has a String datatype.
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Notice that this property does not yet have a value associated with it
because the Debugger interrupted execution before the ProfileString
function executed.

!
- {)= dynamicstagingarea sglsa -
{x)= error error
()= message message

= n_pbtutor_connectservice gnv_connect
{*)= pbtutor pbtutor
e
--4H* boolean autocommit = false
--<@* long sglcode =0
<0 long sgldbcode = 0
--4@* long sglnrows = 0
--<[¥ powerobject dassdefinition
4[> string database = ™ %
<[ siring dbms = ™
--4@* string dbparm = ™
<A siring dbpass =™
--<E¥ siring lock = ™
--£@* string logid ="
--<H¥ string logpass =™
--£@* string servername ="
--<[¥ siring sqlerrtext = ™
--4[* string sqlreturndata =™
< siring userid =™

m

Local 3 Global dlnstance yParent xShared AObjects in Memory

To execute the next statement, click the Step In button in PainterBar1
or
Select Debug>Step In from the menu bar.

The application starts execution of the Open event for the MDI frame
window.

Use Step In or Step Over to step through the code until you reach this
statement in the script for the frame window Open event:

open (w_welcome)

After PowerBuilder finishes executing this statement, the login window
displays and the Debug window is minimized.

The Open event for the frame window also has a posted call to the
ue_postopen function (that you stepped through without examining). This
function in turn includes code that starts the processing of a chain of sheet
manager functions. These functions are processed at the end of the script
for the Open event, after the login window displays.
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Snmp Ower

Snmp Cant

Click Step Over until the login window displays and the Debugger is
minimized.

Type dba in the User ID box of the login window.

Type sgl in the Password box and click OK.

You return to the Debug window. The yellow arrow in the Source view
points to the next executable statement, the CREATE statement for the
connection service object. This is the first executable line in the script for
the Clicked event of the cb_ok command button.

Select the Call Stack tab in the lower-right stack.

The yellow arrow in the Call Stack view indicates the current location in
the call stack. If you double-click another line in the stack, the Source and
Variables views change to display the context of that line, and a green

arrow indicates the line in the Source view. If you then single-click another
line in the stack, a green arrow displays in the Call Stack view to indicate
the line for which context is displayed. When you continue to step through
the code, the Source and Variables views return to the current context.

Click the Step In button.

The Debugger takes you to the script for the Constructor event of the
connection service object.

Click the Step Out button.
Click the Global tab in the lower-left stack.
Look again at the Transaction object properties.

You step out of the Constructor event in a single step and return to the
script for the OK button Clicked event. Now the value of sqlcode has
changed, and the sqlerrortext and DBMS property have values, but the
UserID, DBPass, and DBParm properties do not.
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The values were assigned during execution of the Constructor event of the
connection service object after the of GetConnectionInfo function
returned information from the INI file, but because you commented out the
lines in the code for the UserID, DBPass, and DBParm properties, these
values were not retrieved.

[ Global * ol x|
(0= pbtutor pbutor -
oo Y

--4H*> boolean autocommit = false

40> long sglcode = -1

-4 long sqldbcode =0

--4H> long sglnrows =0

4> powerobject classdefinition

4[> string database =™

40> string dbms = "ODBC™

-4 string dbparm =™

40> string dbpass =™

-«H> gtring lock =™

4@ string logid =™

40> sfring logpass =™

-4 string servername = ™

--£H* string sglerrtext = “Transaction not connected”
40> string sqlreturndata =™

-4 string userid =™ =
[-04)= window w_pbtutor_frame =
Local 3 Global dInstance WParent AShared 3 0bjects in Memory

m

10 Click on the Local tab in the lower-left stack.

The local variables for the Clicked script have not yet been assigned
values.

11 Use the Step In button to step through the three assignment
statements for the local variables.

As you step through each statement, you can check that the values
assigned to the local variables are what you expected.

oo arx||
7 string |s_database = "ConnectString=TSN=PB Demo DB V2017;"
I"" string ls_password = "sgl” [/\\y‘

g5 string ls_userid = "dba”

Local 4Global jInstance jParent 3Shared 0bjects in Memory

Getting Started 207



Run in debug mode

208

12

13

14

Click again on the Global tab in the lower-left stack and expand the
Transaction object.

Use the Step In button to step through the three lines that instantiate
the Transaction object (SQLCA) with user-entry values for UserID,
DBPass, and DBParm.

As you step through each statement, you can check that the values you
entered in the login window are being assigned to the Transaction object.
You are still not connected to the database until the connection service
object of Connect function is executed.

i
o Global ol x|
[#-8d= n_pbtutor_connectservice gnv_connec -
[#-fd= pbtutor pbtutor th
[=-89d= transaction sqlca
--4H* boolean autocommit = false
4@ long sglcode = -1
4[> long sgldbcode =0
-4@* long sglnrows =0
-4H» powerobject dassdefinition
4@ string database = ™
4@ string dbms = "ODBC”
4@ string dbparm = "ConnectString=D5N=PE Demo DB V2017;UID=dba;PWD=sql'™
4@ string dbpass = "sql”
< string lock =™
4@ string logid =™
4@ string logpass =™

m

Click the Continue button in PainterBar1.

The Continue button resumes execution until the next breakpoint. The
database connection is established, the login window closes, and the MDI
frame for your application displays. The application is waiting for user
input.

Select File>Report>Maintain Customers from the menu bar.

The application continues until it reaches the line in the
RowFocusChanged event that contains the next breakpoint you added.

The RowFocusChanged event for a DataWindow occurs before the
DataWindow is displayed. For this reason, execution stops before the
Customer window is opened.
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Set a watch and a conditional breakpoint

Getting Started

Where you are
Add breakpoints in application scripts
Run in debug mode

> Set a watch and a conditional breakpoint

Next you set a watch on a variable whose value changes when the user selects
arow in the Customer window. You then change one of the simple breakpoints
you have set into a conditional breakpoint that is triggered only when a variable
has a specific value.

1 Click the Watch tab in the lower-right stack.
Click the Local tab in the lower-left stack.
Select the llI_itemnum variable in the Local view and drag it to the
Watch view.

The 1l_itemnum variable is set to 101, the ID of the first customer
retrieved. Displaying it in the Watch view makes it easier to observe when
its value changes. You can also drag Global, Instance, and Parent variables
to the Watch view so that you can easily keep track of several variables of
different types.

2 Click the Continue button.

The application resumes execution. The Customer window displays and
shows the list of customers retrieved from the database. The detail
DataWindow shows information about customer 101.

3 Select a different row in the master DataWindow of the Customer
window.

You return to the Debug window. The new value of II_itemnum displays
in both the Local Variables view and the Watch view.

4 Click the Breakpoints tab in the lower-right stack.
Double-click the rowfocuschanged breakpoint.

The Edit Breakpoints dialog box opens with the breakpoint in the
RowFocusChanged event selected.

5 Type the following line in the Condition text box and click OK:
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11 itemnum = 107

Edit Breakpoints @
Location | yariable IA\’

#® pbtutor.open.&
* yw_welcome.ch_ok.dicked. 4
® w_master_detail_ancestor.dw_master.rowfocuschanged. 3

Mew ] [ Clear ] [ Clear Al
Location: w_master_detail_ancestor.dw_master.rowfocuschal
Occurrence:
Condition:  Il_itemnum = 107]
[ QK ] [ Cancel ] [ Apply ] [ Help ]

%

The breakpoint in the RowFocusChanged event script is now a conditional
breakpoint. PowerBuilder suspends execution only when it reaches this
statement and the value of 11_itemnum is 107.

Click OK to close the dialog box.
Click the Continue button.

The application resumes execution. Now you can select different rows in
the Customer window, and the Debug window opens at the breakpoint
only if you select the customer whose ID is 107.

If you select customer 107, click the Continue button again to return to the
application.

Select File>Exit from the application’s menu bar.

The application terminates and you return to the Debug window.

Select File>Close from the menu bar.

You return to the PowerBuilder development environment.
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LESSON

Getting Started

10

Exception Handling

Exception handling allows you to trap errors that occur during the
execution of a program and to provide useful information about those
errors to the application user. This lesson describes how to create
user-defined exception objects and use them to catch exceptions that you
throw from a method in a TRY-CATCH statement.

In this lesson you:

Add a new sheet window to the existing application
Create user-defined exception objects

Create a new user function and user event

Call the methods and catch the exceptions

Run the application

How long does it take?
About 45 minutes.
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Add a new sheet window to the existing application
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Where you are
> Add a new sheet window to the existing application
Create user-defined exception objects
Create a new user function and user event
Call the methods and catch the exceptions
Run the application

In this lesson you add a third sheet window to the main tutorial application. You
create and call a function to perform a routine operation (calculate a
percentage) on values returned from embedded SQL commands and a value
selected by the application user from a drop-down list box control.

The prototype for the function you create throws user-defined exceptions. You
call the function in a TRY-CATCH block inside the Clicked event on a
command button control. The CATCH clauses in the Clicked event catch
user-defined exceptions thrown by the new function as well as a system
exception thrown up the application call stack.

You use the new sheet window to calculate the percentage of customers that
resides in a selected state. The controls you add to the new sheet window are:

*  Two static text boxes that you change programmatically to display
read-only results

* A command button to call a function that calculates percentages
* A drop-down list box for a list of states where customers reside

* A text box that displays the percentage of customers residing in the state
that application users select from the drop-down list box

To add a sheet window to the existing application, you must:
¢ Create the sheet window

¢  Provide access to the sheet window from the main application frame
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Create the sheet window

You inherit the sheet window from the w_pbtutor basesheet window. This is
the base class for sheet windows that you generated with the Template
Application wizard. You do not use the w_master detail ancestor extension
layer window, since the modifications you made to it are not useful in the new
sheet window.

1 Select File>Inherit from the PowerBuilder menu.
Make sure the Objects of Type box displays Windows.
Select w_pbtutor_basesheet from the available windows in the
pbtutor.pbl library and click OK.

2 Make sure the Layout view displays in the Window painter.
Select Insert>Control>StaticText and click near the top left corner of
the Layout view.

3 In the Properties view, highlight the default text in the Text text box
and type the following:

1. Select or type a state code in drop-down list:

4 Lengthen the control width and the width of the sheet window to
display the entire text and allow room for a drop-down list control at
the top right of the window.

A length of 2250 should be sufficient for the sheet window width. You can
set this on the Other tab of the Properties view for the window, or you can
drag the window edge in the Layout view to make room for an additional
control.

5 Right-click the static text control in the Layout view and click
Duplicate from the pop-up menu.
In the Properties view, highlight the default text in the Text text box of
the new static text control and type the following:

2. Click Percentage button
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6 Select Insert>Control>DropDownListBox and click to the right of the
static text boxes near the top right corner of the Layout view.

[ Layout k Replace h o=/

7 In the Properties view for the drop-down list box, type dd1b_state
for the control name.
Select the AllowEdit and the VScrollBar check boxes.

8 Click the CommandButton button in the painter bar and click below
the two static text boxes.
In the Properties view, type cb_percent for the button name and type
Percentage for the button text.

9 Select Insert>Control>SingleLineEdit and click below the command
button in the Layout view.
In the Properties view, type sle result for the control name and
type the following for the control text:

Text box for percent of customers in the selected
state

10 Lengthen the control width to display the entire text.

[ Layout N alx||

-
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11 Make sure no control is selected and the sheet window properties are
displayed in the Properties view.
Type Customer Location for the Tag property.

The text you typed will be visible in the sheet window title at runtime.
Code in the basesheet ue_postopen event assigns the Tag text to the sheet
window title.

12 Select File>Save from the PowerBuilder menu.
Select pbtutor.pbl for the application library, type w_cust pct for the
new sheet window name, and click OK.

This saves the new sheet window with all its controls to the main tutorial
library.
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Provide access to the sheet window from the main application

frame

216

You must register the new sheet with the sheet manager.

Double-click w_pbtutor_frame in the System Tree.

If the ue_postopen event is not visible in the Script view, click the
Event List tab and double-click ue_postopen.

The ue postopen event script displays in the Script view.

Edit the list of sheets to add your new window. The following entry
should be a single line:

string ls sheets[] = { "w customers", "w_products",
"w_cust pct" }

Edit the display list to add a label for your new window. The following
entry should be a single line:

string 1ls display[] = { "Maintain Customers",
"Maintain Products", "Customer Location" }

IEISG"pt -ue for returns (None) ol x|
w_pbtutor_frame V] 1=l ue_postopen () returns {(none) - B |
"= = e
/f* ue_postopen: Register the sheets
"= =

/* Define sheet windows and their display names =/
string Is_sheets[] = { "w_customers", "w_prEducts", "w_cust_pct" }
string Is_display[] = { "Maintain Customers", "Maintain Products", "Customer Location" }

/* Reqister sheet windows with sheet manager */
inv_sheetmgt.of_RegisterSheets ( Is_sheets, Is_display )

4| 11 | F
Layout hue_postopen {Event List yFunction List 4Dedare Instance Variables

Select File>Save and close the w_pbtutor_frame window.

The next time you run the pbtutor application, you should be able to open
the new sheet window from the File menu of the main frame window.
Although you can now run the new sheet window from the development
environment, you must make sure that you can run it from a compiled
application as well.
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For this purpose, you reference the sheet windows as window objects in
the sheet manager of registersheet script. The reference is necessary for
the compiler to know that this object is used in the application so that it
will include it in the executable.

You create a compiled application in Lesson 11, Preparing the Application
for Deployment.

6 Double-click n_pbtutor_sheetmanager in the System Tree.

7 Click the Function List tab and double-click of_registersheet.

The script for the of registersheet function displays in the Script view.

8 Enter the following after the lines declaring sheet window variables
for the w_customers and w_products windows:

w_cust pct 1w sheet3

IGISG"pt - of_registersheet ( readonly string as_sheet, readonly string as_displi O] X}

(Functions) V] 1= of_registetgbeet(read - EIE'

s +f -
//* of_ReqgisterSheet: Add a new sheet to the sheet array
7 *f

long ll_g, ll_sheets

/* These references to the mdi sheets provide the ability to
build an executable that includes these objects. Without
these references, these objects ( previously referenced only
in strings ) would not otherwise be included.

If you choose to use a PBR file or dynamic libraries, these
references can be removed */

w_customers  lw_sheetl

w_products lw_sheet2

w_cust_pct lw_sheet3

lI_sheets = UpperBound ( is_sheets )
/* Make sure sheet is not already registered */
For ll_s = 1 to ll_sheets
If Lower ( as_sheet ) = is_sheets[ll_s] Then Return -1
Mext

is_sheets[ll_sheet=+1] = Lower { as_sheet )
is_display[ll_sheet=+1] = as_display

of_AddToMenu ( as_sheet, as_display )

Return 1

4 | n | k

of_registersheet 4Event List 3Function List 3Dedare Instance Variables

9 Save and close the n_pbtutor_sheetmanager user object.
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Where you are

Add a new sheet window to the existing application
> Create user-defined exception objects

Create a new user function and user event

Call the methods and catch the exceptions

Run the application

Now you create two user-defined exception objects that you will throw from a
function that is invoked when the user clicks the command button on the
w_cust_pct window. You also create a user-defined exception object that you
throw from a user event on the drop-down list box control that you added to the
w_cust_pct window.

1 Select File>New from the PowerBuilder menu and click the PBObject
tab in the New dialog box.

2 Select the Standard Class icon and click OK.
Select throwable from the Types list box and click OK.

The new exception object displays in the User Object painter.

3 In the Text box of the Properties view, type the following:

No rows were returned from the database. If you typed
or selected a state code in the drop-down list box
and the database connection has not been closed,
either the state you entered has no customers or you
entered the state code incorrectly.

The exception object has get and set methods for handling the Text
property. Here you set the text property directly in the user interface.

4 Click outside the Properties view to enable the Save button.
Select File>Save, select the pbtutor.pbl application library, and type
exc_no_rows in the User Objects box for the new exception object
name, and click OK.

5 Select File>Close.
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Repeat steps 1-5 using the following values for the Text property and
the exception object name:

Property

Value

Text

Percentage too low. Only one customer
in this state. Notify regional sales
manager. ..

Exception object name

exc_low_number

Repeat steps 1-5 using the following values for the Text property and
the exception object name:

Property

Value

Text

You must use the two-letter postal
code for the state name.

Exception object name

exc_bad _entry

219



Create a new user function and user event
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Where you are
Add a new sheet window to the existing application
Create user-defined exception objects
> Create a new user function and user event
Call the methods and catch the exceptions
Run the application

Now you add a function that you invoke from the Percentage command
button’s Clicked event and an event that is triggered when the focus is changed
from the drop-down list box on the w_cust_pct window. The function
calculates the percentage of customers living in a particular state. The event
processes the current value of the drop-down list box control to make sure it is
two characters in length (for the state code).

1 Open w_cust_pct in the Window painter if it is not already open.
Select (Functions) in the first list box in the Script view.

The Script view displays the Prototype window. The first drop-down list
box in the Script view displays (Functions) and the second drop-down list
box displays (New Function).

2 Select decimal for the Return Type and type uf percentage for
Function Name.

3  Select integer for the Argument Type and type ai custbystate for
the Argument Name.

You will add a second argument in the next step.

4 Right-click anywhere in the Prototype window and select Add
Parameter from the pop-up menu.

5 Selectinteger for the second Argument Type and type ai totalcust
for the second Argument Name.

6 Type exc no rows,exc low number in the Throws box.
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Enter the following script for the new function:

Decimal my result
exc no rows le nr
exc_low number le ex
/* Process two integers passed as parameters.
Instantiate and throw exceptions if the first
integer value is 0 or 1. Otherwise calculate a
percentage and return a numeric value truncated to a
single decimal place. If the second integer value is
0, catch and rethrow the runtime dividebyzero error
during the calculation.
*/
CHOOSE CASE ai custbystate
CASE O

le nr = create exc _no_rows

throw le nr
CASE 1

le ex = create exc low number

throw le ex
CASE ELSE

TRY

my result=(ai custbystate/ai totalcust)*100
CATCH (dividebyzeroerror le zero)
throw le zero

End TRY
END CHOOSE
return truncate(my result,1)

Later in this tutorial, you will call the uf percentage function from the
Clicked event on the command button, passing in two integers and
processing the return value.

You now add a user event for the drop-down list box that throws the
exc_bad_entry exception object when a user-entered state code is not
exactly two characters in length.

Select ddlb_state in the first drop-down list box of the Script view and
select (New Event) in the second drop-down list box.

Select integer for Return Type and type ue modified for Event
Name.

Select string for Argument Type and type as_statecode for
Argument Name.

Type exc_bad_entry in the Throws box or drag it from the System
Tree to the Throws box.
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Note that the Event ID is (None). You do not select an Event ID for the
ue_modified event. If you selected an Event ID, you could not enter
user-defined exception objects in the event Throws clause.

10 Enter the following script for the new ue_modified event:

exc bad entry le ex
//Make sure the current text in the drop-down list
//box is two characters in length. Otherwise,
//instantiate the exc bad entry exception object and
//throw the exception.
IF len(this.text)<>2 Then

le ex = create exc bad entry

throw le ex
END IF
Return 1

Next you call the ue_modified event and the uf_percentage function,
and catch the exceptions thrown by these methods.
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Call the methods and catch the exceptions
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Where you are
Add a new sheet window to the existing application
Create user-defined exception objects
Create a new user function and user event
> Call the methods and catch the exceptions
Run the application

You now write code to populate the drop-down list box controls with state
codes from the customer table in the Demo Database database. Since you made
the control editable, an application user can also type in a value for the state
code. Before you process a user-entered value, you check to make sure the
value conforms to the conditions you set in the ue_modified event, namely that
it is two characters in length.

You also add code to the Clicked event of the command button control to
process the current state code in the drop-down list box control. In the Clicked
event you call the uf percentage function to calculate the percentage of
customers from the selected state and catch all exceptions that can be thrown
by the function.

1 Make sure the w_cust_pct is open in the Window painter and that
ddlb_state displays in the first drop-down list box of the Script view.

2 Select losefocus () returns long [pbm cbnkillfocus] inthe
second drop-down list box.

3 Call the ue_modified event and catch the exception object that it
throws by entering the following lines for the losefocus event script:

Try
this.EVENT ue modified(this.text)
Catch (exc bad entry le be)

messagebox ("from exc bad entry", &
le be.getmessage())
End Try
return 1
4 Select constructor ( ) returns long [pbm constructor]

from the second drop-down list box in the Script view prototype
window for the ddlb_state control.
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5 Enter the following lines in the Constructor event to populate the
drop-down list box control:

int 1i nrows, n
string ls_ state

//Get the distinct count of all states in the
//customer table

SELECT count (distinct state) INTO :1i nrows
FROM customer;

//Declare the SQL cursor to select all states
//in customer table but avoid
//rows with duplicate values for state.
DECLARE custstatecursor CURSOR FOR
SELECT state FROM customer
GROUP BY state HAVING count (state)=1
UNION
SELECT state FROM customer
GROUP BY state
HAVING count (state)>1;
OPEN custstatecursor ;
//Populate the control with a single entry for
//every state in the customer table.
FOR n=1 TO 1i nrows
FETCH NEXT custstatecursor INTO :1s state;
this.additem( ls state)
NEXT
CLOSE custstatecursor ;
//Set first item in list as selected item
this.selectitem (1)

6 Select cb_percent from the first drop-down list in the Script view.
Make sure clicked ( ) returns long [pbm bnclicked]
displays in the second drop-down list box.

7  Enter the following lines for the Clicked event script:

Decimal my result
Double entry 1, entry 2
Int 1i int, 1i rtn
String sel state

sel state=ddlb state.text

//Get the number of rows with customers from the
//selected states and place in the entry 1 variable.
//Change the first static control to display this
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//number.

SELECT count (*) INTO :entry 1 FROM customer
WHERE customer.state=:sel state;
st 1.text="Customers in state: " + string(entry 1)

//Get the total number of customers and place in
//the entry 2 variable.
//Change the second static control to display this
//number.
SELECT count (*) INTO :entry_Z FROM customer;
st 2.text="Total number of customers: " &

+ string(entry 2)

//Call uf percentage and catch its exceptions.
TRY
my result = uf percentage (entry 1, entry 2)
CATCH (exc no _rows e nr )
MessageBox ("From exc no rows", &
e nr.getmessage())
CATCH (exc_low number e 1n )
1i int=1
MessageBox ("From exc low number", &
e In.getmessage())
CATCH (dividebyzeroerror e zero)
1i rtn = MessageBox ("No Customers", &
"Terminate Application?", Stopsign!, YesNo!)
IF liirtn=1 THEN
HALT
END IF
END TRY

//Display the message in the text box. Vary the
//message depending on whether there is only one
//customer for the selected state or if more than
//one customer resides in selected state.

IF li_int:l THEN

sle result.text ="Value not calculated for " &
+ sel state + "." + " Try another state."
ELSE
sle result.text = String (my result) + &
" % of customers are in " + sel state + "."
END IF
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Run the application

Where you are
Add a new sheet window to the existing application
Create user-defined exception objects
Create a new user function and user event
Call the methods and catch the exceptions
> Run the application

You are now ready to run the application and calculate the percentage of
customers in a selected state.

You can test the exception conditions you scripted, but to test the
divide-by-zero error condition, you need to artificially set the number of
customers in the database to zero. You do this by adding a check box to the
sheet window, then setting the number of customers to zero if the check box is
selected.

In this exercise you:
e Test the new sheet window

*  Add a test for the divide-by-zero error
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Test the new sheet window
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Getting Started

Click the Run button in the PowerBar.

If PowerBuilder prompts you to save changes, click Yes.

Type dba in the User ID box.
Type sgl in the Password box and click OK.

The database connection is established, and the MDI frame for the
application displays.

Select File>Report>Customer Location from the menu bar.

The Customer Location window displays. The current entry in the
drop-down list is AB for Alberta.

& Customer Location:1 EI@

1. Select or type a state code in drop-down list: b AB -
2. Click Percentage button

Text box for percent of customers in the selected state

Click the Percentage button.

Because there is only one customer in Alberta, the exc_low_number
user-defined exception is thrown. The message from the exception is
displayed in a message box that was defined in a CATCH clause in the
button Clicked event.
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228

Click OK to close the message box.

The text in the static text boxes now displays the number of customers in
Alberta and the total number of customers in the database. The text in the
editable text box tells you the value was not calculated and prompts you to
select another state.

& Customer Location:1 EI\EI

Customers in state: 1 AB -

Total number of customers: 1@6

Value not calculated for AB. Try another state.

Select or type C2 in the drop-down list box and click the Percentage
button.

The results from the database show 10 customers in California for a total
of 7.9% of all customers in the database. The percentage may be different
if you have modified the database.

& Customer Lecation:1 EI@

Customers in state: 10 CA -

Total number of customers: 126

7.9 % of customers are in CA.
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10

11

12

Type Ohio into the drop-down list box and click the Percentage
button.

When you lose focus from the drop-down list box by clicking the
Percentage button control, the LoseFocus event fires. This event calls the
ue_modified event that throws the exc_bad _entry user-defined exception.
The exception message tells you to use a two-letter postal code for the state
name.

Click OK to close the message box, type US in the drop-down list box,
and click the Percentage button.

Because no rows are found in the database with US as the state code, the
exc_no_rows exception is thrown. A message displays indicating no rows
have been returned and suggests reasons why that might be the case. A
more robust application might compare the typed text to a list of state
codes and throw the exc_bad_entry exception instead, letting you know
that US is not a state code.

Click OK to close the message box.

Right-click the database icon for the Demo Database, a red and yellow
SQL symbol, in your Windows System Tray.

Select Shut down from the pop-up menu, and click Yes in the Warning
message box that displays.

This shuts down the connection to the Demo Database.

Select or type AB again in the drop-down list box and click the
Percentage button.

The message from the exc_no_rows exception object displays for Alberta
because the connection to the database was closed. To obtain results again,
you need to terminate the application and restart it. PowerBuilder
reestablishes a connection to the database at runtime when you restart the
application.

Click OK to close the message box and select File>Exit from the
application menu to return to the development environment.

The Database painter and the Database Profile painter might still list the
database connection as being open. In this case you can use either painter
to disconnect and reconnect to the database at design time.
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Add a test for the divide-by-zero error

You now add a check box to the w_cust pct window. You then write code to
force a divide-by-zero error if the check box is selected. Because this test
requires an instantiated check box object, you surround the new code in a
TRY-CATCH statement that checks for null object errors.

1 Make sure the w_cust_pct window is open in the Layout view.
Select Insert>Control>CheckBox from the Window painter menu.

2 Click in the window just to the right of the Percentage command
button.

3 Inthe Name box in the Properties view, type cbx zero.
In the Text box, type Test divide-by-zero error.

4 Click the Function List tab.
Double-click the uf_percentage function.

5 Type the following text just above the CHOOSE CASE statement:

//Set denominator to zero to test error condition
//Numerator unimportant, avoid user exception cases
TRY
IF cbx zero.checked=TRUE THEN
ai totalcust=0
ai custbystate=2
END IF
CATCH (nullobjecterror e no)
MessageBox ("Null object", "Invalid Test")
END TRY

Testing for the null object error
After you finish this lesson, you can test for the null object error by adding

the following line above the TRY statement: DESTROY cbx_zero.

6 Click the Run button in the PowerBar.

If PowerBuilder prompts you to save changes, click Yes.
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10

Type dba in the User ID box.
Type sgl in the Password box and click OK.

The database connection is established, and the MDI frame for the
application displays.

Select File>Report>Customer Location from the menu bar.
Select a state code from the drop-down list box.

Select the Test divide-by-zero error check box.

& Custorer Location:1 % EI@

1. Select or type a state code in drop-down list: co -
2. Click Percentage button

[7|Test divide-by-zero error.:

Text box for percent of customers in the selected state

Click the Percentage button.

The division by zero error is thrown during the percentage calculation and
caught by the button Clicked event. The message box that you coded in the
CATCH clause for this error displays.

r© |
Mo Customers l\r- —

\r

lel Terminate Application?

| oves || me
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11 Click No to continue running the application.
Continue to test the application by selecting another state code and
optionally clearing the check box.

If the check box is selected when you click the button again and you select
Yes in the error message box, the application closes and you return to the
development environment.

12 Close the application when you have finished testing it.
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11

Preparing the Application for
Deployment

In this lesson you create an executable version of the application for
distribution to users. Users can run this executable version of the
application just as they can any other application.

You:

*  Create the Project object
*  Create the executable file
e Create a shortcut

e Test the executable file

How long does it take?
About 10 minutes.
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Create the Project object

234

Where you are

> Create the Project object
Create the executable file
Create a shortcut
Test the executable file

Now you create the PBTUTOR Project object. You can then use the Project
object to create the executable file for the application.

About machine code If When you deploy an application to users, you may
want to take advantage of the execution speed of machine code for some
computations, such as loops, floating point or integer arithmetic, and function
calls. While you are developing the application, you usually use Pcode because
it is faster to generate.

About dynamic libraries You can also create dynamic libraries for your
application. Dynamic libraries can be used to store the objects in the
application. By using dynamic libraries, you can break the application into
smaller units that are easier to manage and also reduce the size of the
executable file.

For small applications like the one that you are working on now, you do not
need to use dynamic libraries.

1 Click the New button in the PowerBar.
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Getting Started

Click the Project tab in the New dialog box.
IrNew ﬂ1

Target: (3) pbh..ltor%:'\Users\wanghui‘\Domments\,nppeon‘l,ﬂowersuilder 17.0%Tutorial) -

| workspace | Target | Library | PB Object | DataWindow | Database | Project |Tool |

Application Wizard .NET Web Service .MET Web Service  .NET Assembly
Wizard Wizard

JNET Assembly  Web Service Proxy Web Service Proxy EJB Client Proxy  EJB Client Proxy
Wizard Wizard

[ Ok ] [ Cancel

Select the Application Wizard icon and click OK.

Using the Project painter
If you clicked the Application icon on the Project page instead of the

Application Wizard icon, you open the Project painter. You can make the
same selections in the Project painter that you make with the wizard, but
the wizard prompts you for this information.

Click Next.
The Specify Destination Library page displays.
Select pbtutor.pbl in the Application Libraries list box if it is not

already selected.
Click Next until the Specify Build Options page displays.

The wizard will generate a project with the following default selections:
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Wizard property Default value
Project name p_pbtutor_exe
Executable filename pbtutor.exe
Optional resource file none

5 Select Incremental Build for the Build Option.
Click Next until the Specify Version Information page displays.

The wizard will generate a project with the following default selections:

Wizard property Default value

Generate machine code No

Build dynamic libraries No

6 If you want to, enter your own version information on the Specify
Version Information page.

If you do not change the information on this page, the defaults display in
Windows Explorer when you look at the properties of the executable.

7 Click Next.
Review the information on the Ready to Create Application page.
Click the Finish button.
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PowerBuilder creates a Project object for your application and displays it
in the Project painter workspace.

) (CAL:

1= p_pbtutor_exe (pk

huiz\Documents\Appe... EI@

General |Libraries | Version | Security | Run |

Executable file name:
Resource file name:

Project build options

@ Pcode

() Machine code

with these parameters):

|:| Prompt for overwrite

[T windows dassic style

Code generation options

Trace information

Speed

Enable DEBUG symbol

Rebuild:

Platform:

Error context information

@ Incremental

& Full
32-bit -

PBC runtime parameters {You can directly run the PowerBuilder Compiler pbc.exe

After a project is defined, you can easily create an executable version of
the application. Using a project saves time when you are working on an

application that includes dynamic libraries that you expect to rebuild

often. Selecting incremental build means that if you make a few changes,

you can rebuild your project quickly, rebuilding only files that have
changed or files that depend on files that have changed.
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Create the executable file

Where you are

Create the Project object
> Create the executable file

Create a shortcut

Test the executable file

Now you create the executable file for your application. The executable file
you generate contains definitions for all the objects in the application. For the
tutorial application, this includes the bitmap file used in the login window,
since you did not include a separate resource file with your project.

You can create the executable in the Project painter, but usually, once you have
defined the project, you do not need to open the painter again.

Workspaces and targets in the System Tree have Incremental Build, Full Build,
and Deploy items on their pop-up menus that enable you to build and deploy
some or all of the projects in a target or in the whole workspace. Incremental
Build and Full Build compile your code. Deploy compiles the code and, for
applications like the one you built in this tutorial, creates an executable file and
optional dynamic libraries.

In this lesson you look at the property sheets where build and deploy options
are specified and then create the executable from the PowerBar.

1 Close the Project painter.
Click Yes if prompted to save changes.

2 Right-click the pbtutor target in the System Tree.
Select Properties and then select the Deploy tab.

238 PowerBuilder



Lesson 11 Preparing the Application for Deployment

Getting Started

Dreglay

This page shows all the projects in this target (currently only one).

-
Properties of Target pbtutor |_§:§ |

| Library List| Deploy |

Use the checked projects in the following order: @
Iml=]p_pbtutor_exe

If you have more than one project in the target, you can change the order
in which they are executed and select which projects you want to build.

Leaving p_pbtutor_exe checked, click the Cancel button.
Right-click MyWorkspace in the System Tree.
Select Properties and select the Deploy Preview tab.

The Deploy Preview page shows all the targets in your workspace and the
projects in each that have been selected for deployment, in the order in
which they are to be deployed. You cannot change anything on this page—
you use it to check that you have set up deployment options for your
workspace the way you want to. All the projects shown on this page are
deployed when you click the Deploy button in the PowerBar.

This workspace has only one target and only one project, so you can use
the Deploy button to create the executable.

Click the Cancel button to close the property sheet.

Click the Deploy button in the PowerBar.

The process of creating the executable file might take a few moments.
While PowerBuilder is working, you can look at the Output window at the
bottom of the screen to see what PowerBuilder is doing.

If you wanted to stop the deployment process, you could click the Stop
button in the PowerBar. When deployment is complete, the Output
window displays the following text: Finished Deploy of workspace
MyWorkspace.
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Create a shortcut

240

Where you are

Create the Project object

Create the executable file
> Create a shortcut

Test the executable file

Now you create a shortcut for the executable file. The icon serves as a shortcut
to open the executable file. You can add the shortcut directly to the desktop or
to the program group of your choosing.

1 Minimize PowerBuilder.

PowerBuilder is minimized to an icon on the taskbar.

2 Right-click on a blank area of the desktop.
Select New>Shortcut from the pop-up menu.

3 Inthe Create Shortcut dialog box, click the Browse button and locate
pbtutor.exe.

If you accepted the default installation locations, the file is in
Users\<username>\Documents\Appeon\Powerbuilder 17.0\Tutorial.

4 Click OK, then click Next.
5 Type SportsWear, Inc. as the name of the shortcut.

6 Click Finish to create the shortcut on the desktop.

Now you must modify a property of the shortcut so that you can run the
application. You can also change the icon.

7 Right-click the SportsWear, Inc. icon on the desktop.
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Choose Properties in the pop-up menu.

-'& SportsWear, Inc Properties ﬂ
! N

Security | Details | Prewvious Versions

Geneal | Shortout | Compatibiliy

% SportsWear, Inc

Target type: Application

Target location: Tutorial

Target: lAppeon®PowerBuilder 17.0%Tutoral \pbtutor.exe™

Start in: "C:xUserswanghuiDocuments*Appeon\PowerE

Shortcut key:  None

Run: [Non‘nal window ']
Comment:
Open File Location ] ’ Change Icon... l [ Advanced... ]

8 Select the Shortcut tab.
Type the path to the PowerBuilder shared modules in the Start In box.
Click OK.

About the location of the shared modules
When you install PowerBuilder, the installation process puts the DLLs in

a shared directory. The default location is: C:\Program
Files\Appeon\Shared\PowerBuilder

If you want the user to be able to run the application by double-clicking
the executable file, you must include the shared directory location in the
system environment path.
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Test the executable file

Where you are
Create the Project object
Create the executable file
Create a shortcut

> Test the executable file

Now you test the new executable file.

1 Make sure the pbtutor.ini file is in the same directory as the
pbtutor.exe executable file.

The default location of the pbtutor.ini file and the pbtutor.exe file is
Documents\Appeon\Powerbuilder 17.0\Tutorial.

2 Double-click the icon for the tutorial application.

The application begins running.

3 Test the application.
Notice the changes you made to the customer information.

4 When you have finished testing the application, select File>Exit from
the menu bar.

What to do next

Congratulations. You have completed the client-server part of the tutorial.
Now you know the basics of application development with PowerBuilder.

The Preface to this book includes a guide to the PowerBuilder documentation.
To further your education, you should continue with these books:

Users Guide
Application Techniques
DataWindow Programmer s Guide
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All the PowerBuilder books are available in the Product Manuals page on the
Appeon Web site at https://www.appeon.com/developers/library/product-manuals-
for-pb.
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