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Testing with QTP Appeon® for PowerBuilder® 2016

1 Testing with QTP

1.1 Overview

Y ou can automate the testing of Appeon Web application by using QTP (QuickTest
Professional), one of the most popular automatic testing tools. This guide will walk you
through how to configure QTP. It also introduces several considerations and known issues for
recording Web applications with QTP. To make sure that you can follow this guide easily,
you would need to know how to use QTP beforehand. Please read the QTP user manual first
if you do not know the basis of QTP.

Y ou will find step-by-step instructions for the following tasks in this user guide:

e Configuring AEM

Configuring QTP

Considerations for Recording Web Applications

Known Issues

Appendix

1.2 Configuring AEM

To test aWeb application converted by Appeon for PowerBuilder, go to AEM and switch the
Run Modeto Test Mode (by default, Normal Mode is selected).

For more information, please refer to Section 5.4.6.4, “Run Mode” in Appeon Server
Configuration Guide for .NET or in Appeon Server Configuration Guide for J2EE.

Figure 1.1: Configuring AEM

Run Mode Settings

Select the run mode for Web applications. If test mode has been turned on, Appeon Server will start in the performance test mode, allowing stress
testing tools (such as LoadRunner) to read and write parameters in the plain text.

Run Mode: Normal Mode /@ Test Mode

1.3 Configuring QTP

Before you can use QTP to record the operations on the controls or functionalities of a Web
application, you will need to configure QTP properly.

1.3.1 Selecting Web add-in

When you start QuickTest, the Add-in Manager dialog box opens. In the Add-in Manager,
select the Web add-in, and then click OK to save the settings and close Add-in Manager.

Note: If the Add-in Manager does not open when starting QuickTest, choose Tools >
Options, click General and select Display Add-in Manager on startup. When you exit and
restart QuickTest, the Add-in Manager opens.
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Figure 1.2: Selecting add-ins

2 QuickTest Profeszional - Add-in Manager
Select add-ins to load:

A

QuickTest

Professional
Add-ins

[ Show on startup

Add-in | License

O MET 12 dayis) remaining
[0 Activex Licensed

O Java 12 dayis) remaining
[0 PowerBuil.. 12 dayls) remaining
[ ‘isual Basic Licensed

| Web Licensed

[0 Web Serv... 12 dayis) remaining
O m 12 dayis) remaining

Add-n description:

Tests WPF (Windows Presentation Foundation)
applications

Tip: To maximize performance and object

identification reliability, load onhy the add-ins you
need.

QK Cancel

1.3.2 Configuring options
Step 1: Choose Tools > Options. The Options dialog box opens.
Step 2: In the left pane, click General, and in the right pane, select Use Only Windows API

from the Use text recognition mechanismsin thisorder list.

Testing Appeon Web Applications (Web only)
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Figure 1.3: Text Recognition

Options @
& General General > Text Recognition
EDIF'EFS Use text recognition mechanisms in this order:
o Active Screen
El H_un |I_lse Only Windows API j
L 5'3“3'3"_' Capturs OCR. mechanism configuration
=~ '."-:-'inu:h:u'f'\'s Applications ~
;e Advanced
E- .'n":"Eb (+
- Page/Frame Options
L Advanced

m
(I}
il

il =
]

QK Cancel Apply Help

Notes:

1. If there is unrecognized script obtained and the checkpoint is not an image when you
insert a Text checkpoint, check the configuration here. Make sure the Use Only Window
API isselected in the Usetext recognition mechanism in this order dropdown list box.

. Windows 7 and Windows Server 2008 R2 do not support the Windows APl test
recognition mechanism. Therefore, when you install relevant QTP 10.00 patches, the Use
text recognition mechanismsin thisorder option in the Options dialog box (Options >
General > Text Recognition) is set to Use only OCR, and cannot be changed (the option
is disabled), as shown in the figure below. However, you can still test a Web application
on Windows 7 or Windows Server 2008 R2, the only problem you might have is the text
that QTP obtain may contain some unrecognizable characters. When this happens, you can

manually modify these unrecognizable characters. For more information, refer to the QTP
10.0 user guide.
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Figure 1.4: View Text Recognition window

Cptions 53
| B General General > Text Recognition
i Text Recognition
Fclt.:lers Use text recognition mechanisms in this order:
i Active Screen |
& Run Use Only OCR | E
W'g MCEI'P’[UFE OCR mechanism configuration
El- Windows Applications i
B H '
o Eerae Single text block mode

Step 3: Click Run in the left pane. In the right pane, select Normal (displays execution
marker), and then type 500 or select 500 using the spin control in the Delay each step
execution by [ ] milliseconds spin control, as shown in the figure below.

Figure 1.5: Choose the Run mode

. COptions
=B G_eneml Run
i Teat Recognition
Folders
Run mode

- Active Screen

=- Run

| i Screen Capture
Bl Windows Applications

: i Advanced
E| Web

L Advanced

Page/Frame Options

* Momal (displays execution marker)

Delay each step execution by: | 500 3: miliseconds

" Fast

-

v ‘iew results when run session ends

[ Allow cther HP products to nun tests and componerts

Stop command shortout key:

|Ctr = At = F5

oK

Apply Help

Step 4: In the left pane, expand Windows Applications and click Advanced. In the right
pane, select Always enumer ate child windows (may affect perfor mance) option under

Object identification.
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Figure 1.6: Set the object identification

Optiens ==
= General Windows Applications > Advanced
i - Text Recognition
Folders |lze the options below to configure your settings:

i Active Screen

El Fun

i t... Screen Capture
- Windows Applications

JE Object identffication .

Always enumerate child windows {may affect performance)
s Record seftings

m

2 Web O Record arly the ohject’s basic operation
Page/Frame Options il Record Click
‘... Advanced {.% On mouse button down

On mouse button up
8 List
O FRecord only the ohject’s basic operation

% On monse hotton down
Description
Specifies the method Quick Test uses to identify objects when running a test or
compaonent.

Reset

QK | Cancel | Help |

Step 5: Click OK or Apply to save the settings.

1.3.3 Configuring object identification
Copy the following scripts to the Expert View in QTP and click Run.

Thisisto map the Appeon Web application objects with standard QTP objects. And it is
an "import once, use forever" operation. Y ou just need to copy the following scriptsto
your QTP Expert View for the very first time when you begin to record Appeon Web
applications.

Dim App ' As Application

DimintPosition

Set App = CreateCbject("QuickTest. Application")
App. Launch

App. Visible = True

' Configuration of Standard W ndows objects
"Cbject identification configuration for user-defined object "WnEdit"\
intPosition =
App. Opti ons. Obj ect I denti ficati on("WnEdit").Mandat oryProperties. Find("attached
text")
If intPosition <> -1 Then
App. Opti ons. Qbj ectldentification("WnEdit").Mandat oryProperties. Renove i ntPosition
End |f

'Cbject identification configuration for user-defined object "WnEditor"

Testing Appeon Web Applications (Web only) Page 5
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intPosition =

App. Opti ons. Obj ect I denti ficati on("W nEditor"). Mandat oryProperties. Fi nd("attached
text")

If intPosition <> -1 Then

App. Opti ons. Obj ectldentification("WnEditor").MndatoryProperties. Renove
i nt Position
End |f

'Cbject identification configuration for test object object "browser"
App. Opti ons. Obj ectldentification("browser"). Mandat oryProperties. RenoveAl | ()
App. Opti ons. Obj ectldentification("browser"). AssistiveProperties. RemoveAll ()
' Configuration of user-defined objects

' bj ect
App. Opti ons.
App. Opti ons.

identification configuration for user-defined object "eoncheckbox"
Obj ect I denti ficati on("W nCheckBox") . Creat eUser Def i nedObj ect (" eoncheckbox")
oj ectldentification("eoncheckbox").Odinalldentifier = "location"

App. Opt i
App. Opti
App. Opt i
App. Opti

oj ectldentification("eoncheckbox").
oj ectldentification("eoncheckbox").
oj ectldentification("eoncheckbox").
oj ectldentification("eoncheckbox").

ons.
ons.
ons.
ons.

Mandat or yPr operti es
Assi stiveProperties
Mandat or yPr operti es
Assi stiveProperties

. RemoveAl | ()

. RemoveAl | ()

. Add("nativecl ass")
. Add("w ndow

id")
' App. Options. Obj ectldentification("eoncheckbox"). Assi stiveProperties. Add("x")
' App. Opti ons. Obj ectl dentification("eoncheckbox"). Assi stiveProperties. Add("y")
App. Opti ons. Obj ectl dentification("eoncheckbox").Enabl eSmart| dentification Fal se
App. Opti ons. Qbj ectldentification("eoncheckbox").BaseFilterProperties. RenoveAll ()
App. Opti ons. Obj ect I dentification("eoncheckbox"). Optional FilterProperties. RenoveAll ()

' bj ect

App. Opti

App. Opti

App. Opti

App. Opti

App. Opti

App. Opti
id")

' App. Opti ons. Obj ectldentification("eoncndbutton"). Assi stiveProperties. Add("x")

' App. Options. Obj ectldentification("eoncndbutton"). Assi stiveProperties. Add("y")

App. Opti ons. Ooj ect I denti fi cati on("eoncndbutton"). Enabl eSmart|dentification Fal se

App. Opti ons. Qbj ectl dentification("eoncndbutton"). BaseFilterProperties. RenoveAll ()

App. Opti ons. Obj ectl dentification("eoncndbutton"). Optional FilterProperties. RenoveAll ()

' (bj ect
App. Opt i
App. Opti

identification configuration for user-defined object "eoncndbutton”

ons. oj ectldentification("WnButton").CreateUserDefi nedCbj ect ("eoncndbutton")
ons. bj ectldentification("eoncndbutton").Ordinalldentifier = "location"

ons. Cbj ectldentification("eoncndbutton"). Mandat oryProperties. RenoveAl | ()

ons. Cbj ectldentification("eoncndbutton"). AssistiveProperties. RenoveAl |l ()

ons. bj ectldentification("eoncndbutton"). Mandat oryProperti es. Add("nati vecl ass")
ons. bj ectldentification("eoncndbutton"). Assi stiveProperties. Add("w ndow

identification configuration for user-defined object "eonconmbobox"
ons. oj ectldentification("WnConboBox"). Creat eUser Def i nedObj ect (" eonconbobox")
ons. oj ectldentification("eonconbobox").Ordinalldentifier = "location"

App. Opt i
App. Opt i
App. Opti
App. Opti

ons. bj ectldentification("eonconbobox").
ons. bj ectldentification("eonconbobox").
ons. bj ectldentification("eonconbobox").
ons. bj ectldentification("eonconbobox").

Mandat or yPr operti es
Assi stiveProperties
Mandat or yPr operti es
Assi stiveProperties

. RemoveAl | ()

. RemoveAl | ()

. Add("nativecl ass")
. Add("w ndow

id")

' App. Opti ons. Obj ectldentification("eonconbobox"). Assi stiveProperties. Add("x")

' App. Opti ons. Obj ectl dentification("eonconbobox"). Assi stiveProperties. Add("y")

App. Opti ons. Obj ectl dentification("eonconbobox"). Enabl eSmart| dentification Fal se

App. Opti ons. Qbj ectl dentification("eonconbobox"). BaseFilterProperties. RenoveAll ()

App. Opti ons. Obj ectl dentification("eonconbobox"). Optional FilterProperties. RenoveAll ()

'"Cbject identification configuration for user-defined object "eondataw ndow'

App. Opti ons. Qbj ectldentification("WnGObject").CreateUser Defi nedObj ect ("eondat awi ndow')

App. Opti ons. Obj ect |l dentification("eondataw ndow'). Ordi nal Identifier = "l ocation"

App. Opti ons. Qbj ectl dentification("eondataw ndow'). Mandat or yProperti es. RenoveAl | ()

App. Opti ons. Obj ectl dentification("eondataw ndow'). Assi stiveProperties. RenoveAll ()

App. Opti ons. Ooj ect | denti fi cati on("eondat awi ndow') . Mandat or yProperti es. Add("nati vecl ass")

App. Opti ons. Obj ectl dentification("eondataw ndow'). Assi stiveProperties. Add("w ndow
id")
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' App. Opti ons. Obj ectl dentification("eondataw ndow'). Assi stiveProperties. Add("x")
" App. Opti ons. Obj ectldentification("eondataw ndow'). AssistiveProperties. Add("y")

App. Opt i
App. Opti
App. Opti

' (bj ect
App. Opti
App. Opti
App. Opti
App. Opti
App. Opti
App. Opti

ons. bj ectldentification("eondatawi ndow'). Enabl eSnart|dentification

Fal se

ons. Cbj ectl dentification("eondataw ndow') . BaseFi|terProperties. RenoveAl |l ()
ons. bj ectldentification("eondataw ndow'). Optional FilterProperties. RemoveAll ()

identification configuration for
Obj ect I denti ficati on("W nCal endar") . Creat eUser Def i nedObj ect (" eondat epi cker")
oj ectldentification("eondatepicker").Odinalldentifier = "location"

ons.
ons.
ons.
ons.
ons.
ons.

Obj ect I denti ficati on("eondat epi cker").
Obj ect I denti ficati on("eondat epi cker").
Obj ect I denti ficati on("eondat epi cker").
Obj ect I denti ficati on("eondat epi cker").

user - def i ned obj ect

Mandat or yPr operti es
Assi stiveProperties
Mandat or yPr operti es
Assi stiveProperties

"eondat epi cker"

. RemoveAl | ()

. RemoveAl | ()

. Add("nativecl ass")
. Add("w ndow

id")
' App. Options. Obj ectl dentification("eondatepicker"). AssistiveProperties. Add("x")
' App. Options. Obj ectl dentification("eondatepicker"). AssistiveProperties. Add("y")
App. Opti ons. Qbj ectldentification("eondatepicker").Enabl eSmartldentification Fal se
App. Opti ons. Obj ectl dentification("eondatepicker").BaseFilterProperties. RemoveAl |l ()
App. Opti ons. Qbj ectl dentification("eondatepicker").Optional FilterProperties. RemoveAll ()

' (bj ect
App. Opti
App. Opti
App. Opti
App. Opti

identification configuration for user-defined object "eondwedit"

ons. j ectldentification("WnEditor").CreateUserDefi nedCbj ect ("eondwedit")
ons. j ectldentification("eondwedit").Ordinalldentifier = "location"

ons. bj ectldentification("eondwedit"). Mandat oryProperti es. RenoveAl | ()

ons. bj ectldentification("eondwedit"). AssistiveProperties. RenoveAll ()

App. Opti ons. Obj ectl dentification("eondwedit").Mandat oryProperties. Add("nativecl ass")
App. Opti ons. Obj ectldentification("eondwedit"). AssistiveProperties. Add("w ndow id")
" App. Options. Obj ectldentification("eondwedit"). AssistiveProperties.Add("x")

" App. Opti ons. Obj ectldentification("eondwedit"). AssistiveProperties.Add("y")

App. Opti ons. Obj ectldentification("eondwedit"). Enabl eSmart|dentification Fal se
App. Opti ons. Qbj ectldentification("eondwedit").BaseFilterProperties. RenoveAll ()
App. Opti ons. Obj ectldentification("eondwedit"). Optional FilterProperties. RemoveAll ()

' bj ect
App. Qpt i
App. Opti

identification configuration for user-defined object "eondweditnask"
ons. Cbj ectldentification("WnEditor"). CreateUserDefi nedCbj ect (" eondwedi t mask")
ons. j ectldentification("eondweditmask"). Ordinal ldentifier = "location"

App. Opt i
App. Opt i
App. Opt i
App. Opt i
id")

ons.
ons.
ons.
ons.

oj ectldentification("eondweditnmask").
oj ectldentification("eondweditnmask").
oj ectldentification("eondweditnmask").
oj ectldentification("eondweditnmask").

Mandat or yPr operti es
Assi stiveProperties
Mandat or yPr operti es
Assi stiveProperties

. RemoveAl | ()

. RemoveAl | ()

. Add("nativecl ass")
. Add("w ndow

' App. Options. Obj ectldentification("eondweditmask"). AssistiveProperties. Add("x")

" App. Options. Obj ectl dentification("eondweditmask"). AssistiveProperties. Add("y")

App. Opti ons. Qbj ectldentification("eondweditnask").Enabl eSmartldentification Fal se
App. Opti ons. Obj ectl dentification("eondweditnmask").BaseFilterProperties. RenmoveAl |l ()
App. Opti ons. Qbj ectl dentification("eondweditnask"). Optional FilterProperties. RemoveAll ()

user - defi ned obj ect "eondw i st box"

' bj ect
App. Opti
App. Opti
App. Opti
App. Opti
App. Opti
App. Opti

identification configuration for
Obj ect I denti fication("WnList").CreateUser Defi nedObj ect ("eondw i st box")
st box"). Ordi nal I dentifier = "l ocation"

ons.
ons.
ons.
ons.
ons.
ons.

Obj ect I dentification("eondw i
Obj ect I dentification("eondw i
Obj ect I denti fication("eondw i
Obj ect I denti fication("eondw i
Obj ect I dentification("eondw i

st box") .
st box").
st box").
st box").

Mandat or yPr operti es
Assi stiveProperties
Mandat or yPr operti es
Assi stiveProperties

. RemoveAl | ()

. RemoveAl | ()

. Add("nati vecl ass")
. Add("wi ndow

id")
' App. Opti ons. Obj ect I dentification("eondw
' App. Opti ons. Obj ectl dentification("eondw
App. Opti ons. Obj ectl dentification("eondw i
App. Opti ons. Obj ectl dentification("eondw i
App. Opti ons. Obj ectl dentification("eondw i

i stbox"). Assi stiveProperties. Add("x")

i stbox"). Assi stiveProperties. Add("y")

st box"). Enabl eSmart | dentification Fal se

st box"). BaseFi | t er Properti es. RenmoveAl | ()
stbox"). Optional FilterProperties. RemoveAll ()

'Cbject identification configuration for user-defined object "eondwstatic"
App. Opti ons. Qbj ectldentification("Static").CreateUserDefi nedCbj ect ("eondwstatic")
App. Opti ons. Qbj ectldentification("eondwstatic").Odinalldentifier = "location"
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. Obj ectldentification("eondwstatic").
. Obj ectldentification("eondwstatic").
. Obj ectldentification("eondwstatic").
. Obj ectldentification("eondwstatic").

Mandat or yPr operti es
Assi stiveProperties
Mandat or yPr operti es
Assi stiveProperties

. RemoveAl | ()

. RemoveAl | ()

. Add("nativecl ass")
. Add("w ndow

App. Opt i ons

App. Opt i ons

App. Opt i ons

App. Opt i ons
id")

' App. Options. Obj ectldentification("eondwstatic"). AssistiveProperties.Add("x")

' App. Options. Obj ectldentification("eondwstatic"). AssistiveProperties.Add("y")

App. Opti ons. Obj ectldentification("eondwstatic").Enabl eSmartldentification Fal se

App. Opti ons. Qbj ectldentification("eondwstatic").BaseFilterProperties. RenoveAll ()

App. Opti ons. Obj ectldentification("eondwstatic").Optional FilterProperties. RenoveAll ()

' (bj ect

App. Opti

App. Opti

App. Opti

App. Opti

App. Opti

App. Opti
id")

" App. Options. Obj ectldentification("eoneditnask"). AssistiveProperties. Add("x")

' App. Options. Obj ectldentification("eoneditnask"). AssistiveProperties. Add("y")

App. Opti ons. Obj ectl dentification("eoneditnmask").Enabl eSmart|dentification Fal se

App. Opti ons. Qbj ectldentification("eoneditnmask").BaseFilterProperties. RenoveAll ()

App. Opti ons. Obj ectl dentification("eoneditnmask"). Optional FilterProperties. RenoveAll ()

' (bj ect

App. Opt i
App. Opt i

identification configuration for user-defined object "eoneditmsk"

ons. Cbj ectldentification("WnEdit").CreateUserDefi nedObj ect ("eonedit mask")
ons. oj ectldentification("eoneditmsk").Odinalldentifier = "location"

ons. Cbj ectldentification("eoneditnask").Mandat oryProperties. RenoveAl | ()

ons. Cbj ectldentification("eoneditnask").AssistiveProperties. RenoveAll ()

ons. Cbj ectldentification("eoneditmask").Mandat oryProperties. Add("nati vecl ass")
ons. oj ectldentification("eoneditmask"). Assi stiveProperties. Add("w ndow

identification configuration for "eonhscrol | bar"
ons.

ons.

user - def i ned obj ect

oj ectldentification("eonhscrollbar").Odinalldentifier = "location"

oj ectldentification("WnScrollBar"). CreateUser Defi nedoj ect ("eonhscrol | bar")

App. Opt i
App. Opt i
App. Opt i
App. Opti

ons.
ons.
ons.
ons.

oj ectldentification("eonhscrollbar").
oj ectldentification("eonhscrollbar").
oj ectldentification("eonhscrollbar").
oj ectldentification("eonhscrollbar").

Mandat or yPr operti es
Assi stiveProperties
Mandat or yPr operti es
Assi stiveProperties

. RemoveAl | ()

. RemoveAl | ()

. Add("nativecl ass")
. Add("w ndow

id")
' App. Options. Obj ectl dentification("eonhscrollbar"). AssistiveProperties. Add("x")
" App. Options. Obj ectl dentification("eonhscrollbar"). AssistiveProperties. Add("y")
App. Opti ons. Qbj ectldentification("eonhscrollbar").Enabl eSmartldentification Fal se
App. Opti ons. Obj ectl dentification("eonhscrollbar").BaseFilterProperties. RenoveAl |l ()
App. Opti ons. Qbj ectldentification("eonhscrollbar").Optional FilterProperties. RemoveAll ()

' bj ect

App. Opti
App. Opti
App. Opti
App. Opti
App. Opti
App. Opti

id")

' App. Options. Obj ectldentification("eonl abel edit"). Assi stiveProperties. Add("x")
' App. Options. Obj ectldentification("eonl abel edit"). Assi stiveProperties. Add("y")

identification configuration for user-defined object "eonl abel edit"

ons. j ectldentification("WnEdit").CreateUserDefi nedObj ect ("eonl abel edit")
ons. bj ectldentification("eonl abeledit").Ordinalldentifier = "location"
ons. Cbj ectldentification("eonlabel edit"). Mandat oryProperties. RenoveAl | ()
ons. Cbj ectldentification("eonlabeledit").AssistiveProperties. RenoveAll ()
ons. bj ectldentification("eonl abel edit").Mandat oryProperti es. Add("nati vecl ass")
ons. bj ectldentification("eonl abeledit"). AssistiveProperties. Add("w ndow

App. Opti ons. Qbj ectl dentification("eonl abel edit"). Enabl eSmart|dentification = Fal se
App. Opti ons. Qbj ectldentification("eonl abel edit").BaseFilterProperties. RenoveAll ()
App. Opti ons. Obj ectl dentification("eonlabeledit").Optional FilterProperties. RenoveAll ()
'Cbject identification configuration for user-defined object "eonlistbox"

App. Opti ons. Qbj ectldentification("WnList").CreateUserDefi nedObj ect ("eonli stbox")
App. Opti ons. Obj ectldentification("eonlistbox").Odinalldentifier = "|ocation"

App. Opti ons. Qbj ectldentification("eonlistbox").MandatoryProperties. RenmoveAl |l ()

App. Opti ons. Obj ectldentification("eonlistbox"). AssistiveProperties. RenoveAll ()

App. Opti ons. Ooj ect | denti fi cation("eonlistbox").MandatoryProperties. Add("nativecl ass")
App. Opti ons. Qbj ectldentification("eonlistbox"). AssistiveProperties.Add("w ndow id")

" App. Options. Obj ectldentification("eonlistbox").AssistiveProperties.Add("x")

" App. Options. Obj ectldentification("eonlistbox").AssistiveProperties.Add("y")

App. Opti ons. Ooj ect I denti fication("eonlistbox").Enabl eSmartldentification Fal se
App. Opti ons. Obj ectl dentification("eonlistbox").BaseFilterProperties. RenoveAll ()
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App. Opti ons. Qbj ectldentification("eonlistbox").Optional FilterProperties.RemoveAll ()
'Cbject identification configuration for user-defined object "eonlistview'
App. Opti ons. Qbj ectldentification("WnListView').CreateUserDefi nedObj ect ("eonlistview')
App. Opti ons. Obj ectldentification("eonlistview').Odinalldentifier = "location"
App. Opti ons. Obj ectldentification("eonlistview').MandatoryProperties. RenoveAl |l ()
App. Opti ons. Obj ectldentification("eonlistview'). AssistiveProperties. RenoveAll ()
App. Opti ons. Ooj ect I denti fication("eonlistview').MandatoryProperties. Add("nati vecl ass")
App. Opti ons. Obj ectl dentification("eonlistview'). AssistiveProperties. Add("w ndow

id")

" App. Opti ons. Obj ectl dentification("eonl
" App. Opti ons. Obj ectl dentification("eonl
ons.
ons.
ons.

App. Qpt i
App. Opti
App. Opti

' bj ect
App. Opti
App. Opti
App. Opti
App. Opti
App. Opti
App. Opti
id")

identification configuration for
ons.
ons.
ons.
ons.
ons.
ons.

Obj ect I denti ficati on("eonl
Obj ect I denti ficati on("eonl
Obj ect I denti ficati on("eonl

user - def i ned obj ect

i stview'). Assi stiveProperties. Add("x")
i stview'). AssistiveProperties. Add("y")
stview'). Enabl eSmart | denti fication
stview') . BaseFi | terProperties. RemoveAl | ()

stview'). Optional FilterProperties. RemoveAll ()

Fal se

"eonnont hcal endar"

Obj ect I denti ficati on("W nCal endar") . Creat eUser Def i nedObj ect (" eonnont hcal endar ")
oj ectldentification("eonnonthcal endar"). Ordinalldentifier = "location"

Ooj ectl dentification("eonnont hcal endar").
Ooj ectl dentification("eonnont hcal endar").
Ooj ectl dentification("eonnont hcal endar").
Ooj ectl dentification("eonnont hcal endar").

Mandat or yPr operti es
Assi stiveProperties
Mandat or yPr operti es
Assi stiveProperties

. RemoveAl | ()

. RemoveAl | ()

. Add("nati vecl ass")
. Add("wi ndow

' App. Options. Obj ectldentification("eonnonthcal endar"). Assi stiveProperties. Add("x")
" App. Options. Obj ectldentification("eonnonthcal endar"). Assi stiveProperties. Add("y")

App. Opti ons. Qbj ectl dentification("eonnont hcal endar"). Enabl eSmart| dentification =
Fal se
App. Opti ons. Obj ectl dentification("eonnont hcal endar"). BaseFilterProperties. RenoveAll ()
App. Opti ons. Qbj ectl dentification("eonnont hcal endar"). Optional FilterProperties. RenoveAl |l ()
'Cbject identification configuration for user-defined object "eonmultilineedit"
App. Opti ons. Qbj ectldentification("WnEditor").CreateUserDefi nedObject ("eonmultilineedit")
App. Opti ons. Obj ectldentification("eonmultilineedit").Odinalldentifier = "location"
App. Opti ons. Qoj ect I dentification("eonnultilineedit"). MandatoryProperties. RenoveAl |l ()
App. Opti ons. Obj ectldentification("eonmultilineedit").AssistiveProperties. RenoveAll ()
App. Opti ons. Ooj ectl dentification("eonnultilineedit").MandatoryProperties. Add("nativecl ass")
App. Opti ons. Obj ectldentification("eonnmultilineedit"). AssistiveProperties. Add("w ndow
id")

' App. Opti ons. Obj ectldentification("eonnultil
' App. Opti ons. Obj ectldentification("eonnultil
App. Opti ons. Obj ectldentification("eonmultili
Fal se
App. Opti
App. Opti

' bj ect

App. Opti

App. Opti

App. Opti

App. Opti

App. Opti

App. Opti
id")

' App. Options. Obj ectl dentification("eonpicbutton"). AssistiveProperties. Add("x")

' App. Options. Obj ectl dentification("eonpicbutton"). AssistiveProperties.Add("y")

App. Opti ons. Obj ect I dentification("eonpicbutton").Enabl eSnmartldentification Fal se

App. Opti ons. Qbj ectldentification("eonpicbutton").BaseFilterProperties. RenoveAll ()

App. Opti ons. Obj ectl dentification("eonpicbutton"). Optional FilterProperties. RenoveAll ()

ineedit").AssistiveProperties. Add("x")
ineedit").AssistiveProperties. Add("y")
needi t"). Enabl eSnart | dentification

ons. Cbj ectldentification("eonmultilineedit").BaseFilterProperties. RenmoveAll ()
ons. Cbj ectldentification("eonmultilineedit").Optional FilterProperties.RenoveAll ()

identification configuration for user-defined object "eonpicbutton”

ons. Cbj ectldentification("WnButton"). CreateUserDefi nedCbj ect ("eonpi cbutton")
ons. bj ectldentification("eonpicbutton").Ordinalldentifier = "location"

ons. Cbj ectldentification("eonpicbutton"). Mandat oryProperties. RenoveAl | ()

ons. bj ectldentification("eonpi cbutton"). AssistiveProperties. RenoveAll ()

ons. bj ectldentification("eonpichutton").Mandat oryProperti es. Add("nati vecl ass")
ons. bj ectldentification("eonpichutton"). AssistiveProperties. Add("w ndow

'Cbject identification configuration for user-defined object "eonpi cconbobox"

App. Opti ons. Qbj ectldentification("WnConboBox") . Creat eUser Def i nedObj ect (" eonpi ccombobox")
App. Opti ons. Qbj ectl dentification("eonpi ccombobox"). Ordinalldentifier = "location"

App. Opti ons. Obj ect |l dentification("eonpi ccombobox"). Mandat oryProperties. RenmoveAl | ()
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App. Opti ons. Obj ect |l dentification("eonpi ccombobox"). Assi stiveProperties. RenmoveAl |l ()
App. Opti ons. Qbj ectldentification("eonpi ccombobox"). Mandat oryProperties. Add("nativecl ass")
App. Opti ons. Qbj ectl dentification("eonpi ccombobox"). Assi stiveProperties. Add("w ndow
i dll)
' App. Options. Obj ectldentification("eonpi cconbobox"). Assi stiveProperties. Add("x")
' App. Opti ons. Obj ectldentification("eonpi cconbobox"). Assi stiveProperties. Add("y")

App. Opti ons. Obj ectl dentification("eonpi cconmbobox"). Enabl eSnartldentification =

Fal se
App. Opti ons. Qbj ectl dentification("eonpi ccombobox"). BaseFilterProperties. RemoveAll ()
App. Opti ons. Obj ectl dentification("eonpi ccombobox"). Optional FilterProperties. RemoveAll ()
'Cbject identification configuration for user-defined object "eonpiclistbox"
App. Opti ons. Qbj ectldentification("WnList").CreateUserDefinedObj ect ("eonpi clistbox")
App. Opti ons. Obj ectl dentification("eonpiclistbox").Odinalldentifier = "location"
App. Opti ons. Qbj ectldentification("eonpiclistbox").MandatoryProperties. RenoveAll ()
App. Opti ons. Qbj ectldentification("eonpiclistbox").AssistiveProperties. RenoveAll ()
App. Opti ons. Obj ectl dentification("eonpiclistbox").MandatoryProperties. Add("nati vecl ass")
App. Opti ons. Qbj ectl dentification("eonpiclistbox").AssistiveProperties.Add("w ndow

id")

" App. Options. Obj ectl dentification("eonpiclistbox").AssistiveProperties. Add("x")

" App. Options. Obj ectl dentification("eonpiclistbox").AssistiveProperties.Add("y")

App. Opti ons. Ooj ect l denti fi cati on("eonpiclistbox").Enabl eSmart!dentification Fal se
App. Opti ons. Obj ectl dentification("eonpiclistbox").BaseFilterProperties. RenmoveAll ()
App. Opti ons. Obj ectldentification("eonpiclistbox").Optional FilterProperties.RemoveAll ()

' (bj ect
App. Opti
App. Opti
App. Opti
App. Opti
App. Opti
App. Opti
id")
' App. Options. Obj ectldentification("eonradi obutton"). AssistiveProperties. Add("x")
' App. Options. Obj ectldentification("eonradi obutton"). AssistiveProperties. Add("y")
App. Opti ons. Obj ectl dentification("eonradi obutton").Enabl eSnartldentification
Fal se
App. Opti
App. Opti

' (bj ect

App. Opt i
App. Opt i
App. Opt i
App. Opt i
App. Opt i
App. Opt i

id")

' App. Options. Obj ectldentification("eonrichedit"). AssistiveProperties.Add("x")
" App. Opti ons. Obj ectldentification("eonrichedit").AssistiveProperties. Add("y")

identification configuration for
ons. Cbj ectldentification("WnRad
ons. Cbj ectldentification("eonradi
ons. Cbj ectldentification("eonradi
ons. Cbj ectldentification("eonradi
ons. Cbj ectldentification("eonradi
ons. Cbj ectldentification("eonradi

user - defi ned obj ect "eonradi obutton"

oButton"). Creat eUser Def i nedObj ect (" eonr adi obutt on")
obutton").Ordinal Identifier = "location"

obutton"). Mandat or yProperti es. RemoveAl | ()
obutton"). Assi stiveProperties. RemoveAl | ()

obutton") . Mandat or yProperti es. Add("nati vecl ass")
obutton"). Assi sti veProperties. Add("w ndow

ons. Cbj ectl dentification("eonradi obutton"). BaseFilterProperties. RemoveAll ()
ons. bj ectldentification("eonradi obutton"). Optional FilterProperties. RenoveAll ()

identification configuration for user-defined object "eonrichedit"

ons. j ectldentification("WnEditor").CreateUserDefi nedObj ect ("eonrichedit")
ons. j ectldentification("eonrichedit").Odinalldentifier = "location"

ons. Cbj ectldentification("eonrichedit").Mandat oryProperties. RenoveAl | ()

ons. Cbj ectldentification("eonrichedit").AssistiveProperties. RenoveAll ()

ons. Cbj ectldentification("eonrichedit").Mandat oryProperties. Add("nativecl ass")
ons. bj ectldentification("eonrichedit"). AssistiveProperties. Add("w ndow

App. Opti ons. Qbj ectldentification("eonrichedit").EnableSmartldentification = Fal se
App. Opti ons. Qbj ectldentification("eonrichedit").BaseFilterProperties. RenoveAll ()
App. Opti ons. Obj ectldentification("eonrichedit").Optional FilterProperties. RenoveAll ()
'Obj ect identification configuration for user-defined object "eonsinglelineedit"
App. Opti ons. Obj ectldentification("WnEdit").CreateUserDefi nedObj ect ("eonsi ngl el ineedit")
App. Opti ons. Qbj ectldentification("eonsinglelineedit").Odinalldentifier =
"l ocati on"
App. Opti ons. Obj ectl dentification("eonsinglelineedit").MandatoryProperties. RenoveAll ()
App. Opti ons. Obj ectl dentification("eonsinglelineedit"). AssistiveProperties. RenoveAll ()
App. Opti ons. Obj ectldentification("eonsinglelineedit").MandatoryProperties. Add("nativecl ass")
App. Opti ons. Obj ectldentification("eonsinglelineedit"). AssistiveProperties.Add("w ndow
id")

' App. Options. Obj ectldentification("eonsinglelineedit"). AssistiveProperties. Add("x")
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' App. Options. Obj ectldentification("eonsinglelineedit"). AssistiveProperties.Add("y")
App. Opti ons. Qbj ectl dentification("eonsinglelineedit").Enabl eSmartldentification
Fal se
App. Opti
App. Opti

' (bj ect
App. Opti
App. Opti
App. Opti
App. Opti

ons. j ectldentification("eonsinglelineedit").BaseFilterProperties.RemoveAll ()

identification configuration for user-defined object "eonstatic"

ons. vjectldentification("Static").CreateUserDefi nedObj ect("eonstatic")
ons. vj ectldentification("eonstatic").Odinalldentifier = "location"

ons. bj ectldentification("eonstatic").Mandat oryProperties. RenoveAll ()

ons. vj ectldentification("eonstatic").AssistiveProperties. RenoveAll ()

App. Opti ons. Obj ectldentification("eonstatic").MandatoryProperties. Add("nativecl ass")
App. Opti ons. Obj ectldentification("eonstatic").AssistiveProperties. Add("w ndow id")
" App. Options. Obj ectldentification("eonstatic").AssistiveProperties.Add("x")

' App. Options. Obj ectldentification("eonstatic").AssistiveProperties.Add("y")

App. Opti ons. Obj ectldentification("eonstatic").Enabl eSmartl|dentification Fal se
App. Opti ons. Obj ectldentification("eonstatic").BaseFilterProperties. RenoveAll ()
App. Opti ons. Obj ectldentification("eonstatic").Optional FilterProperties. RenmoveAll ()

' bj ect
App. Opti
App. Opti
App. Opti
App. Opti

identification configuration for
ons. Cbj ectldentification("WnTab").
ons. oj ectldentification("eontab").
ons. oj ectldentification("eontab").
ons. oj ectldentification("eontab").
App. Opti ons. Qbj ectl dentification("eontab"). Mandat oryProperties. Add("nati vecl ass")
App. Opti ons. Obj ectl dentification("eontab").AssistiveProperties. Add("w ndow id")

' App. Options. Obj ectldentification("eontab"). AssistiveProperties. Add("x")

' App. Options. Obj ectldentification("eontab"). AssistiveProperties. Add("y")

App. Opti ons. Qbj ectl dentification("eontab").Enabl eSnartl|dentification Fal se

App. Opti ons. Obj ectldentification("eontab").BaseFilterProperties. RenoveAll ()

App. Opti ons. Obj ectldentification("eontab").Optional FilterProperties. RenoveAll ()

' (bj ect

App. Opti

App. Opti

App. Opti

App. Opti

App. Opti

App. Opti
id")

' App. Options. Obj ectldentification("eontreeview'). AssistiveProperties.Add("x")

' App. Options. Obj ectldentification("eontreeview'). AssistiveProperties.Add("y")

App. Opti ons. Obj ectldentification("eontreeview'). Enabl eSmart|dentification Fal se

App. Opti ons. Qbj ectldentification("eontreeview').BaseFilterProperties. RenoveAll ()

App. Opti ons. Ooj ect I denti fication("eontreeview').Optional FilterProperties. RenoveAll ()

' bj ect

App. Qpt i
App. Opt i

user - defi ned obj ect "eontab"

Cr eat eUser Def i nedObj ect (" eont ab™")
O dinalldentifier = "location"
Mandat or yPr operti es. RenoveAl | ()
Assi stiveProperties. RemoveAl | ()

identification configuration for user-defined object "eontreeview'

ons. Cbj ectldentification("WnTreeView').CreateUser Defi nedObj ect ("eontreevi ew')
ons. j ectldentification("eontreeview').Ordinalldentifier = "location"

ons. Cbj ectldentification("eontreeview').Mandat oryProperties. RenoveAl | ()

ons. Cbj ectldentification("eontreeview').AssistiveProperties. RenoveAll ()

ons. bj ectldentification("eontreeview').Mandat oryProperties. Add("nati vecl ass")
ons. bj ectldentification("eontreeview'). Assi stiveProperties. Add("w ndow

identification configuration for "eonvscrol | bar"
ons.

ons.

user - def i ned obj ect

oj ectldentification("eonvscrollbar").Odinalldentifier = "location"

ons. Cbj ectldentification("eonsinglelineedit").Optional FilterProperties. RemoveAll ()

oj ectldentification("WnScrollBar"). CreateUser Defi nedOoj ect ("eonvscrol | bar")

App. Qpt i
App. Opti
App. Opt i

ons.
ons.
ons.

oj ectldentification("eonvscrollbar").
oj ectldentification("eonvscrollbar").
oj ectldentification("eonvscrollbar").

Mandat or yPr operti es
Assi stiveProperties
Mandat or yPr operti es

. RemoveAl | ()
. RemoveAl | ()
. Add("nativecl ass")

oj ectldentification("eonvscrollbar"). AssistiveProperties. Add("w ndow

App. Opt i
id")

' App. Options. Obj ectldentification("eonvscrollbar"). AssistiveProperties. Add("x")

" App. Options. Obj ectl dentification("eonvscrollbar"). AssistiveProperties. Add("y")

App. Opti ons. Qbj ectldentification("eonvscrollbar").Enabl eSmartldentification Fal se

App. Opti ons. Obj ectldentification("eonvscrollbar").BaseFilterProperties. RemoveAl |l ()

App. Opti ons. Qbj ectldentification("eonvscrollbar").Optional FilterProperties. RemoveAll ()

ons.
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1.4 Considerations for Recording Web Applications

This section only highlights afew areas that you should pay special attention to when you
test Appeon Web applications with QTP. For step-by-step instructions on how to use QTP,
please refer to the QTP user guide.

1.4.1 Mouse scroll ball

QTP cannot record operations performed by using the mouse scroll ball, therefore avoid
using mouse scroll ball to scroll awindow when recording the application with QTP.

1.4.2 Keeping data consistent

Make sure that the data of running atest need to be the same data when the test is recorded,
otherwise it may cause run failures.

1.4.3 Recording TreeView DataWindow

The TreeView Datawindow is not a standard Windows TreeView in QTP, therefore when
clicking a TreeView node, its coordinates will be recorded by QTP.

1.4.4 Recording DatePicker

For the DatePicker control or controls of this type (time controls that use x and y coordinates
to recognize data), the date (year and month) to run atest need to be the same as the year and
month when the test is recorded.

1.4.5 Recording Menu

QTP may occasionally record a Menu as a ControlMenu which will cause run failures. When
this happens, you can record the operation again, and make sure that you do not click any
menu other than the one you intend to record.

Typically, to record a sub-menu, instead of clicking the menu, move the mouse over the
menu, for example DataWindows and then EditMask as shown in the figure below, until the
sub-menu you want to record appears, and then click the sub-menu.

Figure 1.7: Recording Menu
DataWindows | PowerScript  SQL  Standard Controls  Graphs  User Objects  N-

Dot Motation r |
EdithMask » DataWindow Edithask |
Events & Functions »
Performance »
Presentation Styles k
Retrieval »
Runtirme Medification »
Updating 3
Objects k
Runtirme Creation »
Query Mode 3
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1.5 Known Issues

This section lists the issues one may come across when testing Appeon Web applications
with QTP.

1.5.1 Failing to record operations on SDI windows in Internet Explorer 8.0

Description: No test script is generated while QTP 10.00 is recording operations on an SDI
window (main-type window opened by the PB Open function) in IE 8.0.

Cause: It is probably caused by the limited support of QTP 10.00 for IE 8.0.
Solution: Y ou can upgrade to QTP 11.00 to avoid this problem.

1.5.2 Generating scripts in an incorrect order
Description: The test scripts are generated in an incorrect order.
Cause: Thisis probably a QTP issue and happens occasionally.

Solution: When this happens, you can record the operation again and make sure that the
scripts are generated in the correct order; or you can manually change the scripts into the
correct order in the Expert View.

1.5.3 Failing to run tests
Description: Test failed to runin QTP, and errors like " Cannot identify the object ..." occur.

Cause A & Solution A: Thisis caused by the incorrect order in which the record is
generated. See Generating scripts in an incorrect order for details.

Cause B & Solution B: Data of running atest is not the same data when the test is recorded.
See Keeping data consistent.

1.6 Appendix

This section lists the default ID of several objects. They will be used to represent the object
in the Object Repository and the script. Y ou can refer to the following table and modify the
default ID in the Object Repository if you find it difficult to understand or remember them.

Control code Descri pti on
[ ATL: Eon000202] MDI W ndow
[ ATL: Eon000203] MDI W ndow wi th hel p status bar
[ ATL: Eon000204] Popup wi ndow
[ ATL: Eon000205] Response wi ndow
[ ATL: Eon000206] Chil d W ndow
[ ATL: Eon000038] User Obj ect
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2 Testing with LoadRunner

2.1 Overview

The HP LoadRunner is an automated performance and testing product for examining system
behaviors and performance. The HP LoadRunner can simulate hundreds or thousands

of concurrent users to put the application through the rigors of real-life user loads, while
collecting information from key infrastructure components (Web servers, database servers,
etc.). The results can then be analyzed in details, to explore the reasons for a particular
behavior.

2.2 General Limitations on Performance Testing
1. The Web/HTTP protocol is used;
2. Only Web applicationsin English can be tested with LoadRunner.

2.3 Testing Steps

To put it concisely, performing test of Appeon for PowerBuilder with the HTTP protocol in
the test mode is to compl ete the following steps:

1. Set the record parameters and record the scripts;

2. Change the constants of Session ID in the scriptsto variables;

w

. If testing the Update operation, you need to parameterize SQL statements (to avoid
deadlock of database tables when there are many concurrent access);

D

. Configure the Run-Time Settings;

ol

. Play back the scripts unless the tests succeed, otherwise return to 2), 3), 4);

[o2]

. Design and run the scenario according to the testing scheme.

2.3.1 Configuring AEM

1. Select the Test M ode as the run mode:
Navigate to AEM > Application > Client Features> Y ourApplicationName > Run
Mode > Test Mode, and then click Save.

2. Select the Debug M ode as the log generation mode:
Navigateto AEM > Server > Logging > Log M ode > Debug Mode, and then click Save.

After you play back scripts successfully in vugen.exe, change the Debug M ode back to
Standard Mode.
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2.3.2 Data Preparation (for update only)
Thisisrequired only when testing the Update operation.

To smulate large number of concurrent access of Update, sufficient records should be
prepared first.

Requirements in the modified table:

1. The Recording Numbers must meet the following condition:

In the table, the number of Records should be greater than the number of (Vusers +
1) times the number of Modified Record/Users (Number of Records > (Vusers+ 1) *
Number of Modified Record/Users).

For example, if there arel0 users concurrently accessing and conducting the Datawindow
Update 10r x 7c with the "use update” mode operation, the modified table must at |east
contain the following number of records: (10 + 1) * 10 = 110.

2. Theinitial value of the keyword "id" should be O (Thisisfor simplifying the code process
for the SQL statement parameterization in scripts).

2.3.3 Preparing Test Cases

Determine the scripts to be recorded and the actions to be executed in scripts.

2.3.4 Recording Scripts

1. Set therecord engine: Record script using earlier recording engine.
Select from File > Tools > Recor ding Options > Advanced.

Check the Record script using earlier recording engine checkbox below Recording
Engine, and then click OK as shown in the following figure.
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Figure 2.1: Recording Options

Recording Options

HTTF Properties: Advanced

E---G_eneral
- Recording Preferences
- HTTF Properties v Recard think-tirne Thinktime threshold: |0 3: T8

i~ Browser ;
i [” Beset contest for each action

Recaording Prosy =
5 I Full trace recording log
i Cormelation

¥ Save snapshot resources locally

| Generate web_req_find functions for page titles

u
I Add comment to script for HT TP errors while recording
I~ Suppart charset

{+

i

Recording Engine

¥ FRecord scnpt Lzing earlier recording engine
{ This engine will be used the next time you create a new ‘Web Yuser script I

Recording schemes

Headers... Content Tppes. .. Non-Resources... |

Hint;
Move the mouse over ang item to zee itz description.

Usge Defaultz | QK | Cancel Help

Restart the L oadRunner.

2. Set the protocol for recording: Web (HTTP/HTML).
Select from File> New.

In the New Virtual User window, select Web (HTTP/HTML), and then click OK as
shown in the following figure.
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Figure 2.2: New Virtual User

Mew ¥irtual User

2 x|

Select Protocal Tepe

&I All Pratocals

Sybase CtLib

Sybaze Dblib

Terminal Emulation [RTE]
Tuxedo B

Tuxedo ¥

im0 piceihd L
i war

=]

—'web [HTTFHTML]

browser and “Web zerver.

E mulation of communication between a

Ok,

Cancel

3. Set the Recording options.

Select from Tools > Recor ding Options.

In the window that appears, select General > Recording on the |eft, and then select the

URL -based scriptsradio button as shown in the following figure.
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Figure 2.3: Recording Options

Recording Options Iﬁ
-~ Genersl General: Recording
Recording
“ HTTP Praperties HTTP # HTML Level
o Browser
- Recarding Prosy ggg " HTML-bazed script |
i Advanced
‘.. Correlation
' URL-bazed script URL Advanced.. |
Hint:
towe the mouse ower any item to e itz deszcription.
Usge Defaultz | QK | Cancel Help

Click the URL Advanced button in the same window, and the Advanced URL window

appears.

Check all the checkboxes and click OK as shown in the following figure.
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Figure 2.4: Advanced URL

Advanced URL |
v Create concument groups for resources after therr source HTML page oK,
¥ Enable cache [do not suppress the IF-Modified-Since header) Cancel
¥ Clear cache before recording [Microsoft Internet E xplorer only]
v Usze web custom_request only Lozlisizule

— Hirt:

Move the mouse over any item to zee itz description.

4. Set the Advanced options.

Select from Tools > Recor ding Options.

In the window that appears, select HT TP Properties > Advanced on the left, and then
uncheck the Reset context for each action option, as shown in the following figure.
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Figure 2.5: Recording Options

Recording Options

HTTF Properties: Advanced

E---G_eneral

E - Recording Freferences

:"'I_;IT;P Properties W Recard think-time Think-time threshald: |0 E: eC
i Browser

‘- Recording Prasy I Beset context for each action

; wance I Full trace recording log
i Correlation

¥ Save snapshot resources locally
| Generate web_req_find functions for page titles
u
I Add comment to script for HT TP errors while recording
I~ Suppart charset
{+
i
Recording Engine

¥ Fecord script using earlier recarding engine
[ Thiz engire will be uzed the nest time you create a new Web Yuser sonpt |

Recording schemes

Headers... ‘ ‘ Content Tppes. .. Non-Resources...

Hint;
Move the mouse over ang item to zee itz description.

Usge Defaultz | QK | Cancel Help

Click the Header s button in the same window.

In the Header s window, select the Record headersin list from the dropdown list box,
and then check the Accept and the Accept-L anguage checkboxes, as shown in the
following figure.
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Figure 2.6: Headers

X

ak.

Header Lizt

[+

Accept

[ accept-Charset
[ Accept-Encading
Accepk-Language
[ accept-Ranges

Jage

O Ao

=

=

Canicel

Restore List

Uze Defaults

Hint:
Mowve the mousze over any item to zee itz descrphion.

Click the "+" sign to add two headers: pt and Pr otocolM ode, then select them in the
Header List, and then click OK as shown in the following figure.
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Figure2.7: Headers
Headers : |

@ Record headers in list j ak. I
Header List HFE Cancel
Cupgrade F_;'" “I
[Juser-agent A~ Restore List
D Vary ,f”f
Yia L= Usze Defaults
[¥]Protocolhiode

Hint:
Mowve the mousze over any item to zee itz descrphion.

2.3.5 Modifying Scripts
Parameterize scripts of SessionID:
1. Usethe keyword "servlet" to search in the scripts, and add the following scripts to the

line previous to the line where the second "servlet" appears, so as to capture the current
SessionID.

web_reg_save_param " Sessionl D',"LB=ID =", "RB=\r\n", LAST) ;
2. Search al the remaining "servlet" statements, and modify the parameters starting with
"Body=" in the following way:

Find the location of "session_id =", and replace the recorded value of SessionlD with the
character string "{ SessionlD}", for example,

Replace

- 318005152\ r\ n"

"session_id
with
"session_id = {SessionlD}\r\n"

The following block ({SessionlD} in"session id = {SessionID}\r\n") is an example after
changed.

web_cust om r equest (" appeon. webl i br ary. AXDi spat cher _6",
"URL=http://172.17. 1. 108: 8080/ servl et/ appeon. webl i br ary. AXDi spat cher",
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" Met hod=POST"

"Resour ce=1",

"Referer=",

"EncType=",

" Body="

"\ \ x1F\\ x8B\ \ x08\ \ xO0\ \ xOO0\ \ xOO0\ \ xOO0\ \ xOO\ \ xOO0\ \ xOB"
"G

"\\x16"

" b0a0l"

"\\ x06"

" pn

"\\ xOB\ \ x06"

" g

"\\ x06"

o

"\\ x06"

ngn

"\\ x06"

"

"\\ x06"

"gr

"\\ x06"

wqn

"\ \ x86\\ x00"

e

"\\ x86"

wy

"\\ x86"

"4t ™EHEHC

"\\ x90\\ xOC\ \ x14\\ x01\\ x01"

"1 fb"

"\ \ x00\ \ x00\ \ x12\\ x02"

" 148"

"\ \ x00\ \ x00\ \ x00"
-------------------- appeon data\r\n"
"Name = Kill Session\r\n"
"session_id = {SessionlD}\r\n"
-------------------- appeon data\r\n"
"y

"\ \ x00\ \ x00\ \ x00"

LAST) ;

2.3.5.1 Additional steps for the Update operation

For the Update operation, the script parameterization should meet the following three
requirements:

1. Parameterization of SessionlD (which has already been described in Modifying Scripts);

2. Parameterization of SQL statements (which will be described in Parameterization of
DatawWindow SQL statements and in Parameterization of Embedded SQL statements);

3. Add the Commit request to the end of each Update request, that is, move the Commit
request in the recorded scripts from end.c to action.c.

2.3.5.2 Parameterization of Datawindow SQL statements

1. Therecorded Datawindow SQL statements are as follows:

"UpDateSQ._1 = update \"PERF_TEST1\" set \"depid\" =
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1,\"code\" = '"nodifyl' ,\"nanme\" = 'nodifyl' ,\"born\" = "'2006-09-04
14:35:12.843"' ,\"age\" = 1,\"salary\" = 1 where \"id\" = O;update
\"PERF_TEST1\" set \"depid\" = 1,\"code\" = 'nodifyl ,\"name\" =
"modi fyl',\"born\" = '2006-09-04 14:35:12.843"' ,\"age\" =
1,\"salary\" = 1 where \"id\" = 1;update \"PERF_TEST1\" set
\"depid\" = 1,\"code\" = "'nodifyl' ,\"nane\" = 'nodi fyl' ,\"born\" =

' 2006- 09- 04 14:35:12.843',\"age\" = 1,\"salary\" = 1 where \"id\"
= 2;update \"PERF_TEST1\" set \"depid\" = 1,\"code\" =
"modi fyl' ,\"name\" = 'nodifyl' ,\"born\" = '2006-09-04

14:35:12.843"' ,\"age\" = 1,\"salary\" = 1 where \"id\" = 3;update
\"PERF_TEST1\" set \"depid\" = 1,\"code\" = 'nodifyl' ,6 \"nane\"

= "nodi fyl' ,\"born\" = '2006-09-04 14:35:12.843" ,\"age\" =
1,\"salary\" = 1 where \"id\" = 4;update \"PERF_TEST1\" set
\"depid\" = 1,\"code\" = "'nodifyl' ,\"nane\" = 'nodifyl' ,\"born\" =

' 2006- 09- 04 14:35:12.859',\"age\" = 1,\"salary\" = 1 where \"id\"
= 5;update \"PERF_TEST1\" set \"depi"

"d\" = 1,\"code\" = 'nodifyl',\"nane\" =

"modi fyl',\"born\" = '2006-09-04 14:35:12.859',\"age\" =
1,\"salary\" = 1 where \"id\" = 6; update \"PERF_TEST1\" set
\"depid\" = 1,\"code\" = 'nodifyl' ,\"nane\" = 'nodi fyl' ,\"born\" =

' 2006- 09- 04 14:35:12.859',\"age\" = 1,\"salary\" = 1 where \"id\"
= 7;update \"PERF_TEST1\" set \"depid\" = 1,\"code\" =
"modi fyl' ,\"name\" = 'nodifyl' ,\"born\" = '2006-09-04

14:35:12.859' ,\"age\" = 1,\"salary\" = 1 where \"id\" = 8;update
\"PERF_TEST1\" set \"depid\" = 1,\"code\" = 'nodifyl ,\"name\" =
"modi fyl',\"born\" = '2006-09-04 14:35:12.859',\"age\" =

1,\"salary\" = 1 where \"id\" = 9\r\n"

a. To make the field value change every time the same user executesiit, you need to
parameterize the constant after the field: "modify1” in the above example.

b. To ensure that different virtual users modify different records, you need to parameterize
the id value after the "Where" keyword.
For these purposes, at least two parameters should be set: "Modified" and "I1D".

To parameterize fields of the number type and the data type, it is also necessary to set the
new parameters.

In this example, the type of parameter "Modified" isiteration number, and the type of
parameter "id" is UserID.

2. Inthe scripts, for most field values, you must perform the following two replacementsin
the Datawindow SQL statements.

a. Replace "modify1" with "{modified}"
b. Replace "where\"id\" =" (Note: In this example, the |ast character included in the

guotation mark must be a space) with "where\"id\" = {id}"

If the text to be replaced is split and displayed in two lines, for example, "modifyl" is
displayed as "modif" and "y1" in two separated lines, you need to manually modify or
programmatically replace it, otherwise transaction failures will occur when there are many
concurrent user access.

Make sure that every SQL statement is correctly replaced.

........................ A\"col8\" = '{nodified}', \"col9\" = ' nodif"
"y1' ,)\"col 10\" = 'nmodifyl' where \"id\" = {id}06; ..ccoerrrmrr.....
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3. The parameterized SQL statements are as follows:

"UpDat eSQL_1 = update \"PERF_TEST1\" set \"depid\" = 1,\"code\" =
"{nodified}',\"nane\" = '{nodified}',\"born\" = '2006-09-04
11:25:12.859' ,\"age\" = 1,\"salary\" = 1 where \"id\" =
{id}O; update \"PERF_TEST1\" set \"depid\" = 1,\"code\" =
"{nodified}',\"nane\" = '{nodified}',\"born\" = '2006-09-04
11:25:12.859' ,\"age\" = 1,\"salary\" = 1 where \"id\" =
{id}1; update \"PERF_TEST1\" set \"depid\" = 1,\"code\" =
"{nodified}',\"nane\" = '{nodified}',\"born\" = '2006-09-04
11:25:12.859' ,\"age\" = 1,\"salary\" = 1 where \"id\" =
{id}2;update \"PERF_TEST1\" set \"depid\" = 1,\"code\" =
"{nodified}',\"nane\" = '{nodified}',\"born\" = '2006-09-04
11:25:12.875' ,\"age\" = 1,\"salary\" = 1 where \"id\" =
{id}3;update \"PERF_TEST1\" set \"depid\" = 1,\"code\" =
"{nodified}',\"nane\" = '{nodified}',\"born\" = '2006-09-04
11:25:12.875' ,\"age\" = 1,\"salary\" = 1 where \"id\" =
{id}4;update \"PERF_TEST1\" set \"depid\" = 1,\"code\" =
"{nodified}',\"nane\" = '{nodified}',\"born\" = '2006-09-04
11:25:12.875' ,\"age\" = 1,\"salary\" = 1 where \"id\" =
{id}5; update \"PERF_TEST1\" set \"depid\" = 1,\"code\" =
"{nodified}',\"nane\" = '{nodified}',\"born\" = '2006-09-04
11:25:12.875' ,\"age\" = 1,\"salary\" = 1 where \"id\" =
{id}6; update \"PERF_TEST1\" set \"depid\" = 1,\"code\" =
"{nodified}',\"nane\" = '{nodified}',\"born\" = '2006-09-04
11:25:12.875' ,\"age\" = 1,\"salary\" = 1 where \"id\" =
{id}7;update \"PERF_TEST1\" set \"depid\" = 1,\"code\" =
"{nodified}',\"nane\" = '{nodified}',\"born\" = '2006-09-04
11:25:12.890' ,\"age\" = 1,\"salary\" = 1 where \"id\" =
{id}8;update \"PERF_TEST1\" set \"depid\" = 1,\"code\" =
"{nodi fied}',\"nanme\" "{nodi fied}',\"born\" = "'2006-09-04
11: 25:12.890' ,\"age\" 1,\"salary\" = 1 where \"id\" = {id}o\r\n"

4. When playing back the scripts after replacement, the DataWindow SQL statements
executed are as follows:

UpDat eSQL_1 = update "PERF _TEST1" set "depid" = 1,"code" =
"modi fyl',"nane" = 'nodifyl',"born" = '2006-09-04
11: 25:12.859' ,"age" = 1,"salary" = 1 where "id" =
10; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fyl',"nane" = 'nodifyl',"born" = '2006-09-04
11: 25:12.859' ,"age" = 1,"salary" = 1 where "id" =
11; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fyl',"nane" = 'nodifyl',"born" = '2006-09-04
11: 25:12.859' ,"age" = 1,"salary" = 1 where "id" =
12; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fyl',"nane" = 'nodifyl',"born" = '2006-09-04
11: 25:12.875' ,"age" = 1,"salary" = 1 where "id" =
13; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fyl',"nane" = 'nodifyl',"born" = '2006-09-04
11: 25:12.875' ,"age" = 1,"salary" = 1 where "id" =
14; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fyl',"nane" = 'nodifyl',"born" = "'2006-09-04
11: 25:12.875' ,"age" = 1,"salary" = 1 where "id" =
15; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fyl',"nane" = 'nodifyl',"born" = '2006-09-04
11: 25:12.875' ,"age" = 1,"salary" = 1 where "id" =
16; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fyl',"nane" = 'nodifyl',"born" = '2006-09-04
11: 25:12.875' ,"age" = 1,"salary" = 1 where "id" =
17; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fyl',"nane" = 'nodifyl',"born" = "'2006-09-04
11: 25:12.890' ,"age" = 1,"salary" = 1 where "id" =
18; updat e "PERF_TEST1" set "depid" = 1,"code" =
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"nmodi fyl',"name" = 'nodifyl',"born" = '2006-09-04
11:25:12.890',"age" = 1,"salary" = 1 where "id" = 19

5. Intheiterative operations, the DataWindow SQL statements executed at the third time are
asfollows:

UpDat eSQL_1 = update "PERF_TEST1" set "depid" = 1,"code" =
"modi fy3', "nane" = 'nodify3',"born" = '2006-09-04
11: 25:12.859' ,"age" = 1,"salary" = 1 where "id" =
10; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fy3', "nane" = 'nodify3',"born" = '2006-09-04
11: 25:12.859' ,"age" = 1,"salary" = 1 where "id" =
11; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fy3', "nane" = 'nodify3',"born" = '2006-09-04
11: 25:12.859' ,"age" = 1,"salary" = 1 where "id" =
12; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fy3', "nane" = 'nodify3',"born" = '2006-09-04
11: 25:12.875' ,"age" = 1,"salary" = 1 where "id" =
13; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fy3', "nane" = 'nodify3',"born" = '2006-09-04
11: 25:12.875' ,"age" = 1,"salary" = 1 where "id" =
14; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fy3', "nane" = 'nodify3',"born" = '2006-09-04
11: 25:12.875' ,"age" = 1,"salary" = 1 where "id" =
15; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fy3', "nane" = 'nodify3',"born" = '2006-09-04
11: 25:12.875' ,"age" = 1,"salary" = 1 where "id" =
16; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fy3', "nane" = 'nodify3',"born" = '2006-09-04
11: 25:12.875' ,"age" = 1,"salary" = 1 where "id" =
17; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fy3', "nane" = 'nodify3',"born" = '2006-09-04
11: 25:12.890',"age" = 1,"salary" = 1 where "id" =
18; updat e "PERF_TEST1" set "depid" = 1,"code" =
"modi fy3', "nane" = 'nodify3',"born" = '2006-09-04
11:25:12.890',"age" = 1,"salary" = 1 where "id" = 19

In this way, the value changes every time the same user executes an Update operation.

2.3.5.3 Parameterization of Embedded SQL statements

To parameterize the value in the embedded SQL statement, you will have to define the value
asavariable.

For example, the following script cannot be parameterized.

select a fromtable where ¢c = ‘1" ;

Y ou will have to modify the script as below, in order to parameterize the value:

int ic
ic =1
select a fromtable where c= :ic

2.3.6 Playing back scripts to test the correctness of scripts

Before playing back the scripts, set as follows from the menu: Vuser > Run-time Settings >
Browser Emulation > Options > Check new resour ces when simulating browser cache =
Yes.
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Check thelog of AEM to seeif the log of recorded scriptsis the same as the log of playback
(SessionID values can be different), otherwise, go back to the previous step to check and
modify the scripts and settings again.

2.3.7 Setting Scenarios
1. Select from Tools> Create controller scenario;
2. Set the schedule of scenario according to your needs;

3. Configure the parameter settings for scenario:

Navigate to Browser Emulation, uncheck the Simulate browser cache and the Smulate
anew user each iteration checkboxes, and then check the Download non-HTML
resour ces checkbox, as shown in the following figure.

Click OK.

Figure 2.8: Run-times Settings
Runtimesetings @

F'au:ingl Log I T hirk: Timel Progy  Browser Emulation | F'referenu:esl Netwu:urkl EnntentEheckI 1 I "I

Browser properties

Ig,ﬁ |lzer-&gent [browser to be emulated]:

Mozillas4.0 [compatible; MSIE B.0; YWindows HT 5.0]

[ Simulate browser cache
¥ [Diownload non-HTHML resources

[ Simulate a new uzer each iteration

Advanced
% Set browszer advanced options Optionsz.... |
Hint:

M ove the mouge over any item to zee itz description.

[k Cancel Usze Defaultz Help

2.3.7.1 Additional steps for the Update operation

Set the Update operation being committed when 10 virtual users access concurrently. Make
sure that the IDs of virtual users are the successive integers starting from 1, for example,
1~10, and keep running for 5 minutes.
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When you run the scenario, ensure that it runs correctly without any error or error messages
inthe AEM log, and check the corresponding tables in the database and make sure the values
of records (id 10-109) have been changed.

2.3.8 Running Scenarios

Select to run the scenario and the test report will be generated.
2.4 Troubleshooting

2.4.1"The session does not exist" error

Phenomena: The scripts run correctly right after they are recorded and modified, but after
awhile or after the server is restarted, the following error messages appear in the log of
Appeon when playing back the scripts:

1150101302078: 0 [ 06-06-12 16: 35: 02. 078]

[ com appeon. server. services.control |l er. JRouterlnpl (call())] The
session does not exist.”

Solution: Check and make sure that the Reset context for each action option is unchecked
as shown in the following figure, and then record the scripts again.

In thisway, the scripts will remain usable even after the application server is restarted.

Figure 2.9: Recording Options
Recording Options [éy

HTTF Properties: Adwvanced

- General

- Recarding Preferences

E-"HTTP Fraperties v Record think-time ik -t - |0 3‘
;---Erowser £ Think-time threzhold: = sec

" Recording Prosy I Reset contest for each action

I Full trace recording lag

¥ Save snapshot resources lacally
I Generate web_req_find funchions for page tides
o
[ Add comment to script for HTTP errors while recarding
I Suppaort charset
{+
l“'“
Recording Engine

¥ Recaord script wzsing earlier recarding engine
[ Thiz engine will be uzed the next time you create a new Web Vuser script |

Recording schemes

Headers... Content Types. Naon-Fesources. .

Hint:
Move the mouse over any item to see its description.

Uze Defaults | 0k | Cancel Help
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2.4.2 Errors appear when playing back scripts with LoadRunner 8.0

Phenomena: The following error messages will appear in the AppeonServer.log or
AppeonError.log when the scripts are played back with LoadRunner 8.0:

1154707726562: 0 [ 06- 08- 04 09: 08: 46. 562]
[ com appeon. server. services.control l er.JRouterlnpl (call())] The
sessi on does not exi st.

Solution: Thisisaknown issue with LoadRunner 8.0.

Please upgrade LoadRunner 8.0 to alater version.

2.4.3 The value of sessionlID is null

Phenomena: If you use the following statements to debug the value of SessionID, the
Sessionl D value will be null in the Execution Log after the script is played back.

I r_out put _nessage(lr_eval _string("SessionlD------- >"));
I r_out put _nmessage(lr_eval string("{SessionlD}"));

Solution: The function (as follows)
web_reg_save_param " Sessionl D',"LB=ID =", "RB=\r\n", LAST) ;

to obtain Session 1D should be placed before the second HTTP request. Do not place it before
the first request.

web_cust om r equest (" AXDi spat cher. aspx_2", "URL=http://172.17.1.29/servl et/ AXD spa
tcher",
" Met hod=PCST",
"Resour ce=1",
"RecCont ent Type=t ext/ pl ai n",
"Referer=",
"Bi nary=1",
"EncType=",
" Body="
"\\ x1F\\ x8B\ \ x08\ \ x00\ \ x00\ \ xOO0\ \ xO0\ \ xOO0\ \ xOO\ \ xOB"
" gpf "
"\'\ xDO"
" cHd( "
"\\ x00\ \ xC2"
"
"\\ x86"
K
"\\ x86"
" n
"\\ x86"
"
"\\ x86"
ny n
"\\ x9D\ \ x02\ \ xE4\ \ xC5\ \ x03"

q
"\\ x05"

"p
"\\x17"

" ( "

"\\ x97\\ x03"
" dl'
"\\x17\\x03"
=
"\\x12\\x81"
II\ nn
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"\\ x8C\\ x0C'

" @

"\\ xCO\ \ x02\ \ xC4"

wpn

"\\ xO0CQ\\ x00\ \ x9D\ \ x84\ \ xA2\ \ xD6"
n o

"\\ x00\ \ x00\ \ x00"

LAST) ;

2.4.4 Error message appears in script playback

Phenomena: After recording, modifying, and playing back the scripts, the following
messages appear in the Execution log.

vuser_init.c(236): Error: No match found for the requested

paraneter "SessionlD'. If the data you want to save exceeds 256
bytes, use web_set max_htm _param|len to i ncrease the paraneter size
vuser_init.c(236): Error: The above "not found" error(s) may be

expl ai ned by header and body byte counts being 0 and 0, respectively.
Abort was called froman action

Solution: Thisis probably caused by the Web cache setting. If you will not test Web cache,
be sure to cancel the settings for simulating cache in the Run-time Settings, by selecting
from Vuser > Run-time Settings > Browser Emulation > Options > Check for newer
resour ces when simulating browser cache=Yes.

2.4.5 Error message in Appeon Log

Phenomena: After the script is played back, set the pacing>1 and play back the scripts again,
the following error messages appear in the AppeonServer log for AEM:

1154707726562: 0 [ 06- 08- 04 09: 08: 46. 562]

[ com appeon. server. services.control | er.JRouterlnmpl (call())]
The session does not exist.

1154707726593: 0 [ 06- 08- 04 09: 08: 46. 593]

[ com appeon. server. services.control |l er. JRouterlnmpl (call())]
The session does not exist.

1154707726625: 0 [ 06- 08- 04 09: 08: 46. 625]

[ com appeon. server. services.control |l er.JRouterlnmpl (call())]
The session does not exist.

1154707726687: 0 [ 06- 08-04 09: 08: 46. 687]

[ com appeon. server. services.control |l er.JRouterlnmpl (call())]
The session does not exist.

1154707726718: 0 [ 06- 08- 04 09: 08: 46. 718]

[ com appeon. server. services.control | er.JRouterlnmpl (call())]
The session does not exist.

Solution: Make sure that the Simulate a new user each iteration option for Run-time
Settingsis unchecked.

2.4.6 Failed to parameterize scripts

Phenomena: After the scripts are recorded, the plain text cannot be found in all
web_custom_request as shown below:

web_cust om r equest (" appeon. webl i br ary. AXDi spat cher 3",
"URL=http://172.17. 1. 29/ servl et/ appeon. webl i br ary. AXDi spat cher",
" Met hod=POST",
"Resour ce=1",
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"RecCont ent Type=t ext/ pl ai n",

"Referer=",

"Bi nary=1",

"EncType=",

" Body="

"\\ x1F\\ x8B\\ x08\ \ x00\ \ xO0\ \ xOO0\ \ xOO0\ \ xOO\ \ x00\ \ xOB"
Q'

"\\ x16"

"a
"\'\ xDO"
"e
"\'\ xBO"

"d0c0e0"

"\\ x07\\ xD3\ \ XE6\ \ xOC'

" g

"\\ x0Q\ \ xC6\ \ xOCQ\ \ x5C\ \ xC5\ \ xOC\ \ x85\ \ x0C"

ngn

"V XO0CQ \ xCO\ \ XOC\ \ x89\ \ XOC\ \ x5C\ \ xOC\ \ xFF\ \ x19\\ x19\\ x98\ \ x18"
nym

"\\x18"

ngn

"\\ x81"

e

"\\ x06\\ x1E\\ x06"

D AD

"\\ x06"

non

"\\ x06\ \ x10\ \ x90\ \ x00"

" h&"

"\\ x06\ \ x00\ \ XxE6\ \ x89"

" XB"

"\\ x00\ \ x00\ \ x00"

LAST) ;

Solution: Before running the scenario, make sure that you have selected Test Modein the
Run M ode settings of AEM and that you have set the log mode to Standard. Then the plain
text ("----m-mmmmmm e appeon data\r\n” "Name = Connect\r\n" "session_id = -1476559241\r
AN e appeon datalr\n" "P" "\\x00\\x00\\x00" ) will appear as shown below.

web_cust om r equest (" appeon. webl i brary. AXDi spat cher 3",
"URL=http://172.17. 1. 29/ servl et/ appeon. webl i br ary. AXDi spat cher",
" Met hod=POST",

"Resour ce=1",

"RecCont ent Type=t ext/ pl ai n",
"Referer=",

"Bi nary=1",

"EncType=",

" Body="

"\\ x1F\\ x8B\ \ x08\ \ x00\ \ xO0\ \ xOO\ \ xO0\ \ xOO0\ \ xOO\ \ xOB"
Q'

"\\x16"

"en

"\'\ xDO"

"e0d0a0g0c0"

"\\ x05"

" BK"

"\\ x06"

g

"\ XCF\ \ x90\ \ x81\ \ xAB\ \ x98\ \ xA1\\ x90"

"\ \ x87"
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"\\ x99"
wpn

"\\ x91\\ x81\\ x8B\ \ xE1"

e

"\\x03\\x13"

n g

"\\ x0B\ \ x03"

"\ x90\ \ xCO\ \ XxCD\ \ xCO\ \ xC3\ \ xCO\ \ xCB\ \ xCO\ \ xC7\ \ x00\ \ x02"
"R@

"\ \ xCQ\\ xC4\ \ x00\ \ x00"

"\ \ xCo"

" &D"

"\ \ x00\ \ x00\ \ x00"
lescscscscscscscscscs appeon data\r\n"
"Name = Connect\r\n"

"session_id = -1476559241\r\ n"
lescscscscscscscscscs appeon data\r\n"
"\ \ x00\ \ x00\ \ x00"

LAST) ;

2.4.7 Out of memory error and the application server shut down

Phenomena: On the Solaris platform, WebL ogic reports the out of memory error, and then
shuts down. Thisis because the physical memory of the server istoo low.

Solution: Increase the virtual memory of the server.
1. For Windows, set the virtual memory to 2G;

2. For Solaris, set the swap spaceto 2G.
The commands to set swap on Solaris are:

Wfile /beaswap
swap —a [/beaswap

To add new swap space, this command must be run every time a Solaris server is restarted.

2.4.8 Field values do not change after parameterization and playback

Phenomena A: The corresponding field values in the records do not change after the SQL
parameterization and script playback, when using SAP ASA/SQL Anywhere database.

Solution A:
Steps to reproduce:

1. Record in the Test Mode: DataWindow > Updating > Change Employee Salary
function.

"UpDateSQL_1 = update \"enpl oyee\" set \"salary\" = ? where \"enp_id\" =2.."

2. Intherecord scripts, create a new parameter "Salary” for the incremental change, and
parameterize the SQL statements, as shown below:

"UpDateSQL_1 = update \"enpl oyee\" set \"salary\" = {salary} where
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\"enp_id\" = 105...."
3. Play back the scripts.

Phenomena B: When open another URL, the value of salary in records such as\"emp_id\" =
105 are found unchanged.

Solution B: The connection parameters (DisableBind=1) should be set in PowerBuilder for
the SAP ASA/SQL Anywhere database, then deploy the application source code and record
the scripts again.

Connect Stri ng=" DSN=AppeonSanpl e; U D=dba; PWD=sql ' , Di sabl eBi nd=1

2.4.9 Runtime errors causing scenario failure

For the Appeon .NET version, after errors occur at runtime, the scenario cannot run correctly
as before.

Phenomena: The following errors are reported in the server log:

2006- 08-17 14:41:36.609 : Cbject reference not set to an instance of an object.
at Appeon. Server. Commands. Commi t Conmand. Execut e()

at Appeon. Server. Commands. Conmand. Const r uct AndExecut e( ConmandDat a comrandDat a)
at Appeon. Server. Servi ces. Control | er. JRout er | npl . Execut el nTransacti on
(ConmandDat a comrandDat a)

at Appeon. Server. Servi ces. Control | er. JRout er | npl . Execut eCommand

(Htt pResponse response, CommandDat a super Command, Sessi onAccesslnfo session)
at Appeon. Server. Servi ces. Control | er. JRouter | npl . Cal | (ConmandDat a

super Command, Htt pRequest request, HtpResponse response)

at Appeon. Server. Servi ces. Control | er. JRouter | npl. Call (I nt32

client Type, Object requestData, Hashtable clientContext)

LoadRunner will report the following error:

Actionl.c(190): Error: Page downl oad tineout (120 seconds) has expired.

Solution: Restart 1S, SQL Server, and LoadRunner.

Check the PowerBuilder source code and change autocommit=false to autocommit=true,
or move the Commit operation after the Retrieve operation, so as to ensure the commit
operation will be executed for every retrieval.

2.4.10 Transactions failed

Many transactionsin the test fail when there are large amount of concurrent access with
Update or Retrieve.

Phenomena: The script playback is successful in the Virtual User Generator, and the logs
in AEM report no errors. But the transaction fails when there are large amount of concurrent
access.

Solution: Move the Commit request after the Update request, that is, move the Commit
request in recorded scripts from end.c to action.c.

2.4.11 Unable to connect to remote servers

Phenomena: LoadRunner is not able to generate the scripts after recording and the following
error appearsin the log:
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(Service=) NOT PROXI ED! (REASON: Unable to connect to renote server: rc = -1, le =
0)

Solution: Go to Tools > Recor ding Options and look at the Port M apping.
Select Socket level and WinlNet level data for Capture level as shown in the following
figure.

Figure 2.10: Port Mapping
[ Recording Options ﬁw

Metwork: Port Mapping

- General
- Seript Capture level. | Socket level and WinlNet level data -] ‘
- Protocals -
- Recarding Metwork-level server address mappings for [l 1Dvs) -
Dat&a Fl:ulrrnat EHtenSan Server Fuort Service S5L
- Configuration
- Headers Chain @ @
- Body Chain ﬁ@
- Cookies Chain
- CJueny Stiing Chain 5 &
- Metwark, &
M Eort M apping l J
- HTTP Properes
& Advanced g
‘.. Correlation e

tew Entry Edit Entry Delete Entry Optionz. ..

Dezcription :
Select a gerver entry to enable/dizable or update.

Usge Defaultz | QK | Cancel | Help ‘
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