Manipulating the UFA Report

Opening or saving a UFA Report

You can open or save a UFA Report using the File menu in the UFA Report window.

  • To open an existing UFA Report, select the File > Open Report menu. The Open UFA Report dialog box is displayed. If there is no UFA report available, select New Analysis and click OK to analyze an application.

    Figure 52. Open UFA Report

    Open UFA Report

  • To save a UFA Report, select the File > Save menu.

  • To save a UFA Report with a new name, select the File > Save As menu.

Selecting report view mode

You can view the UFA Report in four different modes. Go to the View menu in the UFA Report window and select the desired mode:

  • Category: Enables you to view the unsupported features in the following categories: Unsupported Objects, Unsupported PowerScript, Unsupported Embedded SQL and Others.

  • Hierarchy: Enables you to view the unsupported features in hierarchical order: PBL, Object, Control, Method (Event/Function).

  • Priority: Enables you to view the unsupported features in priorities (you can go to the Tools > Define Priority menu to define the priorities of the PowerBuilder features): Have to modify, Suggest to modify, Can be ignored.

  • Summary: Enables you to view summary information of each unsupported feature.

You can set the default view mode in the Tools > Options menu. For detailed descriptions, refer to the section called “Customizing the general settings of the UFA Report”.

Searching for UFA Report items

To do a quick search, you can directly enter the text that you want to search in the search field of the UFA Report window. Or follow steps below to use the standard Find Text dialog box:

Step 1: Select the Edit > Find menu. Or right click in the unsupported feature list treeview and select Find.

Step 2: In the Find Text box, enter the text that you want to search.

Step 3: Select any other options that you want.

Step 4: Click Find Next.

Figure 53. Find Text

Find Text

Filtering UFA Report items

Filtering helps you restrict the number of the unsupported features displayed in the UFA Report and quickly find the target unsupported features, especially when there are a large number of unsupported features in the application.

You can filter the unsupported features by the objects they reside in, or by the feature types, or by the priorities.

Filtering by objects

Step 1: Select the Edit > Filter by Object menu. Or right click in the unsupported feature list treeview and select Filter by Object.

The Filter by Object dialog box is displayed, as shown in the following figure.

Figure 54. Filter by object

Filter by object

Step 2: Make sure that the unsupported objects you want to display in the report are on the right list box, whereas the unsupported objects you want to hide are on the left listbox. Click OK.

To quickly select all objects of the same type, right click the list and select an object type.

The UFA Report hides the unsupported objects that are on the left listbox in the Filter by Object window.

Filtering by categories

Step 1: Select the Edit > Filter by Category menu. Or right click in the unsupported feature list treeview and select Filter by Category.

The Filter by Category dialog box is displayed, as shown in the following figure.

Figure 55. Filter by Category

Filter by Category

Step 2: Make sure the categories of the unsupported features you want to display in the report are on the right listbox, whereas the categories of the unsupported features you want to hide are on the left listbox. Click OK.

The UFA Report hides unsupported features that belong to the categories that are on the left in the Filter by Category window.

Filtering by priorities

Step 1: Select the Edit > Filter by Priority menu. Or right click in the unsupported feature list treeview and select Filter by Priority.

The Filter by Priorities dialog box is displayed, as shown in the following figure.

Figure 56. Filter by Priority

Filter by Priority

Step 2: Uncheck the priorities of the unsupported features which you want to hide. For example, if you want to hide the features that can be ignored, uncheck the Can be ignored option.

Step 3: Click OK.

The UFA Report only displays unsupported features of the specified priorities.

Specifying report display level

You can quickly expand or collapse a node of the unsupported feature list treeview by selecting Expand Sub-node or Collapse Sub-node from the Edit menu or from the popup menu on any node.

You can also specify the display level using the following steps:

Step 1: Select the Edit > Display Level menu.

Step 2: In the Display Level box, enter the number of the level at which the unsupported feature list treeview will display.

Figure 57. Display Level

Display Level

Step 3: Click OK.

The UFA Report only displays unsupported features of the specified level.

Defining the priority settings of unsupported features

By default, Appeon divides all unsupported features into three priority levels:

  • Have to modify: The features flagged with Have to modify are important in the application and will cause significant functionality loss if they are not modified or worked around.

  • Suggest to modify: The features flagged with Suggest to modify will not necessarily cause functionality loss if they are not modified or worked around. You can decide whether to modify them according to their functionalities in the application.

  • Can be ignored: The features flagged with Can be ignored are small or trivial features which will not compromise application functionality even if they are not modified or worked around.

To customize or change priority levels for unsupported features, take the following steps:

Step 1: Select the Tools > Define Priority menu. The Define Priority window is displayed, as shown in the following figure.

Figure 58. Define Priority dialog box

Define Priority dialog box

Step 2: Add, modify or delete the system default priorities in the left Priority Level box.

Step 3: Change priority levels of unsupported feature types by selecting a priority level in the Priority Name column.

Step 4: Click Save to save the priority settings.

Click Reset to Default to restore the system default priority settings.

Customizing the general settings of the UFA Report

You can define your preference settings of the UFA Report window. These settings include default report view mode, display formats of PBLs, feature count, unsupported source code edition, and filtering. The new settings will be saved as the default settings.

Select the Tools > Options menu in the UFA Report window. The General Settings window is displayed, as shown in the following figure.

Figure 59. General Settings dialog box

General Settings dialog box

  • Default Report View group box: Select the default view mode of the UFA Report. For detailed description of each view mode, refer to the section called “Selecting report view mode”.

  • Display Full Path of PBL Files: Displays the full path and the file name of the PBLs in the UFA Report.

  • Display Unsupported Feature Count: Displays the total number of the unsupported features in the UFA Report.

  • Auto start PowerBuilder and load target application: Enables PowerBuilder to automatically start and load the target application when you click the Edit or Edit Source button in the UFA Report window.

  • Filter Previous Results: Allows you to filter only the results of a previous filter. It narrows a filter that resulted in too many data the first time. If you want to search all data of the report, leave this option as unselected.