Bug 6461

SubMenu Items shows with different line-height 21 November, 2021

Roland Plessing
21 April, 2021
Product: PowerBuilder Category: Controls & UI
Version: 2019 R3 Build: 2703
Classification: Appeon bug Publishing: Public
Priority: P3
Status: Verifying Reason:
Communication Status: Waiting for Customer
Mark Lee @Appeon 21 November, 2021
#12
Hi Roland,

I'm just touching base with you about this ticket.  
Did we provide you with enough information to resolve this issue?. 

Please let us know if there is something else to support you with.  
Remember that you can always open a new ticket if need it. 

Regards,
Mark Lee
Mark Lee @Appeon 04 November, 2021
#11
Hi Roland,

I would like to check with you if the response provided has been helpful enough to resolve your case. If so, can we proceed to close the ticket?. Otherwise, please let us know if we can provide you with any further assistance, remember that you can always open another ticket any time you need it. 

Regards,
Mark Lee
Mark Lee @Appeon 27 August, 2021
#10
Hi Roland,

Good news that PowerBuilder 2019 R3 MR (build 2728) is available for download. The issue you reported has been fixed in this release. Please download and install it to verify the issue you reported and let us know if any problems. You can get the installer from our Downloads portal at https://account.appeon.com/download/2019 (login required).

We welcome all feedback from you!

Regards,
Mark Lee
Mark Lee @Appeon 06 August, 2021
#9
Hi Roland,

Good news that PowerBuilder 2021 GA (build 1288) is available for download. The
issue you reported has been fixed in this release. Please download and install
it to verify the issue you reported and let us know if any problems. 
You can get the installer from our Downloads portal at
https://account.appeon.com/download (login required).

We welcome all feedback from you!

Regards,
Mark Lee
Mark Lee @Appeon 07 June, 2021
#8
Hi Roland,

Thanks for the confirmation!
Glad to hear that.

Regards,
Mark Lee
Roland Plessing 07 June, 2021
#7
(In reply to Mark Lee @Appeon from comment #6)
Hi Roland,

We haven't received any replies yet. 
We just want to make sure whether the fix we made resolves your problems or
there are some other issues.
Please give us your feedback, otherwise it might affect the release plan for
this issue.

Regards,
Mark Lee
Hi Mark, its work fine, thanks Regards, Roland Plessing
Mark Lee @Appeon 06 June, 2021
#6
Hi Roland,

We haven't received any replies yet. 
We just want to make sure whether the fix we made resolves your problems or there are some other issues.
Please give us your feedback, otherwise it might affect the release plan for this issue.

Regards,
Mark Lee
Mark Lee @Appeon 27 April, 2021
#5
new PBVM.DLL

Hi Roland,

The development team has fixed the issue regarding the Menu functionality.
Please replace the PBVM.DLL (default directory is: C:\Program Files (x86)\Appeon\Common\PowerBuilder\Runtime 19.2.0.2703) with this attached one.
Please back up your old file before replacing them.
After that please restart the computer and see if it works on your side.
 
BTW, we haven't fully tested this fix yet, so we suggest that you do some more Menu functionality-related tests to verify if there are other issues. 
Thanks!
 
 
Regards,
Mark Lee
Mark Lee @Appeon 24 April, 2021
#4
Hi Roland,

Thanks for providing the test case and screenshot!
I can reproduce it on our side and also confirm that it works in the early version.
We will escalate this problem to our development team for further analysis.
We will need some time to figure it out and will get back to you if any progress we would make.
 
 
Best regards,
Mark Lee
Roland Plessing 23 April, 2021
#3
Bug6461.zip (416KB)

In PB19 R2 Build 2328 is the height of the lines correct, all png shows with the correct size
Look at the 2 Hardcopy


After this Build the line height is small and the png shows incorrect

I send you all png-, pbl-, pbt-files
Mark Lee @Appeon 21 April, 2021
#2
Hi Roland,

Thanks for reporting this problem.
Please let us know the PB 2019 R2 build version you used before (such as PB 2019 R2 Build 2670).
 
From the screenshot you provided, it seems that the first menu is the same, while the second and third ones are different. And it is not easy for us to locate the root cause of it. Could you please provide a reproducible sample test case (with PBT/PBL) for us to reproduce it on our side? Thanks in advance.
 
 
Best regards,
Mark Lee
Roland Plessing 21 April, 2021
#1
ToolbarProblem_R3.pdf (867KB)

*Phenomenon:
the height of the lines in the menu is different since R3, it is correct in R2

*Reproduce Steps:


Remarks:
OS:
Windows 10
Platform:
32-bit
Database Type:
Microsoft SQL Server
Database Version:
2011