Bug 5014

PowerBuilder 2017 R3 IDE crashes when using debug 01 August, 2020

Michael Connell
31 July, 2020
Product: PowerBuilder Category: PowerBuilder IDE
Version: 2017 R3 Build: 1858
Classification: Publishing: Public
Priority: P2
Status: Analyzing Reason:
Govinda Lopez @Appeon 31 July, 2020
#2
Hi Michael,

Following are some things to consider that might help you get this problem solved:

1.- One of the reasons this might happen is that there could be a variable, in the debug watch, that might no longer exist (ie: a global object or function) which could cause this. Try removing all watch variables.

2.- Try doing a full build and optimize each library. You need to make sure that the folders and files are not write protected.

3.- Try opening PB with an admin account. See if that does any difference.

4.- If you migrated your app from previous versions of PB, make sure you also update to the correct version of the PFC's.

Please do let us know if these helped solve your problem.


Regards,
armando herrera @Appeon 31 July, 2020
#1
Hi Michael, 

Thank you very much for your report. We are working on it and we will get back to you after analyzing it.

Can you re-buit? 

We'll keep you posted here!

Regards!
Michael Connell 31 July, 2020
#0
*Phenomenon: IDE crashes when trying to debug our SIE / PetReg applications. The application does not start and PowerBuilder simply stops without a message.


*Reproduce Steps: Add a breakpoint to the pfc_open event of the application object. Click "Debug sie". Debugger window opens. Click "Start sie". PowerBuilder crashes.

Remarks: SIE / PetReg are critical applications for The Norwegian Petroleum Directorate. It is vital that this bug is fixed.
OS:
Windows 10
Platform:
64-bit
Database Type:
Oracle
Database Version:
11g