Bug 3884

documentation wrong with tooltip enabled values and wrong often with yes/no vs 1/0 values 15 January, 2020

mike S
15 January, 2020
Product: PowerBuilder Category: Documentation
Version: 2017 R3 Build:
Classification: Issue Publishing: Public
Priority: P4
Status: Fixing Reason:
Zhao Kai @Appeon 15 January, 2020
#2
Hi Mike,

The values yes/no only work in modify function and dot notation but not datawindow syntax. Thanks for pointing out the issue in this document. We had forward it to the Document Team for them to correct it.

Regards,
ZhaoKai
Chris Pollach @Appeon 15 January, 2020
#1
Hi Mike;

   Thank you for bringing this documentation issue to our attention. I will transfer this to the Documentation Team.

  BTW: Thanks a $1M for all your diligent PB2019R2 testing!

Regards ... Chris
mike S 15 January, 2020
#0
*Phenomenon:
docs say Yes is the enabled value for showing a tooltip.  It is not.  1 is.


*Reproduce Steps:

These two create statements will both create a text object.  The tooltip does NOT display with enabled = yes.  it does if it set to 1

create text(name=company_dot_company_addr1 text= "company_addr1" tooltip.enabled="Yes" tooltip.tip="company.company_addr1" band=header x="0" y="420" height="64" width="700" color="0" background.color="536870912" border="2" font.face="Calibri" font.height="-10" alignment="0" tag="")

create text(name=company_dot_company_addr1 text= "company_addr1" tooltip.enabled="1" tooltip.tip="company.company_addr1" band=header x="0" y="420" height="64" width="700" color="0" background.color="536870912" border="2" font.face="Calibri" font.height="-10" alignment="0" tag="")



Remarks:
OS:
All
Platform:
Database Type:
Database Version: